diff mbox series

[2/2] package/python-pysnmp: bump to version 7.1.3

Message ID 20240918002220.414668-2-james.hilliard1@gmail.com
State New
Headers show
Series [1/2] package/python-pysnmpcrypto: new package | expand

Commit Message

James Hilliard Sept. 18, 2024, 12:22 a.m. UTC
License hash changed due to date update:
https://github.com/lextudio/pysnmp/commit/fa9909cbbf9b25eb992a945715e2511a2ba2c905

Update license from BSD-3-Clause to BSD-2-Clause, the license
changed in 8122a1d85b6cc9f2adcb1243521c04ba4cae0510 but the commit
incorrectly indicated "no content changed" when updating the hash.

Add new python-pysnmpcrypto runtime dependency.

Drop no longer required python-pycryptodomex runtime dependency.

Migrate from setuptools to poetry build backend.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-pysnmp/Config.in          | 5 +++--
 package/python-pysnmp/python-pysnmp.hash | 6 +++---
 package/python-pysnmp/python-pysnmp.mk   | 9 +++++----
 3 files changed, 11 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/package/python-pysnmp/Config.in b/package/python-pysnmp/Config.in
index a034b16852..2abd3a86ad 100644
--- a/package/python-pysnmp/Config.in
+++ b/package/python-pysnmp/Config.in
@@ -1,8 +1,9 @@ 
 config BR2_PACKAGE_PYTHON_PYSNMP
 	bool "python-pysnmp"
-	select BR2_PACKAGE_PYTHON_PYSMI # runtime
-	select BR2_PACKAGE_PYTHON_PYCRYPTODOMEX # runtime
+	depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS # python-pysnmpcrypto -> python-cryptography
 	select BR2_PACKAGE_PYTHON_PYASN1 # runtime
+	select BR2_PACKAGE_PYTHON_PYSMI # runtime
+	select BR2_PACKAGE_PYTHON_PYSNMPCRYPTO # runtime
 	help
 	  PySNMP is a cross-platform, pure-Python SNMP engine
 	  implementation.
diff --git a/package/python-pysnmp/python-pysnmp.hash b/package/python-pysnmp/python-pysnmp.hash
index 3b0af1af62..9136d23a14 100644
--- a/package/python-pysnmp/python-pysnmp.hash
+++ b/package/python-pysnmp/python-pysnmp.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/pysnmp/json
-md5  2222880259daf6e2cb322e938c818276  pysnmp-4.4.12.tar.gz
-sha256  0c3dbef2f958caca96071fe5c19de43e9c1b0484ab02a0cf08b190bcee768ba9  pysnmp-4.4.12.tar.gz
+md5  527c09f53ea7c28963e55b4c4b483ec2  pysnmp-7.1.3.tar.gz
+sha256  29853e4daca82992ae8b1932a4e32e1ec9df8234905b6d594d43773bdc72c4b4  pysnmp-7.1.3.tar.gz
 # Locally computed sha256 checksums
-sha256  d0b2edd772164395320fc5ad7dfaa9806fa038fb29762b347c549891d7a79237  LICENSE.rst
+sha256  4954453957449b5e6f797d070f4d91024dceb3e056c99d72350795b71db0fc70  LICENSE.rst
diff --git a/package/python-pysnmp/python-pysnmp.mk b/package/python-pysnmp/python-pysnmp.mk
index 520ce2877a..5db86bc976 100644
--- a/package/python-pysnmp/python-pysnmp.mk
+++ b/package/python-pysnmp/python-pysnmp.mk
@@ -4,11 +4,12 @@ 
 #
 ################################################################################
 
-PYTHON_PYSNMP_VERSION = 4.4.12
+PYTHON_PYSNMP_VERSION = 7.1.3
 PYTHON_PYSNMP_SOURCE = pysnmp-$(PYTHON_PYSNMP_VERSION).tar.gz
-PYTHON_PYSNMP_SITE = https://files.pythonhosted.org/packages/4e/75/72f64c451bf5884715f84f8217b69b4025da0b67628d611cd14a5b7db217
-PYTHON_PYSNMP_SETUP_TYPE = setuptools
-PYTHON_PYSNMP_LICENSE = BSD-3-Clause
+PYTHON_PYSNMP_SITE = https://files.pythonhosted.org/packages/f3/0c/bb2ccb587b5e79036dd83aa5fe835c2bc460a3098c4060461e9d324c6670
+PYTHON_PYSNMP_SETUP_TYPE = pep517
+PYTHON_PYSNMP_LICENSE = BSD-2-Clause
 PYTHON_PYSNMP_LICENSE_FILES = LICENSE.rst
+PYTHON_PYSNMP_DEPENDENCIES = host-python-poetry-core
 
 $(eval $(python-package))