diff mbox series

[1/1] package/babeld: bump to version 1.13.1

Message ID 20240917201030.11583-1-dario.binacchi@amarulasolutions.com
State New
Headers show
Series [1/1] package/babeld: bump to version 1.13.1 | expand

Commit Message

Dario Binacchi Sept. 17, 2024, 8:10 p.m. UTC
- Implemented the per-interface option "probe-mtu", which automatically
  discards links with a mis-configured MTU.  Thanks to Daniel Gröber.
- Fixed a typo in the handing of the option "v4viav6".

Release notes:
https://github.com/jech/babeld/blob/master/CHANGES

Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
---
 .../0001-Fix-compilation-error-on-linux.patch | 36 +++++++++++++++++++
 package/babeld/babeld.hash                    |  2 +-
 package/babeld/babeld.mk                      |  2 +-
 3 files changed, 38 insertions(+), 2 deletions(-)
 create mode 100644 package/babeld/0001-Fix-compilation-error-on-linux.patch
diff mbox series

Patch

diff --git a/package/babeld/0001-Fix-compilation-error-on-linux.patch b/package/babeld/0001-Fix-compilation-error-on-linux.patch
new file mode 100644
index 000000000000..41ff834ecf12
--- /dev/null
+++ b/package/babeld/0001-Fix-compilation-error-on-linux.patch
@@ -0,0 +1,36 @@ 
+From a7f807349dcc3297473d8ddc031206b2912f7301 Mon Sep 17 00:00:00 2001
+From: Dario Binacchi <dario.binacchi@amarulasolutions.com>
+Date: Tue, 17 Sep 2024 21:48:01 +0200
+Subject: [PATCH] Fix compilation error on linux
+
+This patch fixes the following compilation error raised by the bump to
+version 1.13.1 in Buildroot:
+
+net.c: In function 'babel_send':
+net.c:199:27: error: 'IPV6_DONTFRAG' undeclared (first use in this function)
+  199 |         cmsg->cmsg_type = IPV6_DONTFRAG;;
+
+Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
+Upstream: https://github.com/jech/babeld/pull/121
+---
+ net.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/net.c b/net.c
+index 7a7b57844e6c..822112299fd8 100644
+--- a/net.c
++++ b/net.c
+@@ -37,6 +37,10 @@ THE SOFTWARE.
+ #include <arpa/inet.h>
+ #include <errno.h>
+ 
++#if defined(__linux)
++#include <linux/in6.h>
++#endif
++
+ #include "babeld.h"
+ #include "util.h"
+ #include "net.h"
+-- 
+2.43.0
+
diff --git a/package/babeld/babeld.hash b/package/babeld/babeld.hash
index 3eb5d2208153..ab2ffc6ef811 100644
--- a/package/babeld/babeld.hash
+++ b/package/babeld/babeld.hash
@@ -1,3 +1,3 @@ 
 # Locally computed
-sha256  d085ccccfb06a11d7fa5b54c51d9c410f5f3b0a9389f584951336ff178f293b8  babeld-1.13.tar.gz
+sha256  15f24d26da0ccfc073abcdef0309f281e4684f2aa71126f826572c4c845e8dd9  babeld-1.13.1.tar.gz
 sha256  b415c41292cedef6c97b243609e50552887c29343566c639f23282d31efd2afd  LICENCE
diff --git a/package/babeld/babeld.mk b/package/babeld/babeld.mk
index 67ff553b8bed..e9d20111f93d 100644
--- a/package/babeld/babeld.mk
+++ b/package/babeld/babeld.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-BABELD_VERSION = 1.13
+BABELD_VERSION = 1.13.1
 BABELD_SITE = https://www.irif.fr/~jch/software/files
 BABELD_LICENSE = MIT
 BABELD_LICENSE_FILES = LICENCE