diff mbox series

[PATCHv3,1/1] package/wpa_supplicant: add configuration for WPA3-Entreprise

Message ID 20240916085510.2953923-1-guillaume.chaye@zeetim.com
State New
Headers show
Series [PATCHv3,1/1] package/wpa_supplicant: add configuration for WPA3-Entreprise | expand

Commit Message

Guillaume GC. Chaye Sept. 16, 2024, 8:55 a.m. UTC
Signed-off-by: Guillaume GC. Chaye <guillaume.chaye@zeetim.com>
---
 package/wpa_supplicant/wpa_supplicant.mk | 15 +++++++++++++--
 1 file changed, 13 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index 984959f679..aef8731341 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -126,18 +126,29 @@  ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_WPS),)
 WPA_SUPPLICANT_CONFIG_DISABLE += CONFIG_WPS
 endif
 
+# WPA3 configurations:
+# - CONFIG_DPP: Easy Connect (Device Provisioning Protocol - DPP R1 & R2)
+# - CONFIG_SAE: Simultaneous Authentication of Equals (SAE), WPA3-Personal
+# - CONFIG_SAE_PK: SAE Public Key, WPA3-Personal
+# - CONFIG_OWE: Opportunistic Wireless Encryption (OWE)
+# - CONFIG_SUITEB: WPA3-Enterprise
+# - CONFIG_SUITEB192: WPA3-Enterprise (SuiteB 192 bits security)
 ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_WPA3),y)
 WPA_SUPPLICANT_CONFIG_ENABLE += \
 	CONFIG_DPP \
 	CONFIG_SAE \
 	CONFIG_SAE_PK \
-	CONFIG_OWE
+	CONFIG_OWE \
+	CONFIG_SUITEB \
+	CONFIG_SUITEB192
 else
 WPA_SUPPLICANT_CONFIG_DISABLE += \
 	CONFIG_DPP \
 	CONFIG_SAE \
 	CONFIG_SAE_PK \
-	CONFIG_OWE
+	CONFIG_OWE \
+	CONFIG_SUITEB \
+	CONFIG_SUITEB192
 endif
 
 # Try to use openssl if it's already available