deleted file mode 100644
@@ -1,36 +0,0 @@
-From e56a2597eb66c2221b004aa3356b06c1b071b5b5 Mon Sep 17 00:00:00 2001
-From: Adrian Perez de Castro <aperez@igalia.com>
-Date: Wed, 14 Aug 2024 00:51:26 +0300
-Subject: [PATCH] Cast to EGLNativeWindowType explicitly
-
-In order to avoid off build failures due to mismatching (but
-compatible) declarations of wl_egl_window and EGLNativeWindowType,
-add an explicit cast to EGLNativeWindowType inside the
-TargetWayland::nativeWindow() function.
-
-Solves the following build issue found by the Buildroot autobuilders:
-
- http://autobuild.buildroot.net/results/92c5cc3134e92c263a0cbb4c05ef8956569e434b/
-
-Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
-Upstream: https://github.com/Igalia/WPEBackend-fdo/commit/e56a2597eb66c2221b004aa3356b06c1b071b5b5
----
- src/egl-client-wayland.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/egl-client-wayland.cpp b/src/egl-client-wayland.cpp
-index 10e02f0..22bb212 100644
---- a/src/egl-client-wayland.cpp
-+++ b/src/egl-client-wayland.cpp
-@@ -63,7 +63,7 @@ TargetWayland::~TargetWayland()
-
- EGLNativeWindowType TargetWayland::nativeWindow() const
- {
-- return m_egl.window;
-+ return (EGLNativeWindowType) m_egl.window;
- }
-
- void TargetWayland::resize(uint32_t width, uint32_t height)
-2.46.0
-
@@ -1,6 +1,7 @@
-# From https://wpewebkit.org/releases/wpebackend-fdo-1.14.2.tar.xz.sums
-sha1 f453f8d77e93f4ac6ac81c1874d4d6bdcb45c253 wpebackend-fdo-1.14.2.tar.xz
-sha256 93c9766ae9864eeaeaee2b0a74f22cbca08df42c1a1bdb55b086f2528e380d38 wpebackend-fdo-1.14.2.tar.xz
+# From https://wpewebkit.org/releases/wpebackend-fdo-1.14.3.tar.xz.sums
+md5 ab73398b1e35495977e50bee103969d2 wpebackend-fdo-1.14.3.tar.xz
+sha1 2d2945df15cc1efa957657fa727f3bc4c6f580bb wpebackend-fdo-1.14.3.tar.xz
+sha256 10121842595a850291db3e82f3db0b9984df079022d386ce42c2b8508159dc6c wpebackend-fdo-1.14.3.tar.xz
# Hashes for license files:
sha256 c9f6803371047fad3e72200ec6cd226329a5ee08ac61104c8211c2761fb46825 COPYING
@@ -4,7 +4,7 @@
#
################################################################################
-WPEBACKEND_FDO_VERSION = 1.14.2
+WPEBACKEND_FDO_VERSION = 1.14.3
WPEBACKEND_FDO_SITE = https://wpewebkit.org/releases
WPEBACKEND_FDO_SOURCE = wpebackend-fdo-$(WPEBACKEND_FDO_VERSION).tar.xz
WPEBACKEND_FDO_INSTALL_STAGING = YES
This is a bugfix release which plugs a couple of small leaks, and includes patch "0001-Cast-to-EGLNativeWindowType-explicitly.patch", which can now be removed. Release notes: https://wpewebkit.org/release/wpebackend-fdo-1.14.3.html Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> --- ...st-to-EGLNativeWindowType-explicitly.patch | 36 ------------------- package/wpebackend-fdo/wpebackend-fdo.hash | 7 ++-- package/wpebackend-fdo/wpebackend-fdo.mk | 2 +- 3 files changed, 5 insertions(+), 40 deletions(-) delete mode 100644 package/wpebackend-fdo/0001-Cast-to-EGLNativeWindowType-explicitly.patch