diff mbox series

[1/1] package/python-dnspython: bump to versin 2.6.1

Message ID 20240915044623.1401733-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/python-dnspython: bump to versin 2.6.1 | expand

Commit Message

James Hilliard Sept. 15, 2024, 4:46 a.m. UTC
Replace poetry-core build backend with hatchling.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-dnspython/python-dnspython.hash | 4 ++--
 package/python-dnspython/python-dnspython.mk   | 8 ++++----
 2 files changed, 6 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/package/python-dnspython/python-dnspython.hash b/package/python-dnspython/python-dnspython.hash
index 77ffb5dedc..acab710d5a 100644
--- a/package/python-dnspython/python-dnspython.hash
+++ b/package/python-dnspython/python-dnspython.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/dnspython/json
-md5  fac4e1580e5e9dfee722cb97bc073722  dnspython-2.4.2.tar.gz
-sha256  8dcfae8c7460a2f84b4072e26f1c9f4101ca20c071649cb7c34e8b6a93d58984  dnspython-2.4.2.tar.gz
+md5  ad29d0392621fb107e0eac4beed79ce5  dnspython-2.6.1.tar.gz
+sha256  e8f0f9c23a7b7cb99ded64e6c3a6f3e701d78f50c55e002b839dea7225cff7cc  dnspython-2.6.1.tar.gz
 # Locally computed sha256 checksums
 sha256  c3ea3ff5654b329c19d3bc5f7481af623c3dded4a6145585499f843ad3d741cd  LICENSE
diff --git a/package/python-dnspython/python-dnspython.mk b/package/python-dnspython/python-dnspython.mk
index f0df733143..01fad58c1d 100644
--- a/package/python-dnspython/python-dnspython.mk
+++ b/package/python-dnspython/python-dnspython.mk
@@ -4,14 +4,14 @@ 
 #
 ################################################################################
 
-PYTHON_DNSPYTHON_VERSION = 2.4.2
+PYTHON_DNSPYTHON_VERSION = 2.6.1
 PYTHON_DNSPYTHON_SOURCE = dnspython-$(PYTHON_DNSPYTHON_VERSION).tar.gz
-PYTHON_DNSPYTHON_SITE = https://files.pythonhosted.org/packages/65/2d/372a20e52a87b2ba0160997575809806111a72e18aa92738daccceb8d2b9
+PYTHON_DNSPYTHON_SITE = https://files.pythonhosted.org/packages/37/7d/c871f55054e403fdfd6b8f65fd6d1c4e147ed100d3e9f9ba1fe695403939
 PYTHON_DNSPYTHON_LICENSE = ISC
 PYTHON_DNSPYTHON_LICENSE_FILES = LICENSE
 PYTHON_DNSPYTHON_SETUP_TYPE = pep517
-PYTHON_DNSPYTHON_DEPENDENCIES = host-python-poetry-core
-HOST_PYTHON_DNSPYTHON_DEPENDENCIES = host-python-poetry-core
+PYTHON_DNSPYTHON_DEPENDENCIES = host-python-hatchling
+HOST_PYTHON_DNSPYTHON_DEPENDENCIES = host-python-hatchling
 
 $(eval $(python-package))
 $(eval $(host-python-package))