diff mbox series

[2/2] package/qt6/qt6tools: enable QML support in linguist

Message ID 20240911132021.2318073-2-christian@klarinett.li
State Accepted
Headers show
Series [1/2] package/qt6/qt6tools: build linuguist tools without printsupport | expand

Commit Message

Christian Hitz Sept. 11, 2024, 1:20 p.m. UTC
From: Christian Hitz <christian.hitz@bbv.ch>

When BR2_PACKAGE_QT6DECLARATIVE_QUICK is enabled the qt linuguist tool
lupdate should support QML/JS files.

Signed-off-by: Christian Hitz <christian.hitz@bbv.ch>
---
 package/qt6/qt6tools/qt6tools.mk | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Sept. 14, 2024, 10:56 a.m. UTC | #1
Hello Christian,

On Wed, 11 Sep 2024 15:20:20 +0200
Christian Hitz via buildroot <buildroot@buildroot.org> wrote:

> From: Christian Hitz <christian.hitz@bbv.ch>
> 
> When BR2_PACKAGE_QT6DECLARATIVE_QUICK is enabled the qt linuguist tool
> lupdate should support QML/JS files.
> 
> Signed-off-by: Christian Hitz <christian.hitz@bbv.ch>
> ---
>  package/qt6/qt6tools/qt6tools.mk | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

Applied, but after adjusting to:

@@ -49,6 +49,12 @@ HOST_QT6TOOLS_DEPENDENCIES = host-qt6base
 
 ifeq ($(BR2_PACKAGE_HOST_QT6TOOLS_LINGUIST_TOOLS),y)
 HOST_QT6TOOLS_CONF_OPTS += -DFEATURE_linguist=ON
+# When we have qt6declarative for the target, we need to build the
+# linguist tool with host-qt6declarative support so that it handles
+# QML/JS files
+ifeq ($(BR2_PACKAGE_QT6DECLARATIVE),y)
+HOST_QT6TOOLS_DEPENDENCIES += host-qt6declarative
+endif
 else
 HOST_QT6TOOLS_CONF_OPTS += -DFEATURE_linguist=OFF
 endif

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/qt6/qt6tools/qt6tools.mk b/package/qt6/qt6tools/qt6tools.mk
index ccb246f6a6..a4ae2a1d3f 100644
--- a/package/qt6/qt6tools/qt6tools.mk
+++ b/package/qt6/qt6tools/qt6tools.mk
@@ -42,11 +42,12 @@  QT6TOOLS_DEPENDENCIES = \
 	qt6base \
 	host-qt6tools
 
+HOST_QT6TOOLS_DEPENDENCIES = host-qt6base
+
 ifeq ($(BR2_PACKAGE_QT6DECLARATIVE),y)
 QT6TOOLS_DEPENDENCIES += qt6declarative
+HOST_QT6TOOLS_DEPENDENCIES += host-qt6declarative
 endif
 
-HOST_QT6TOOLS_DEPENDENCIES = host-qt6base
-
 $(eval $(cmake-package))
 $(eval $(host-cmake-package))