diff mbox series

[1/1] package/python-maturin: bump to version 1.7.1

Message ID 20240907211638.945542-1-james.hilliard1@gmail.com
State Changes Requested
Headers show
Series [1/1] package/python-maturin: bump to version 1.7.1 | expand

Commit Message

James Hilliard Sept. 7, 2024, 9:16 p.m. UTC
Restore cargo2 archive suffix format as well.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-maturin/python-maturin.hash | 2 +-
 package/python-maturin/python-maturin.mk   | 7 ++++---
 2 files changed, 5 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Sept. 14, 2024, 9:20 a.m. UTC | #1
Hello James,

On Sat,  7 Sep 2024 15:16:38 -0600
James Hilliard <james.hilliard1@gmail.com> wrote:

> Restore cargo2 archive suffix format as well.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  package/python-maturin/python-maturin.hash | 2 +-
>  package/python-maturin/python-maturin.mk   | 7 ++++---
>  2 files changed, 5 insertions(+), 4 deletions(-)

Thanks, but it doesn't work for me:

ERROR: while checking hashes from package/python-maturin/python-maturin.hash
ERROR: python-maturin-1.7.1-cargo2.tar.gz has wrong sha256 hash:
ERROR: expected: 92c5fc2a24f32623a6994334b523a587dca63ebb5b46ae14a255a2ebc25fd3f7
ERROR: got     : 9b25e8232b67e7ad8652adfe95e890868f56adfb65a93ad4c2a2cb6a7236a94f
ERROR: Incomplete download, or man-in-the-middle (MITM) attack

Could you have a look?

Thomas
James Hilliard Sept. 14, 2024, 6:42 p.m. UTC | #2
On Sat, Sep 14, 2024 at 3:20 AM Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
>
> Hello James,
>
> On Sat,  7 Sep 2024 15:16:38 -0600
> James Hilliard <james.hilliard1@gmail.com> wrote:
>
> > Restore cargo2 archive suffix format as well.
> >
> > Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> > ---
> >  package/python-maturin/python-maturin.hash | 2 +-
> >  package/python-maturin/python-maturin.mk   | 7 ++++---
> >  2 files changed, 5 insertions(+), 4 deletions(-)
>
> Thanks, but it doesn't work for me:
>
> ERROR: while checking hashes from package/python-maturin/python-maturin.hash
> ERROR: python-maturin-1.7.1-cargo2.tar.gz has wrong sha256 hash:
> ERROR: expected: 92c5fc2a24f32623a6994334b523a587dca63ebb5b46ae14a255a2ebc25fd3f7
> ERROR: got     : 9b25e8232b67e7ad8652adfe95e890868f56adfb65a93ad4c2a2cb6a7236a94f
> ERROR: Incomplete download, or man-in-the-middle (MITM) attack

Weird, I deleted the archive from my dl directory and tried with a full clean
build and was not able to reproduce.

>
> Could you have a look?
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/package/python-maturin/python-maturin.hash b/package/python-maturin/python-maturin.hash
index 3c5f836ad5..2b601d6ee9 100644
--- a/package/python-maturin/python-maturin.hash
+++ b/package/python-maturin/python-maturin.hash
@@ -1,5 +1,5 @@ 
 # Locally calculated after vendoring
-sha256  56c18b09d38080f9975fb679be1fda01b936d21f5ef233967cda3dd74905e683  maturin-1.7.0.tar.gz
+sha256  92c5fc2a24f32623a6994334b523a587dca63ebb5b46ae14a255a2ebc25fd3f7  python-maturin-1.7.1-cargo2.tar.gz
 # Locally computed sha256 checksums
 sha256  a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2  license-apache
 sha256  ea7882c559733766ad08343bde1d1ec80a4967c03a738fb8e0058ef6289f7b7c  license-mit
diff --git a/package/python-maturin/python-maturin.mk b/package/python-maturin/python-maturin.mk
index 70cdb15949..76f136826a 100644
--- a/package/python-maturin/python-maturin.mk
+++ b/package/python-maturin/python-maturin.mk
@@ -4,9 +4,10 @@ 
 #
 ################################################################################
 
-PYTHON_MATURIN_VERSION = 1.7.0
-PYTHON_MATURIN_SOURCE = maturin-$(PYTHON_MATURIN_VERSION).tar.gz
-PYTHON_MATURIN_SITE = https://files.pythonhosted.org/packages/80/da/a4bbd6e97f3645f4ebd725321aa235e22e31037dfd92caf4539f721c0a5a
+PYTHON_MATURIN_VERSION = 1.7.1
+PYTHON_MATURIN_SOURCE_PYPI = maturin-$(PYTHON_MATURIN_VERSION).tar.gz
+PYTHON_MATURIN_SITE_PYPI = https://files.pythonhosted.org/packages/1d/ec/1f688d6ad82a568fd7c239f1c7a130d3fc2634977df4ef662ee0ac58a153
+PYTHON_MATURIN_SITE = $(PYTHON_MATURIN_SITE_PYPI)/$(PYTHON_MATURIN_SOURCE_PYPI)?buildroot-path=filename
 PYTHON_MATURIN_SETUP_TYPE = setuptools-rust
 PYTHON_MATURIN_LICENSE = Apache-2.0 or MIT
 PYTHON_MATURIN_LICENSE_FILES = license-apache license-mit