diff mbox series

[1/1] package/python-lxml: bump to version 5.3.0

Message ID 20240906183000.475670-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/python-lxml: bump to version 5.3.0 | expand

Commit Message

James Hilliard Sept. 6, 2024, 6:30 p.m. UTC
Replace deprecated --xslt-config build option with --with-xslt-config.

Replace deprecated --xml2-config build option with --with-xml2-config.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-lxml/python-lxml.hash |  2 +-
 package/python-lxml/python-lxml.mk   | 12 ++++++------
 2 files changed, 7 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/package/python-lxml/python-lxml.hash b/package/python-lxml/python-lxml.hash
index 3eb427a80d..059238ffab 100644
--- a/package/python-lxml/python-lxml.hash
+++ b/package/python-lxml/python-lxml.hash
@@ -1,5 +1,5 @@ 
 # From https://pypi.org/project/lxml/
-sha256  bb2dc4898180bea79863d5487e5f9c7c34297414bad54bcd0f0852aee9cfdb87  lxml-5.2.2.tar.gz
+sha256  4e109ca30d1edec1ac60cdbe341905dc3b8f55b16855e03a54aaf59e51ec8c6f  lxml-5.3.0.tar.gz
 # Locally computed
 sha256  41d49dd406aa0e1548a6d5f21a30d6bf638b3cd96eb7289dd348d83ed2e40392  LICENSES.txt
 sha256  69edb445c1335a8312d4c09271847e9956d84f0d9f724d125340cc3fad767b2a  doc/licenses/BSD.txt
diff --git a/package/python-lxml/python-lxml.mk b/package/python-lxml/python-lxml.mk
index 2a26c132a7..8604b5783a 100644
--- a/package/python-lxml/python-lxml.mk
+++ b/package/python-lxml/python-lxml.mk
@@ -4,8 +4,8 @@ 
 #
 ################################################################################
 
-PYTHON_LXML_VERSION = 5.2.2
-PYTHON_LXML_SITE = https://files.pythonhosted.org/packages/63/f7/ffbb6d2eb67b80a45b8a0834baa5557a14a5ffce0979439e7cd7f0c4055b
+PYTHON_LXML_VERSION = 5.3.0
+PYTHON_LXML_SITE = https://files.pythonhosted.org/packages/e7/6b/20c3a4b24751377aaa6307eb230b66701024012c29dd374999cc92983269
 PYTHON_LXML_SOURCE = lxml-$(PYTHON_LXML_VERSION).tar.gz
 
 # Not including the GPL, because it is used only for the test scripts.
@@ -29,12 +29,12 @@  HOST_PYTHON_LXML_DEPENDENCIES = host-libxml2 host-libxslt host-zlib
 # libxslt compiler and linker flags
 PYTHON_LXML_BUILD_OPTS = \
 	--skip-dependency-check \
-	-C--build-option=--xslt-config=$(STAGING_DIR)/usr/bin/xslt-config \
-	-C--build-option=--xml2-config=$(STAGING_DIR)/usr/bin/xml2-config
+	-C--build-option=--with-xslt-config=$(STAGING_DIR)/usr/bin/xslt-config \
+	-C--build-option=--with-xml2-config=$(STAGING_DIR)/usr/bin/xml2-config
 HOST_PYTHON_LXML_BUILD_OPTS = \
 	--skip-dependency-check \
-	-C--build-option=--xslt-config=$(HOST_DIR)/bin/xslt-config \
-	-C--build-option=--xml2-config=$(HOST_DIR)/bin/xml2-config
+	-C--build-option=--with-xslt-config=$(HOST_DIR)/bin/xslt-config \
+	-C--build-option=--with-xml2-config=$(HOST_DIR)/bin/xml2-config
 
 $(eval $(python-package))
 $(eval $(host-python-package))