@@ -139,4 +139,9 @@ config BR2_PACKAGE_WEBKITGTK_WEBDRIVER
Enable support for WebDriver. This will build and install the
WebKitWebDriver program in the target.
+config BR2_PACKAGE_WEBKITGTK_MINIBROWSER
+ bool "MiniBrowser"
+ help
+ Example browser application included with WebKitGTK.
+
endif
@@ -61,6 +61,16 @@ else
WEBKITGTK_CONF_OPTS += -DENABLE_WEBDRIVER=OFF
endif
+ifeq ($(BR2_PACKAGE_WEBKITGTK_MINIBROWSER),y)
+define WEBKITGTK_INSTALL_MINIBROWSER_SYMLINK
+ ln -sf ../libexec/webkit2gtk-4.1/MiniBrowser $(TARGET_DIR)/usr/bin/MiniBrowser
+endef
+WEBKITGTK_POST_INSTALL_TARGET_HOOKS += WEBKITGTK_INSTALL_MINIBROWSER_SYMLINK
+WEBKITGTK_CONF_OPTS += -DENABLE_MINIBROWSER=ON
+else
+WEBKITGTK_CONF_OPTS += -DENABLE_MINIBROWSER=OFF
+endif
+
ifeq ($(BR2_PACKAGE_LCMS2),y)
WEBKITGTK_CONF_OPTS += -DUSE_LCMS=ON
WEBKITGTK_DEPENDENCIES += lcms2
Add an option to enable building and installing the MiniBrowser program included in the WebKitGTK source tree. This may be handy now that Midori will no longer be packaged in Builroot. A post-install hook installs a symbolic link to it into /usr/bin for convenience. Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> --- package/webkitgtk/Config.in | 5 +++++ package/webkitgtk/webkitgtk.mk | 10 ++++++++++ 2 files changed, 15 insertions(+)