diff mbox series

[1/1] package/python-sqlalchemy: fix build issue with setuptools > 69.3

Message ID 20240902192122.150821-1-flavio.tapajos@newtesc.com.br
State Changes Requested
Headers show
Series [1/1] package/python-sqlalchemy: fix build issue with setuptools > 69.3 | expand

Commit Message

Flávio Tapajós Sept. 2, 2024, 7:21 p.m. UTC
This commit adds upstream patch that unpins setuptools:
  https://gerrit.sqlalchemy.org/c/sqlalchemy/sqlalchemy/+/5478
  https://github.com/sqlalchemy/sqlalchemy/discussions/11818

Fixes:
  http://autobuild.buildroot.org/results/c531b6e63c5121138e8e8a1c5d1501d9d7e1391e/

Signed-off-by: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
---
 .../2.0.32/0001-unpin-setuptools.patch        | 72 +++++++++++++++++++
 1 file changed, 72 insertions(+)
 create mode 100644 package/python-sqlalchemy/2.0.32/0001-unpin-setuptools.patch

Comments

Yann E. MORIN Sept. 3, 2024, 7:51 p.m. UTC | #1
Flavio, All,

On 2024-09-02 16:21 -0300, Flávio Tapajós spake thusly:
> This commit adds upstream patch that unpins setuptools:
>   https://gerrit.sqlalchemy.org/c/sqlalchemy/sqlalchemy/+/5478
>   https://github.com/sqlalchemy/sqlalchemy/discussions/11818
> 
> Fixes:
>   http://autobuild.buildroot.org/results/c531b6e63c5121138e8e8a1c5d1501d9d7e1391e/
> 
> Signed-off-by: Flávio Tapajós <flavio.tapajos@newtesc.com.br>

Thanks for the respin. However, upstream has released 2.0.33 with this
fix included. Since the fix applies to 20.0.32 that is only in the next
branch, we could probably bump now, no?

> diff --git a/package/python-sqlalchemy/2.0.32/0001-unpin-setuptools.patch b/package/python-sqlalchemy/2.0.32/0001-unpin-setuptools.patch
> new file mode 100644
> index 0000000000..92dd1826a7
> --- /dev/null
> +++ b/package/python-sqlalchemy/2.0.32/0001-unpin-setuptools.patch

Don't create the patches in a versioned sub-directory, as the package
does not have a version choice.

Keeping the patch at the root of the package dir will allow to notice
when we bump and the patch no longer applies (cleanly). Otherwise, we
can easily miss the patch and it would longer unused.

Regards,
Yann E. MORIN.

> @@ -0,0 +1,72 @@
> +From bf33cb4ffa5f058b4bb9e50efaa43038f37cc6e1 Mon Sep 17 00:00:00 2001
> +From: Mike Bayer <mike_mp@zzzcomputing.com>
> +Date: Mon, 2 Sep 2024 09:13:27 -0400
> +Subject: [PATCH] unpin setuptools
> +MIME-Version: 1.0
> +Content-Type: text/plain; charset=UTF-8
> +Content-Transfer-Encoding: 8bit
> +
> +This removes the pin that was placed in 2607262110bdc5c5dc96fc19ddca895a15a58e4e
> +
> +The pin for ``setuptools<69.3`` in ``pyproject.toml`` has been
> +removed.  This pin was to prevent a sudden change to :pep:`625` in
> +setuptools from taking place which changes the file name of SQLAlchemy's
> +source distribution on pypi to be an all lower case name, which is very
> +likely to cause problems with various build environments that expected a
> +particular naming style.  However, the presence of this pin is now holding
> +back environments that otherwise want to use a newer setuptools, so we've
> +decided to move forward with this change, with the assumption that build
> +environments will have largely accommodated the setuptools change by
> +now.
> +
> +References: #11818
> +Change-Id: I0cd9ab0512004669a8f0aa0cb7f560d89a2da2bd
> +
> +Upstream: https://gerrit.sqlalchemy.org/plugins/gitiles/sqlalchemy/sqlalchemy/+/cf82be60f811ed6bdc1a8c4221148d97dd6b704d
> +Signed-off-by: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
> +---
> + doc/build/changelog/unreleased_20/11818.rst | 16 ++++++++++++++++
> + pyproject.toml                              |  4 +---
> + 2 files changed, 17 insertions(+), 3 deletions(-)
> + create mode 100644 doc/build/changelog/unreleased_20/11818.rst
> +
> +diff --git a/doc/build/changelog/unreleased_20/11818.rst b/doc/build/changelog/unreleased_20/11818.rst
> +new file mode 100644
> +index 000000000..c75a6c64b
> +--- /dev/null
> ++++ b/doc/build/changelog/unreleased_20/11818.rst
> +@@ -0,0 +1,16 @@
> ++.. change::
> ++    :tags: change, general
> ++    :tickets: 11818
> ++
> ++    The pin for ``setuptools<69.3`` in ``pyproject.toml`` has been
> ++    removed.  This pin was to prevent a sudden change to :pep:`625` in
> ++    setuptools from taking place which changes the file name of SQLAlchemy's
> ++    source distribution on pypi to be an all lower case name, which is very
> ++    likely to cause problems with various build environments that expected a
> ++    particular naming style.  However, the presence of this pin is now holding
> ++    back environments that otherwise want to use a newer setuptools, so we've
> ++    decided to move forward with this change, with the assumption that build
> ++    environments will have largely accommodated the setuptools change by
> ++    now.
> ++
> ++
> +diff --git a/pyproject.toml b/pyproject.toml
> +index 0f53594df..f75bf3192 100644
> +--- a/pyproject.toml
> ++++ b/pyproject.toml
> +@@ -1,9 +1,7 @@
> + [build-system]
> + build-backend = "setuptools.build_meta"
> + requires = [
> +-    # avoid moving to https://github.com/pypa/setuptools/issues/3593
> +-    # until we're ready
> +-    "setuptools>=61.0,<69.3",
> ++    "setuptools>=61.0",
> +     "cython>=0.29.24; platform_python_implementation == 'CPython'", # Skip cython when using pypy
> + ]
> + 
> +-- 
> +2.46.0
> +
> -- 
> 2.46.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/python-sqlalchemy/2.0.32/0001-unpin-setuptools.patch b/package/python-sqlalchemy/2.0.32/0001-unpin-setuptools.patch
new file mode 100644
index 0000000000..92dd1826a7
--- /dev/null
+++ b/package/python-sqlalchemy/2.0.32/0001-unpin-setuptools.patch
@@ -0,0 +1,72 @@ 
+From bf33cb4ffa5f058b4bb9e50efaa43038f37cc6e1 Mon Sep 17 00:00:00 2001
+From: Mike Bayer <mike_mp@zzzcomputing.com>
+Date: Mon, 2 Sep 2024 09:13:27 -0400
+Subject: [PATCH] unpin setuptools
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This removes the pin that was placed in 2607262110bdc5c5dc96fc19ddca895a15a58e4e
+
+The pin for ``setuptools<69.3`` in ``pyproject.toml`` has been
+removed.  This pin was to prevent a sudden change to :pep:`625` in
+setuptools from taking place which changes the file name of SQLAlchemy's
+source distribution on pypi to be an all lower case name, which is very
+likely to cause problems with various build environments that expected a
+particular naming style.  However, the presence of this pin is now holding
+back environments that otherwise want to use a newer setuptools, so we've
+decided to move forward with this change, with the assumption that build
+environments will have largely accommodated the setuptools change by
+now.
+
+References: #11818
+Change-Id: I0cd9ab0512004669a8f0aa0cb7f560d89a2da2bd
+
+Upstream: https://gerrit.sqlalchemy.org/plugins/gitiles/sqlalchemy/sqlalchemy/+/cf82be60f811ed6bdc1a8c4221148d97dd6b704d
+Signed-off-by: Flávio Tapajós <flavio.tapajos@newtesc.com.br>
+---
+ doc/build/changelog/unreleased_20/11818.rst | 16 ++++++++++++++++
+ pyproject.toml                              |  4 +---
+ 2 files changed, 17 insertions(+), 3 deletions(-)
+ create mode 100644 doc/build/changelog/unreleased_20/11818.rst
+
+diff --git a/doc/build/changelog/unreleased_20/11818.rst b/doc/build/changelog/unreleased_20/11818.rst
+new file mode 100644
+index 000000000..c75a6c64b
+--- /dev/null
++++ b/doc/build/changelog/unreleased_20/11818.rst
+@@ -0,0 +1,16 @@
++.. change::
++    :tags: change, general
++    :tickets: 11818
++
++    The pin for ``setuptools<69.3`` in ``pyproject.toml`` has been
++    removed.  This pin was to prevent a sudden change to :pep:`625` in
++    setuptools from taking place which changes the file name of SQLAlchemy's
++    source distribution on pypi to be an all lower case name, which is very
++    likely to cause problems with various build environments that expected a
++    particular naming style.  However, the presence of this pin is now holding
++    back environments that otherwise want to use a newer setuptools, so we've
++    decided to move forward with this change, with the assumption that build
++    environments will have largely accommodated the setuptools change by
++    now.
++
++
+diff --git a/pyproject.toml b/pyproject.toml
+index 0f53594df..f75bf3192 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,9 +1,7 @@
+ [build-system]
+ build-backend = "setuptools.build_meta"
+ requires = [
+-    # avoid moving to https://github.com/pypa/setuptools/issues/3593
+-    # until we're ready
+-    "setuptools>=61.0,<69.3",
++    "setuptools>=61.0",
+     "cython>=0.29.24; platform_python_implementation == 'CPython'", # Skip cython when using pypy
+ ]
+ 
+-- 
+2.46.0
+