diff mbox series

[1/1] package/flashrom: fix cli with BR2_SHARED_LIBS

Message ID 20240819040213.3563422-1-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [1/1] package/flashrom: fix cli with BR2_SHARED_LIBS | expand

Commit Message

James Hilliard Aug. 19, 2024, 4:02 a.m. UTC
Flashrom requires --default-library=both for the cli when building
with BR2_SHARED_LIBS.

As such set --default-library=both instead of disabling it.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/flashrom/flashrom.mk | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Aug. 19, 2024, 8:27 a.m. UTC | #1
Hello,

On Sun, 18 Aug 2024 22:02:13 -0600
James Hilliard <james.hilliard1@gmail.com> wrote:

> Flashrom requires --default-library=both for the cli when building
> with BR2_SHARED_LIBS.
> 
> As such set --default-library=both instead of disabling it.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Thanks for the patch!

Is this fixing a build issue? If so, which one, which defconfig? Or
perhaps an autobuilder failure reference?

When was this problem introduced?

Thanks!

Thomas
James Hilliard Aug. 19, 2024, 8:31 a.m. UTC | #2
On Mon, Aug 19, 2024 at 2:27 AM Thomas Petazzoni <
thomas.petazzoni@bootlin.com> wrote:

> Hello,
>
> On Sun, 18 Aug 2024 22:02:13 -0600
> James Hilliard <james.hilliard1@gmail.com> wrote:
>
> > Flashrom requires --default-library=both for the cli when building
> > with BR2_SHARED_LIBS.
> >
> > As such set --default-library=both instead of disabling it.
> >
> > Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
>
> Thanks for the patch!
>
> Is this fixing a build issue? If so, which one, which defconfig? Or
> perhaps an autobuilder failure reference?
>

It fixes an issue where the flashlib cli was not being built at all,
only the library was for BR2_SHARED_LIBS systems.


>
> When was this problem introduced?
>

When bumping flashrom to version 1.4.0-rc2:
https://github.com/buildroot/buildroot/commit/8637884057ddc3c1aeb9f0dd285fc6fcf378c26b


>
> Thanks!
>
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering and training
> https://bootlin.com
>
Thomas Petazzoni Aug. 19, 2024, 8:39 a.m. UTC | #3
Hello James,

On Mon, 19 Aug 2024 02:31:02 -0600
James Hilliard <james.hilliard1@gmail.com> wrote:

> > Is this fixing a build issue? If so, which one, which defconfig? Or
> > perhaps an autobuilder failure reference?
> 
> It fixes an issue where the flashlib cli was not being built at all,
> only the library was for BR2_SHARED_LIBS systems.

So there is no build issue, but parts that are expect to be built are
not built?

> > When was this problem introduced?
> 
> When bumping flashrom to version 1.4.0-rc2:
> https://github.com/buildroot/buildroot/commit/8637884057ddc3c1aeb9f0dd285fc6fcf378c26b

Thanks. Could you clarify both aspects in the commit log?

Thanks!

Thomas
James Hilliard Aug. 19, 2024, 8:46 a.m. UTC | #4
On Mon, Aug 19, 2024 at 2:39 AM Thomas Petazzoni <
thomas.petazzoni@bootlin.com> wrote:

> Hello James,
>
> On Mon, 19 Aug 2024 02:31:02 -0600
> James Hilliard <james.hilliard1@gmail.com> wrote:
>
> > > Is this fixing a build issue? If so, which one, which defconfig? Or
> > > perhaps an autobuilder failure reference?
> >
> > It fixes an issue where the flashlib cli was not being built at all,
> > only the library was for BR2_SHARED_LIBS systems.
>
> So there is no build issue, but parts that are expect to be built are
> not built?
>

This fixes the bug which was the reason the cli was originally disabled.


>
> > > When was this problem introduced?
> >
> > When bumping flashrom to version 1.4.0-rc2:
> >
> https://github.com/buildroot/buildroot/commit/8637884057ddc3c1aeb9f0dd285fc6fcf378c26b
>
> Thanks. Could you clarify both aspects in the commit log?
>

Added some more details in v2:
https://patchwork.ozlabs.org/project/buildroot/patch/20240819084352.905082-1-james.hilliard1@gmail.com/


>
> Thanks!
>
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering and training
> https://bootlin.com
>
diff mbox series

Patch

diff --git a/package/flashrom/flashrom.mk b/package/flashrom/flashrom.mk
index 1e7d332dae..030f6816a0 100644
--- a/package/flashrom/flashrom.mk
+++ b/package/flashrom/flashrom.mk
@@ -10,6 +10,7 @@  FLASHROM_LICENSE = GPL-2.0+
 FLASHROM_LICENSE_FILES = COPYING
 FLASHROM_INSTALL_STAGING = YES
 FLASHROM_CONF_OPTS = \
+	-Dclassic_cli=enabled \
 	-Dclassic_cli_print_wiki=disabled \
 	-Dich_descriptors_tool=enabled \
 	-Dtests=disabled \
@@ -78,10 +79,8 @@  endif
 
 FLASHROM_CONF_OPTS += -Dprogrammer=$(subst $(space),$(comma),$(strip $(FLASHROM_PROGRAMMERS)))
 
-ifeq ($(BR2_SHARED_LIBS),)
-FLASHROM_CONF_OPTS += -Dclassic_cli=enabled
-else
-FLASHROM_CONF_OPTS += -Dclassic_cli=disabled
+ifeq ($(BR2_SHARED_LIBS),y)
+FLASHROM_CONF_OPTS += --default-library=both
 endif
 
 $(eval $(meson-package))