diff mbox series

[1/1] package/qt6tools: fix missing host-qt6base dependency

Message ID 20240814111821.399174-1-gael.portay@rtone.fr
State Accepted
Headers show
Series [1/1] package/qt6tools: fix missing host-qt6base dependency | expand

Commit Message

Gaël PORTAY Aug. 14, 2024, 11:18 a.m. UTC
This adds the host dependency host-qt6base as host-qt6tools requires the
Qt cmake modules to be installed.

Fixes:

	$ make qt6tools
	(...)
	CMake Error at CMakeLists.txt:21 (find_package):
	  Could not find a package configuration file provided by "Qt6" (requested
	  version 6.7.2) with any of the following names:

	    Qt6Config.cmake
	    qt6-config.cmake

	  Add the installation prefix of "Qt6" to CMAKE_PREFIX_PATH or set "Qt6_DIR"
	  to a directory containing one of the above files.  If "Qt6" provides a
	  separate development package or SDK, be sure it has been installed.

Signed-off-by: Gaël PORTAY <gael.portay@rtone.fr>
---
Dear Maintainers,

I am trying to create and build the package Qt6WebEngine.

That package raises a warning to build the Widgets; it requires
host-qt6tools with Qt Designer:

	CMake Warning at src/webenginewidgets/CMakeLists.txt:7 (message):
	  Qt tools Designer is required to compile designer plugin

I tried to run $ make qt6tools and it fails with error in the commit
message above because of missing host dependency.

This change could be addressed now.

Note: It requires (qt6base) XML to build Qt Designer; this should be
addressed later I guess.

Regards,
Gaël
 package/qt6/qt6tools/qt6tools.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Thomas Petazzoni Aug. 14, 2024, 6:07 p.m. UTC | #1
On Wed, 14 Aug 2024 13:18:21 +0200
"Gaël PORTAY" <gael.portay@gmail.com> wrote:

> This adds the host dependency host-qt6base as host-qt6tools requires the
> Qt cmake modules to be installed.
> 
> Fixes:
> 
> 	$ make qt6tools
> 	(...)
> 	CMake Error at CMakeLists.txt:21 (find_package):
> 	  Could not find a package configuration file provided by "Qt6" (requested
> 	  version 6.7.2) with any of the following names:
> 
> 	    Qt6Config.cmake
> 	    qt6-config.cmake
> 
> 	  Add the installation prefix of "Qt6" to CMAKE_PREFIX_PATH or set "Qt6_DIR"
> 	  to a directory containing one of the above files.  If "Qt6" provides a
> 	  separate development package or SDK, be sure it has been installed.
> 
> Signed-off-by: Gaël PORTAY <gael.portay@rtone.fr>
> ---
> Dear Maintainers,

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/qt6/qt6tools/qt6tools.mk b/package/qt6/qt6tools/qt6tools.mk
index d996f75b34..09c986cfc6 100644
--- a/package/qt6/qt6tools/qt6tools.mk
+++ b/package/qt6/qt6tools/qt6tools.mk
@@ -41,5 +41,7 @@  ifeq ($(BR2_PACKAGE_QT6DECLARATIVE),y)
 QT6TOOLS_DEPENDENCIES += qt6declarative
 endif
 
+HOST_QT6TOOLS_DEPENDENCIES = host-qt6base
+
 $(eval $(cmake-package))
 $(eval $(host-cmake-package))