diff mbox series

[1/2] Revert "package/chicken: move literals into text section for xtensa architecture"

Message ID 20240811000029.1956409-2-jcmvbkbc@gmail.com
State Accepted
Headers show
Series package/chicken: pass TARGET_CFLAGS to the build system | expand

Commit Message

Max Filippov Aug. 11, 2024, midnight UTC
This reverts commit 86e51fd5fe2810bbf833b48c4914dcd2de01bdbe.
Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
---
 .../0001-xtensa-text-section-literals.patch   | 30 -------------------
 package/chicken/chicken.mk                    | 14 ++-------
 2 files changed, 2 insertions(+), 42 deletions(-)
 delete mode 100644 package/chicken/0001-xtensa-text-section-literals.patch

Comments

Woodrow Douglass Aug. 12, 2024, 12:39 p.m. UTC | #1
On 8/10/24 20:00, Max Filippov wrote:
> CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender.
>
>
> This reverts commit 86e51fd5fe2810bbf833b48c4914dcd2de01bdbe.
> Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
> ---
>   .../0001-xtensa-text-section-literals.patch   | 30 -------------------
>   package/chicken/chicken.mk                    | 14 ++-------
>   2 files changed, 2 insertions(+), 42 deletions(-)
>   delete mode 100644 package/chicken/0001-xtensa-text-section-literals.patch
>
> diff --git a/package/chicken/0001-xtensa-text-section-literals.patch b/package/chicken/0001-xtensa-text-section-literals.patch
> deleted file mode 100644
> index b93aaf9e218d..000000000000
> --- a/package/chicken/0001-xtensa-text-section-literals.patch
> +++ /dev/null
> @@ -1,30 +0,0 @@
> -From e8d177f4d4e1c6bc41787ea1621e323ff4ad493e Mon Sep 17 00:00:00 2001
> -From: Woodrow Douglass <wdouglass@carnegierobotics.com>
> -Date: Mon, 22 Jul 2024 08:50:37 -0400
> -Subject: [PATCH] Move literals into text section for xtensa architecture
> -
> -Upstream: https://bugs.call-cc.org/ticket/1840
> -Signed-off-by: Woodrow Douglass <wdouglass@carnegierobotics.com>
> ----
> - Makefile.linux | 5 +++++
> - 1 file changed, 5 insertions(+)
> -
> -diff --git a/Makefile.linux b/Makefile.linux
> -index b628cda4..e97c2b94 100644
> ---- a/Makefile.linux
> -+++ b/Makefile.linux
> -@@ -52,6 +52,11 @@ USES_SONAME = yes
> -
> - # architectures
> -
> -+ifeq ($(ARCH),xtensa)
> -+C_COMPILER_OPTIONS += -mtext-section-literals
> -+LINKER_OPTIONS += -mtext-section-literals
> -+endif
> -+
> - ifeq ($(ARCH),x32)
> - C_COMPILER_OPTIONS += -mx32
> - LINKER_OPTIONS += -mx32
> ---
> -2.39.2
> -
> diff --git a/package/chicken/chicken.mk b/package/chicken/chicken.mk
> index 0520280134ab..2667f7823d8a 100644
> --- a/package/chicken/chicken.mk
> +++ b/package/chicken/chicken.mk
> @@ -11,19 +11,9 @@ CHICKEN_LICENSE_FILES = LICENSE
>   CHICKEN_CPE_ID_VENDOR = call-cc
>   CHICKEN_INSTALL_STAGING = YES
>
> -# Chicken only uses the "arch" variable for some special-case compile
> -# arguments If it's empty, it tries to detect the arch host Filter out
> -# values that have an effect, or pass "unused" here
> -ifeq ($(NORMALIZED_ARCH),x86_64)
> -CHICKEN_ARCH = x86-64

changing the spelling to `x86-64` here is a good idea i think, because 
chicken does add some flags. Other then that, i agree that the 
C_COMPILER_OPTIMIZATION_OPTIONS approach is better here


> -else ifeq ($(NORMALIZED_ARCH),xtensa)
> -CHICKEN_ARCH = xtensa
> -else
> -CHICKEN_ARCH = unused
> -endif
> -
> +# If ARCH is not set, it attempts to autodiscover. But it is anyway not used.
>   CHICKEN_MAKE_OPTS = \
> -       ARCH="$(CHICKEN_ARCH)" \
> +       ARCH=unused \
>          C_COMPILER="$(TARGET_CC)" \
>          CXX_COMPILER="$(TARGET_CXX)" \
>          PREFIX=/usr \
> --
> 2.39.2
>
Max Filippov Aug. 12, 2024, 6:29 p.m. UTC | #2
On Mon, Aug 12, 2024 at 5:39 AM Woody Douglass
<wdouglass@carnegierobotics.com> wrote:
> On 8/10/24 20:00, Max Filippov wrote:
> > CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender.
> >
> >
> > This reverts commit 86e51fd5fe2810bbf833b48c4914dcd2de01bdbe.
> > Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
> > ---
> >   .../0001-xtensa-text-section-literals.patch   | 30 -------------------
> >   package/chicken/chicken.mk                    | 14 ++-------
> >   2 files changed, 2 insertions(+), 42 deletions(-)
> >   delete mode 100644 package/chicken/0001-xtensa-text-section-literals.patch
> >
> > diff --git a/package/chicken/0001-xtensa-text-section-literals.patch b/package/chicken/0001-xtensa-text-section-literals.patch
> > deleted file mode 100644
> > index b93aaf9e218d..000000000000
> > --- a/package/chicken/0001-xtensa-text-section-literals.patch
> > +++ /dev/null
> > @@ -1,30 +0,0 @@
> > -From e8d177f4d4e1c6bc41787ea1621e323ff4ad493e Mon Sep 17 00:00:00 2001
> > -From: Woodrow Douglass <wdouglass@carnegierobotics.com>
> > -Date: Mon, 22 Jul 2024 08:50:37 -0400
> > -Subject: [PATCH] Move literals into text section for xtensa architecture
> > -
> > -Upstream: https://bugs.call-cc.org/ticket/1840
> > -Signed-off-by: Woodrow Douglass <wdouglass@carnegierobotics.com>
> > ----
> > - Makefile.linux | 5 +++++
> > - 1 file changed, 5 insertions(+)
> > -
> > -diff --git a/Makefile.linux b/Makefile.linux
> > -index b628cda4..e97c2b94 100644
> > ---- a/Makefile.linux
> > -+++ b/Makefile.linux
> > -@@ -52,6 +52,11 @@ USES_SONAME = yes
> > -
> > - # architectures
> > -
> > -+ifeq ($(ARCH),xtensa)
> > -+C_COMPILER_OPTIONS += -mtext-section-literals
> > -+LINKER_OPTIONS += -mtext-section-literals
> > -+endif
> > -+
> > - ifeq ($(ARCH),x32)
> > - C_COMPILER_OPTIONS += -mx32
> > - LINKER_OPTIONS += -mx32
> > ---
> > -2.39.2
> > -
> > diff --git a/package/chicken/chicken.mk b/package/chicken/chicken.mk
> > index 0520280134ab..2667f7823d8a 100644
> > --- a/package/chicken/chicken.mk
> > +++ b/package/chicken/chicken.mk
> > @@ -11,19 +11,9 @@ CHICKEN_LICENSE_FILES = LICENSE
> >   CHICKEN_CPE_ID_VENDOR = call-cc
> >   CHICKEN_INSTALL_STAGING = YES
> >
> > -# Chicken only uses the "arch" variable for some special-case compile
> > -# arguments If it's empty, it tries to detect the arch host Filter out
> > -# values that have an effect, or pass "unused" here
> > -ifeq ($(NORMALIZED_ARCH),x86_64)
> > -CHICKEN_ARCH = x86-64
>
> changing the spelling to `x86-64` here is a good idea i think, because
> chicken does add some flags. Other then that, i agree that the
> C_COMPILER_OPTIMIZATION_OPTIONS approach is better here

I believe that it should be done in a separate change as it has
nothing to do with the topic of 'move literals into text section for
xtensa architecture'.
Woodrow Douglass Aug. 12, 2024, 6:53 p.m. UTC | #3
On 8/12/24 14:29, Max Filippov wrote:
> CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender.
>
>
> On Mon, Aug 12, 2024 at 5:39 AM Woody Douglass
> <wdouglass@carnegierobotics.com> wrote:
>> On 8/10/24 20:00, Max Filippov wrote:
>>> CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender.
>>>
>>>
>>> This reverts commit 86e51fd5fe2810bbf833b48c4914dcd2de01bdbe.
>>> Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
>>> ---
>>>    .../0001-xtensa-text-section-literals.patch   | 30 -------------------
>>>    package/chicken/chicken.mk                    | 14 ++-------
>>>    2 files changed, 2 insertions(+), 42 deletions(-)
>>>    delete mode 100644 package/chicken/0001-xtensa-text-section-literals.patch
>>>
>>> diff --git a/package/chicken/0001-xtensa-text-section-literals.patch b/package/chicken/0001-xtensa-text-section-literals.patch
>>> deleted file mode 100644
>>> index b93aaf9e218d..000000000000
>>> --- a/package/chicken/0001-xtensa-text-section-literals.patch
>>> +++ /dev/null
>>> @@ -1,30 +0,0 @@
>>> -From e8d177f4d4e1c6bc41787ea1621e323ff4ad493e Mon Sep 17 00:00:00 2001
>>> -From: Woodrow Douglass <wdouglass@carnegierobotics.com>
>>> -Date: Mon, 22 Jul 2024 08:50:37 -0400
>>> -Subject: [PATCH] Move literals into text section for xtensa architecture
>>> -
>>> -Upstream: https://bugs.call-cc.org/ticket/1840
>>> -Signed-off-by: Woodrow Douglass <wdouglass@carnegierobotics.com>
>>> ----
>>> - Makefile.linux | 5 +++++
>>> - 1 file changed, 5 insertions(+)
>>> -
>>> -diff --git a/Makefile.linux b/Makefile.linux
>>> -index b628cda4..e97c2b94 100644
>>> ---- a/Makefile.linux
>>> -+++ b/Makefile.linux
>>> -@@ -52,6 +52,11 @@ USES_SONAME = yes
>>> -
>>> - # architectures
>>> -
>>> -+ifeq ($(ARCH),xtensa)
>>> -+C_COMPILER_OPTIONS += -mtext-section-literals
>>> -+LINKER_OPTIONS += -mtext-section-literals
>>> -+endif
>>> -+
>>> - ifeq ($(ARCH),x32)
>>> - C_COMPILER_OPTIONS += -mx32
>>> - LINKER_OPTIONS += -mx32
>>> ---
>>> -2.39.2
>>> -
>>> diff --git a/package/chicken/chicken.mk b/package/chicken/chicken.mk
>>> index 0520280134ab..2667f7823d8a 100644
>>> --- a/package/chicken/chicken.mk
>>> +++ b/package/chicken/chicken.mk
>>> @@ -11,19 +11,9 @@ CHICKEN_LICENSE_FILES = LICENSE
>>>    CHICKEN_CPE_ID_VENDOR = call-cc
>>>    CHICKEN_INSTALL_STAGING = YES
>>>
>>> -# Chicken only uses the "arch" variable for some special-case compile
>>> -# arguments If it's empty, it tries to detect the arch host Filter out
>>> -# values that have an effect, or pass "unused" here
>>> -ifeq ($(NORMALIZED_ARCH),x86_64)
>>> -CHICKEN_ARCH = x86-64
>> changing the spelling to `x86-64` here is a good idea i think, because
>> chicken does add some flags. Other then that, i agree that the
>> C_COMPILER_OPTIMIZATION_OPTIONS approach is better here
> I believe that it should be done in a separate change as it has
> nothing to do with the topic of 'move literals into text section for
> xtensa architecture'.
>
> --
> Thanks.
> -- Max

Sorry, this email was sent by mistake -- the `git send-email` workflow 
is very new for me.


-Woody Douglass
diff mbox series

Patch

diff --git a/package/chicken/0001-xtensa-text-section-literals.patch b/package/chicken/0001-xtensa-text-section-literals.patch
deleted file mode 100644
index b93aaf9e218d..000000000000
--- a/package/chicken/0001-xtensa-text-section-literals.patch
+++ /dev/null
@@ -1,30 +0,0 @@ 
-From e8d177f4d4e1c6bc41787ea1621e323ff4ad493e Mon Sep 17 00:00:00 2001
-From: Woodrow Douglass <wdouglass@carnegierobotics.com>
-Date: Mon, 22 Jul 2024 08:50:37 -0400
-Subject: [PATCH] Move literals into text section for xtensa architecture
-
-Upstream: https://bugs.call-cc.org/ticket/1840
-Signed-off-by: Woodrow Douglass <wdouglass@carnegierobotics.com>
----
- Makefile.linux | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/Makefile.linux b/Makefile.linux
-index b628cda4..e97c2b94 100644
---- a/Makefile.linux
-+++ b/Makefile.linux
-@@ -52,6 +52,11 @@ USES_SONAME = yes
- 
- # architectures
- 
-+ifeq ($(ARCH),xtensa)
-+C_COMPILER_OPTIONS += -mtext-section-literals
-+LINKER_OPTIONS += -mtext-section-literals
-+endif
-+
- ifeq ($(ARCH),x32)
- C_COMPILER_OPTIONS += -mx32
- LINKER_OPTIONS += -mx32
--- 
-2.39.2
-
diff --git a/package/chicken/chicken.mk b/package/chicken/chicken.mk
index 0520280134ab..2667f7823d8a 100644
--- a/package/chicken/chicken.mk
+++ b/package/chicken/chicken.mk
@@ -11,19 +11,9 @@  CHICKEN_LICENSE_FILES = LICENSE
 CHICKEN_CPE_ID_VENDOR = call-cc
 CHICKEN_INSTALL_STAGING = YES
 
-# Chicken only uses the "arch" variable for some special-case compile
-# arguments If it's empty, it tries to detect the arch host Filter out
-# values that have an effect, or pass "unused" here
-ifeq ($(NORMALIZED_ARCH),x86_64)
-CHICKEN_ARCH = x86-64
-else ifeq ($(NORMALIZED_ARCH),xtensa)
-CHICKEN_ARCH = xtensa
-else
-CHICKEN_ARCH = unused
-endif
-
+# If ARCH is not set, it attempts to autodiscover. But it is anyway not used.
 CHICKEN_MAKE_OPTS = \
-	ARCH="$(CHICKEN_ARCH)" \
+	ARCH=unused \
 	C_COMPILER="$(TARGET_CC)" \
 	CXX_COMPILER="$(TARGET_CXX)" \
 	PREFIX=/usr \