diff mbox series

[1/1] package/grantlee: bump to 5.3.1 and enable for Qt6

Message ID 20240807145517.3019024-1-zgyarmati@zgyarmati.de
State Accepted
Headers show
Series [1/1] package/grantlee: bump to 5.3.1 and enable for Qt6 | expand

Commit Message

Zoltan Gyarmati Aug. 7, 2024, 2:55 p.m. UTC
Signed-off-by: Zoltan Gyarmati <zgyarmati@zgyarmati.de>
---
 package/grantlee/Config.in     |  8 +++++---
 package/grantlee/grantlee.hash |  2 +-
 package/grantlee/grantlee.mk   | 11 +++++++++--
 3 files changed, 15 insertions(+), 6 deletions(-)

Comments

Thomas Petazzoni Aug. 7, 2024, 8:59 p.m. UTC | #1
Hello Zoltan,

I have applied, but after doing some changes, see below.

On Wed,  7 Aug 2024 16:55:17 +0200
Zoltan Gyarmati <zgyarmati@zgyarmati.de> wrote:

> Signed-off-by: Zoltan Gyarmati <zgyarmati@zgyarmati.de>
> ---
>  package/grantlee/Config.in     |  8 +++++---
>  package/grantlee/grantlee.hash |  2 +-
>  package/grantlee/grantlee.mk   | 11 +++++++++--
>  3 files changed, 15 insertions(+), 6 deletions(-)

First of all, I've split into two commits: one doing the bump, one
enabling on Qt6.

> diff --git a/package/grantlee/Config.in b/package/grantlee/Config.in
> index 779306bc2e..a64f8a589b 100644
> --- a/package/grantlee/Config.in
> +++ b/package/grantlee/Config.in
> @@ -1,8 +1,10 @@
>  config BR2_PACKAGE_GRANTLEE
>  	bool "grantlee"
> -	depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE && BR2_PACKAGE_QT5
> -	select BR2_PACKAGE_QT5SCRIPT
> -	select BR2_PACKAGE_QT5BASE_GUI
> +	depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE && BR2_PACKAGE_QT5 || BR2_PACKAGE_QT6

I've added parenthesis around (BR2_PACKAGE_QT5_JSCORE_AVAILABLE &&
BR2_PACKAGE_QT5) to clarify the priority of the operators.

> diff --git a/package/grantlee/grantlee.hash b/package/grantlee/grantlee.hash
> index 6508aa70cc..57061fb03f 100644
> --- a/package/grantlee/grantlee.hash
> +++ b/package/grantlee/grantlee.hash
> @@ -1,5 +1,5 @@
>  # Locally calculated
> -sha256  139acee5746b957bdf1327ec0d97c604d4c0b9be42aec5d584297cb5ed6a990a  grantlee-5.2.0.tar.gz
> +sha256  ba288ae9ed37ec0c3622ceb40ae1f7e1e6b2ea89216ad8587f0863d64be24f06  grantlee-5.3.1.tar.gz
>  
>  # Hash for license file
>  sha256  a9bdde5616ecdd1e980b44f360600ee8783b1f99b8cc83a2beb163a0a390e861  COPYING.LIB

The hash of the license file had changed, perhaps you forgot to check
"make legal-info"? So I fixed that up and explained the license change
in the commit log.

Applied with those changes. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/grantlee/Config.in b/package/grantlee/Config.in
index 779306bc2e..a64f8a589b 100644
--- a/package/grantlee/Config.in
+++ b/package/grantlee/Config.in
@@ -1,8 +1,10 @@ 
 config BR2_PACKAGE_GRANTLEE
 	bool "grantlee"
-	depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE && BR2_PACKAGE_QT5
-	select BR2_PACKAGE_QT5SCRIPT
-	select BR2_PACKAGE_QT5BASE_GUI
+	depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE && BR2_PACKAGE_QT5 || BR2_PACKAGE_QT6
+	select BR2_PACKAGE_QT5SCRIPT if BR2_PACKAGE_QT5
+	select BR2_PACKAGE_QT5BASE_GUI if BR2_PACKAGE_QT5
+	select BR2_PACKAGE_QT6BASE_GUI if BR2_PACKAGE_QT6
+	select BR2_PACKAGE_QT6DECLARATIVE if BR2_PACKAGE_QT6
 	help
 	  Qt implementation of the Django template framework
 
diff --git a/package/grantlee/grantlee.hash b/package/grantlee/grantlee.hash
index 6508aa70cc..57061fb03f 100644
--- a/package/grantlee/grantlee.hash
+++ b/package/grantlee/grantlee.hash
@@ -1,5 +1,5 @@ 
 # Locally calculated
-sha256  139acee5746b957bdf1327ec0d97c604d4c0b9be42aec5d584297cb5ed6a990a  grantlee-5.2.0.tar.gz
+sha256  ba288ae9ed37ec0c3622ceb40ae1f7e1e6b2ea89216ad8587f0863d64be24f06  grantlee-5.3.1.tar.gz
 
 # Hash for license file
 sha256  a9bdde5616ecdd1e980b44f360600ee8783b1f99b8cc83a2beb163a0a390e861  COPYING.LIB
diff --git a/package/grantlee/grantlee.mk b/package/grantlee/grantlee.mk
index 7079679ca4..387558319b 100644
--- a/package/grantlee/grantlee.mk
+++ b/package/grantlee/grantlee.mk
@@ -4,11 +4,18 @@ 
 #
 ################################################################################
 
-GRANTLEE_VERSION = 5.2.0
+GRANTLEE_VERSION = 5.3.1
 GRANTLEE_SITE = $(call github,steveire,grantlee,v$(GRANTLEE_VERSION))
 GRANTLEE_INSTALL_STAGING = YES
 GRANTLEE_LICENSE = LGPL-2.1+
 GRANTLEE_LICENSE_FILES = COPYING.LIB
-GRANTLEE_DEPENDENCIES = qt5base qt5script
+ifeq ($(BR2_PACKAGE_QT5BASE),y)
+GRANTLEE_DEPENDENCIES += qt5base qt5script
+endif
+ifeq ($(BR2_PACKAGE_QT6BASE),y)
+GRANTLEE_DEPENDENCIES += qt6base qt6declarative
+GRANTLEE_CONF_OPTS += \
+	-DGRANTLEE_BUILD_WITH_QT6=ON
+endif
 
 $(eval $(cmake-package))