diff mbox series

[3/3] package/pkg-kconfig: cleanup savedefconfig MAKE

Message ID 20240729-pkg-kconfig-ppd-v1-3-36c901c73a7b@collins.com
State Accepted
Headers show
Series package/pkg-kconfig: fixes for per-package-directory | expand

Commit Message

Brandon Maier July 29, 2024, 4:19 p.m. UTC
The kconfig infra defines a 'PKG_KCONFIG_MAKE' var that wraps all the
standard kconfig options. Switch to this so we aren't duplicating the
logic.

Signed-off-by: Brandon Maier <brandon.maier@collins.com>
---
 package/pkg-kconfig.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Peter Korsgaard Sept. 2, 2024, 10:19 a.m. UTC | #1
>>>>> "Brandon" == Brandon Maier via buildroot <buildroot@buildroot.org> writes:

 > The kconfig infra defines a 'PKG_KCONFIG_MAKE' var that wraps all the
 > standard kconfig options. Switch to this so we aren't duplicating the
 > logic.

 > Signed-off-by: Brandon Maier <brandon.maier@collins.com>

Committed to 2024.02.x and 2024.05.x, thanks.
diff mbox series

Patch

diff --git a/package/pkg-kconfig.mk b/package/pkg-kconfig.mk
index 684342bcef..8000de16c4 100644
--- a/package/pkg-kconfig.mk
+++ b/package/pkg-kconfig.mk
@@ -33,8 +33,7 @@  PKG_KCONFIG_COMMON_OPTS = \
 # Macro to save the defconfig file
 # $(1): the name of the package in upper-case letters
 define kconfig-package-savedefconfig
-	$($(1)_MAKE_ENV) $($(1)_MAKE) -C $($(1)_DIR) \
-		$(PKG_KCONFIG_COMMON_OPTS) $($(1)_KCONFIG_OPTS) savedefconfig
+	$($(1)_KCONFIG_MAKE) savedefconfig
 endef
 
 # The correct way to regenerate a .config file is to use 'make olddefconfig'.