diff mbox series

[2/3] package/pkg-kconfig: fix *-diff-config under ppd

Message ID 20240729-pkg-kconfig-ppd-v1-2-36c901c73a7b@collins.com
State Accepted
Headers show
Series package/pkg-kconfig: fixes for per-package-directory | expand

Commit Message

Brandon Maier July 29, 2024, 4:19 p.m. UTC
The 'linux-diff-config' target fails with the below error when
PER_PACKAGE_DIRECTORIES is enabled and the 'host-finalize' target hasn't
run yet.

  scripts/Kconfig.include:39: C compiler '.../buildroot/output/host/bin/arm-buildroot-linux-gnueabihf-gcc' not found

The 'PPD' variable isn't defined for this target, so 'BR_PATH' falls
back to the final host directory.

Signed-off-by: Brandon Maier <brandon.maier@collins.com>
---
 package/pkg-kconfig.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Korsgaard Sept. 2, 2024, 10:19 a.m. UTC | #1
>>>>> "Brandon" == Brandon Maier via buildroot <buildroot@buildroot.org> writes:

 > The 'linux-diff-config' target fails with the below error when
 > PER_PACKAGE_DIRECTORIES is enabled and the 'host-finalize' target hasn't
 > run yet.

 >   scripts/Kconfig.include:39: C compiler '.../buildroot/output/host/bin/arm-buildroot-linux-gnueabihf-gcc' not found

 > The 'PPD' variable isn't defined for this target, so 'BR_PATH' falls
 > back to the final host directory.

 > Signed-off-by: Brandon Maier <brandon.maier@collins.com>

Committed to 2024.02.x and 2024.05.x, thanks.
diff mbox series

Patch

diff --git a/package/pkg-kconfig.mk b/package/pkg-kconfig.mk
index 6bf3d6b4be..684342bcef 100644
--- a/package/pkg-kconfig.mk
+++ b/package/pkg-kconfig.mk
@@ -301,6 +301,7 @@  endif
 # defconfig + fragments (if any) and the current configuration.
 # Note: it preserves the timestamp of the current configuration when moving it
 # around.
+$(1)-diff-config: PKG=$(2)
 $(1)-diff-config: $(1)-check-configuration-done
 	$$(Q)cp -a $$($(2)_DIR)/$$($(2)_KCONFIG_DOTCONFIG) $$($(2)_DIR)/.config.dc.bak
 	$$(call kconfig-package-merge-config,$(2),$$($(2)_DIR)/$$($(2)_KCONFIG_DOTCONFIG),\