diff mbox series

[v2,1/2] package/rpi-utils: new package

Message ID 20240725101711.2443524-2-gael.portay@rtone.fr
State Changes Requested
Headers show
Series rpi-utils replaces rpi-userland | expand

Commit Message

Gaël PORTAY July 25, 2024, 10:17 a.m. UTC
The package rpi-userland has been marked as ancient and deprecated[1].

The useful tools (dtoverlay, dtmerge, vcmailbox, vcgencmd) were moved to
the repository rpi-utils since then.

This adds the new package rpi-utils at latest commit as there is no
tagged commit.

[1]: https://github.com/raspberrypi/userland/commit/96a7334ae9d5fc9db7ac92e59852377df63f1848

Signed-off-by: Gaël PORTAY <gael.portay@rtone.fr>
---
 DEVELOPERS                       |  3 +++
 package/Config.in                |  1 +
 package/rpi-utils/Config.in      | 14 ++++++++++++++
 package/rpi-utils/rpi-utils.hash |  3 +++
 package/rpi-utils/rpi-utils.mk   | 18 ++++++++++++++++++
 5 files changed, 39 insertions(+)
 create mode 100644 package/rpi-utils/Config.in
 create mode 100644 package/rpi-utils/rpi-utils.hash
 create mode 100644 package/rpi-utils/rpi-utils.mk

Comments

Gaël PORTAY July 25, 2024, 10:32 a.m. UTC | #1
All,

On Thu Jul 25, 2024 at 12:17 PM CEST, =?UTF-8?q?Ga=C3=ABl=20PORTAY?= wrote:
> +comment "rpi-utils needs a glibc or musl toolchain w/ dynamic library"
> +	depends on BR2_STATIC_LIBS
> +	depends on !BR2_TOOLCHAIN_USES_UCLIBC

Hum, the depends on is wrong.

Thomas, I will wait for the bootlin toolchain rebuilt and re-run
utils/test-pkg to check for new errors.

Sorry.
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 7d6b364e58..0f10d0dc30 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1204,6 +1204,9 @@  N:	Frank Vanbever <frank.vanbever@mind.be>
 F:	package/libmodsecurity/
 F:	package/nginx-modsecurity/
 
+N:	Gaël PORTAY <gael.portay@rtone.fr>
+F:	package/rpi-utils/
+
 N:	Gao Xiang <hsiangkao@aol.com>
 F:	package/erofs-utils/
 
diff --git a/package/Config.in b/package/Config.in
index 5f0e7491c8..15b286b2fb 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -457,6 +457,7 @@  menu "Firmware"
 	source "package/qoriq-fm-ucode/Config.in"
 	source "package/rcw-smarc-sal28/Config.in"
 	source "package/rpi-firmware/Config.in"
+	source "package/rpi-utils/Config.in"
 	source "package/sunxi-boards/Config.in"
 	source "package/ts4900-fpga/Config.in"
 	source "package/ux500-firmware/Config.in"
diff --git a/package/rpi-utils/Config.in b/package/rpi-utils/Config.in
new file mode 100644
index 0000000000..b2a25f36f5
--- /dev/null
+++ b/package/rpi-utils/Config.in
@@ -0,0 +1,14 @@ 
+config BR2_PACKAGE_RPI_UTILS
+	bool "rpi-utils"
+	depends on !BR2_STATIC_LIBS # dtc
+	depends on !BR2_TOOLCHAIN_USES_UCLIBC # no reallocarray
+	select BR2_PACKAGE_DTC
+	help
+	  A collection of scripts and simple applications for the
+	  Raspberry Pi.
+
+	  https://github.com/raspberrypi/utils/
+
+comment "rpi-utils needs a glibc or musl toolchain w/ dynamic library"
+	depends on BR2_STATIC_LIBS
+	depends on !BR2_TOOLCHAIN_USES_UCLIBC
diff --git a/package/rpi-utils/rpi-utils.hash b/package/rpi-utils/rpi-utils.hash
new file mode 100644
index 0000000000..a6612373b0
--- /dev/null
+++ b/package/rpi-utils/rpi-utils.hash
@@ -0,0 +1,3 @@ 
+# Locally computed
+sha256  c35932e501b43e5fb48cfc488aadc4a8bbceb0e9e6dafdf6c7cd2066b58acd61  rpi-utils-a1d522f0f1b50858a44fac80523a2bd80098e789.tar.gz
+sha256  731da956431d1a7c5073e7ee5ebe01f54e359c5339310b32f0893c6fe6507d5a  LICENCE
diff --git a/package/rpi-utils/rpi-utils.mk b/package/rpi-utils/rpi-utils.mk
new file mode 100644
index 0000000000..49db3aef9f
--- /dev/null
+++ b/package/rpi-utils/rpi-utils.mk
@@ -0,0 +1,18 @@ 
+################################################################################
+#
+# rpi-utils
+#
+################################################################################
+
+RPI_UTILS_VERSION = a1d522f0f1b50858a44fac80523a2bd80098e789
+RPI_UTILS_SITE = $(call github,raspberrypi,utils,$(RPI_UTILS_VERSION))
+RPI_UTILS_LICENSE = BSD-3-Clause
+RPI_UTILS_LICENSE_FILES = LICENCE
+RPI_UTILS_INSTALL_STAGING = YES
+RPI_UTILS_DEPENDENCIES = dtc
+
+# Ensure the internal dtovl remains an archive object and it is not built as a
+# dynamic library that is linked by other utilities; as it is not installed.
+RPI_UTILS_CONF_OPTS = -DSTATIC=STATIC
+
+$(eval $(cmake-package))