diff mbox series

[1/1] package/rtty: bump to version 8.1.2

Message ID 20240723133004.652232-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/rtty: bump to version 8.1.2 | expand

Commit Message

Fabrice Fontaine July 23, 2024, 1:30 p.m. UTC
- Drop patch (already in version)
- This bump will fix the following build failure with musl >= 1.2.5
  thanks to
  https://github.com/zhaojh329/rtty/commit/eb6394c3d83a21a8825e47b40659cfe0ead33b6f:

  /home/autobuild/autobuild/instance-22/output-1/build/rtty-8.1.0/src/file.c: In function 'start_upload_file':
  /home/autobuild/autobuild/instance-22/output-1/build/rtty-8.1.0/src/file.c:156:24: error: implicit declaration of function 'basename' [-Werror=implicit-function-declaration]
    156 |     const char *name = basename(path);
        |                        ^~~~~~~~

https://github.com/zhaojh329/rtty/releases/tag/v8.1.2
https://github.com/zhaojh329/rtty/releases/tag/v8.1.1

Fixes:
 - http://autobuild.buildroot.org/results/382405b421a8ea7b5b3beb553f47fa20427fa3c3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 .checkpackageignore                           |  1 -
 ...keLists.txt-prefer-pkg_check_modules.patch | 40 -------------------
 package/rtty/rtty.hash                        |  2 +-
 package/rtty/rtty.mk                          |  2 +-
 4 files changed, 2 insertions(+), 43 deletions(-)
 delete mode 100644 package/rtty/0001-CMakeLists.txt-prefer-pkg_check_modules.patch

Comments

Thomas Petazzoni Aug. 2, 2024, 6:02 p.m. UTC | #1
On Tue, 23 Jul 2024 15:30:04 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> - Drop patch (already in version)
> - This bump will fix the following build failure with musl >= 1.2.5
>   thanks to
>   https://github.com/zhaojh329/rtty/commit/eb6394c3d83a21a8825e47b40659cfe0ead33b6f:
> 
>   /home/autobuild/autobuild/instance-22/output-1/build/rtty-8.1.0/src/file.c: In function 'start_upload_file':
>   /home/autobuild/autobuild/instance-22/output-1/build/rtty-8.1.0/src/file.c:156:24: error: implicit declaration of function 'basename' [-Werror=implicit-function-declaration]
>     156 |     const char *name = basename(path);
>         |                        ^~~~~~~~
> 
> https://github.com/zhaojh329/rtty/releases/tag/v8.1.2
> https://github.com/zhaojh329/rtty/releases/tag/v8.1.1
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/382405b421a8ea7b5b3beb553f47fa20427fa3c3
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  .checkpackageignore                           |  1 -
>  ...keLists.txt-prefer-pkg_check_modules.patch | 40 -------------------
>  package/rtty/rtty.hash                        |  2 +-
>  package/rtty/rtty.mk                          |  2 +-
>  4 files changed, 2 insertions(+), 43 deletions(-)
>  delete mode 100644 package/rtty/0001-CMakeLists.txt-prefer-pkg_check_modules.patch

Applied to master, thanks.

Thomas
Peter Korsgaard Sept. 3, 2024, 4:27 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > - Drop patch (already in version)
 > - This bump will fix the following build failure with musl >= 1.2.5
 >   thanks to
 >   https://github.com/zhaojh329/rtty/commit/eb6394c3d83a21a8825e47b40659cfe0ead33b6f:

 >   /home/autobuild/autobuild/instance-22/output-1/build/rtty-8.1.0/src/file.c: In function 'start_upload_file':
 >   /home/autobuild/autobuild/instance-22/output-1/build/rtty-8.1.0/src/file.c:156:24: error: implicit declaration of function 'basename' [-Werror=implicit-function-declaration]
 >     156 |     const char *name = basename(path);
 >         |                        ^~~~~~~~

 > https://github.com/zhaojh329/rtty/releases/tag/v8.1.2
 > https://github.com/zhaojh329/rtty/releases/tag/v8.1.1

 > Fixes:
 >  - http://autobuild.buildroot.org/results/382405b421a8ea7b5b3beb553f47fa20427fa3c3

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.05.x, thanks.
diff mbox series

Patch

diff --git a/.checkpackageignore b/.checkpackageignore
index baa4d20d73..6fd873a3c8 100644
--- a/.checkpackageignore
+++ b/.checkpackageignore
@@ -1211,7 +1211,6 @@  package/rpi-userland/0006-interface-vcos-pthreads-CMakeLists.txt-fix-build-wit.p
 package/rpi-userland/0007-GLES2-gl2ext.h-add-GLint64-GLuint64-and-GLsync-typed.patch lib_patch.Upstream
 package/rt-tests/0001-Fix-a-build-issue-with-uClibc-ng.patch lib_patch.Upstream
 package/rtorrent/0001-Added--disable-execinfo-option-to-configure.patch lib_patch.Upstream
-package/rtty/0001-CMakeLists.txt-prefer-pkg_check_modules.patch lib_patch.Upstream
 package/rubix/0001-dont-use-legacy-functions.patch lib_patch.Upstream
 package/rubix/0002-misc-fixes.patch lib_patch.Sob lib_patch.Upstream
 package/rygel/S99rygel Shellcheck lib_sysv.Indent lib_sysv.Variables
diff --git a/package/rtty/0001-CMakeLists.txt-prefer-pkg_check_modules.patch b/package/rtty/0001-CMakeLists.txt-prefer-pkg_check_modules.patch
deleted file mode 100644
index 3714050445..0000000000
--- a/package/rtty/0001-CMakeLists.txt-prefer-pkg_check_modules.patch
+++ /dev/null
@@ -1,40 +0,0 @@ 
-From 565c003ac412c9b0fa39d208d4a911f4300477c3 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sun, 26 Feb 2023 20:39:11 +0100
-Subject: [PATCH] CMakeLists.txt: prefer pkg_check_modules
-
-Prefer pkg_check_modules over find_package to avoid the following static
-build failure with openssl and -latomic:
-
-/home/autobuild/autobuild/instance-8/output-1/host/lib/gcc/sparc-buildroot-linux-uclibc/10.4.0/../../../../sparc-buildroot-linux-uclibc/bin/ld: /home/autobuild/autobuild/instance-8/output-1/host/sparc-buildroot-linux-uclibc/sysroot/usr/lib/libssl.a(ssl_cert.o): in function `ssl_cert_free':
-ssl_cert.c:(.text+0x53c): undefined reference to `__atomic_fetch_sub_4'
-
-Fixes:
- - http://autobuild.buildroot.org/results/f606bb15bf4f88ba29ef0795413e13acc9cd0976
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/zhaojh329/ssl/pull/4]
----
- CMakeLists.txt | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/ssl/CMakeLists.txt b/src/ssl/CMakeLists.txt
-index 4868bf7..36488c7 100644
---- a/src/ssl/CMakeLists.txt
-+++ b/src/ssl/CMakeLists.txt
-@@ -14,10 +14,10 @@ endif()
- 
- find_package(PkgConfig QUIET)
- 
--find_package(OpenSSL)
-+pkg_check_modules(OPENSSL openssl)
- 
- if (NOT OPENSSL_FOUND)
--    pkg_check_modules(OPENSSL openssl)
-+    find_package(OpenSSL)
- endif()
- 
- find_package(WolfSSL)
--- 
-2.39.1
-
diff --git a/package/rtty/rtty.hash b/package/rtty/rtty.hash
index a6ccb5c2e6..004314eea1 100644
--- a/package/rtty/rtty.hash
+++ b/package/rtty/rtty.hash
@@ -1,2 +1,2 @@ 
-sha256  e634939bae62bf3d52ceebae5df00179629d214634b93464eeb2294406512b30  rtty-8.1.0.tar.gz
+sha256  522b0fc5e032c3b84ac707abce8ac4ff5609900011f8f300ce4f4246abac0acc  rtty-8.1.2.tar.gz
 sha256  99efed4bbc0b62f96f999ef23399e38234fb91651af734fd389a52b033a85b55  LICENSE
diff --git a/package/rtty/rtty.mk b/package/rtty/rtty.mk
index b2fac14432..618971c9a3 100644
--- a/package/rtty/rtty.mk
+++ b/package/rtty/rtty.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-RTTY_VERSION = 8.1.0
+RTTY_VERSION = 8.1.2
 RTTY_SITE = https://github.com/zhaojh329/rtty/releases/download/v$(RTTY_VERSION)
 RTTY_LICENSE = MIT
 RTTY_LICENSE_FILES = LICENSE