diff mbox series

[1/1] package/mtd: fix zlib build

Message ID 20240723095614.993000-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/mtd: fix zlib build | expand

Commit Message

Fabrice Fontaine July 23, 2024, 9:56 a.m. UTC
Commit bb19ffeaab5ba4be0a1033ca326b25d4d4e8203f forgot to move
host-pkgconf dependency from BR2_PACKAGE_MTD_JFFS_UTILS condition to the
new BR2_PACKAGE_ZLIB condition resulting in the following build failure:

hecking for ZLIB... no
configure: error: cannot find zlib

Fixes: bb19ffeaab5ba4be0a1033ca326b25d4d4e8203f
 - http://autobuild.buildroot.org/results/7cbeead738af6302d5f0048a443e3b57d6776bb2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/mtd/mtd.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Thomas Petazzoni July 23, 2024, 10:24 a.m. UTC | #1
On Tue, 23 Jul 2024 11:56:14 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Commit bb19ffeaab5ba4be0a1033ca326b25d4d4e8203f forgot to move
> host-pkgconf dependency from BR2_PACKAGE_MTD_JFFS_UTILS condition to the
> new BR2_PACKAGE_ZLIB condition resulting in the following build failure:
> 
> hecking for ZLIB... no
> configure: error: cannot find zlib
> 
> Fixes: bb19ffeaab5ba4be0a1033ca326b25d4d4e8203f
>  - http://autobuild.buildroot.org/results/7cbeead738af6302d5f0048a443e3b57d6776bb2
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/mtd/mtd.mk | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)

Applied to master, thanks.

Thomas
Brandon Maier July 23, 2024, 12:27 p.m. UTC | #2
Hi Fabric,

On Tue Jul 23, 2024 at 9:56 AM UTC, Fabrice Fontaine wrote:
> Commit bb19ffeaab5ba4be0a1033ca326b25d4d4e8203f forgot to move
> host-pkgconf dependency from BR2_PACKAGE_MTD_JFFS_UTILS condition to the
> new BR2_PACKAGE_ZLIB condition resulting in the following build failure:
>
> hecking for ZLIB... no
> configure: error: cannot find zlib
>
> Fixes: bb19ffeaab5ba4be0a1033ca326b25d4d4e8203f
>  - http://autobuild.buildroot.org/results/7cbeead738af6302d5f0048a443e3b57d6776bb2

Thank you for fixing this!
Brandon Maier

>
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/mtd/mtd.mk | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
> index fe40cf6c06..d3444c88f2 100644
> --- a/package/mtd/mtd.mk
> +++ b/package/mtd/mtd.mk
> @@ -28,7 +28,7 @@ MTD_CONF_OPTS += --without-lzo
>  endif
>
>  ifeq ($(BR2_PACKAGE_ZLIB),y)
> -MTD_DEPENDENCIES += zlib
> +MTD_DEPENDENCIES += host-pkgconf zlib
>  MTD_CONF_OPTS += --with-zlib
>  else
>  MTD_CONF_OPTS += --without-zlib
> @@ -37,7 +37,6 @@ endif
>  MTD_CONF_ENV += LDFLAGS="$(MTD_LDFLAGS)"
>
>  ifeq ($(BR2_PACKAGE_MTD_JFFS_UTILS),y)
> -MTD_DEPENDENCIES += host-pkgconf
>  MTD_CONF_OPTS += --with-jffs
>  else
>  MTD_CONF_OPTS += --without-jffs
diff mbox series

Patch

diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index fe40cf6c06..d3444c88f2 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -28,7 +28,7 @@  MTD_CONF_OPTS += --without-lzo
 endif
 
 ifeq ($(BR2_PACKAGE_ZLIB),y)
-MTD_DEPENDENCIES += zlib
+MTD_DEPENDENCIES += host-pkgconf zlib
 MTD_CONF_OPTS += --with-zlib
 else
 MTD_CONF_OPTS += --without-zlib
@@ -37,7 +37,6 @@  endif
 MTD_CONF_ENV += LDFLAGS="$(MTD_LDFLAGS)"
 
 ifeq ($(BR2_PACKAGE_MTD_JFFS_UTILS),y)
-MTD_DEPENDENCIES += host-pkgconf
 MTD_CONF_OPTS += --with-jffs
 else
 MTD_CONF_OPTS += --without-jffs