diff mbox series

[1/1] package/parsec: new package

Message ID 20240723070439.4119145-1-kazemi.ms@gmail.com
State New
Headers show
Series [1/1] package/parsec: new package | expand

Commit Message

Saeed Kazemi July 23, 2024, 7:04 a.m. UTC
Hardware/platform abstraction service for TPMs, HSMs, and Root of Trust

https://github.com/parallaxsecond/parsec.git

Signed-off-by: Saeed Kazemi <kazemi.ms@gmail.com>
---
 DEVELOPERS                 |  1 +
 package/Config.in          |  1 +
 package/parsec/Config.in   | 15 +++++++++++++++
 package/parsec/parsec.hash |  3 +++
 package/parsec/parsec.mk   | 12 ++++++++++++
 5 files changed, 32 insertions(+)
 create mode 100644 package/parsec/Config.in
 create mode 100644 package/parsec/parsec.hash
 create mode 100644 package/parsec/parsec.mk
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 3650321d6f..58d6368339 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -2866,6 +2866,7 @@  F:	package/biosdevname/
 
 N:	Saeed Kazemi <kazemi.ms@gmail.com>
 F:	package/eza/
+F:	package/parsec/
 F:	package/parsec-tool/
 F:	package/procs/
 F:	package/mxt-app/
diff --git a/package/Config.in b/package/Config.in
index a0d78518b6..8a7c257c85 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1589,6 +1589,7 @@  menu "Crypto"
 	source "package/mbedtls/Config.in"
 	source "package/nettle/Config.in"
 	source "package/openssl/Config.in"
+	source "package/parsec/Config.in"
 	source "package/parsec-tool/Config.in"
 	source "package/pkcs11-helper/Config.in"
 	source "package/rhash/Config.in"
diff --git a/package/parsec/Config.in b/package/parsec/Config.in
new file mode 100644
index 0000000000..378e8b58b4
--- /dev/null
+++ b/package/parsec/Config.in
@@ -0,0 +1,15 @@ 
+config BR2_PACKAGE_PARSEC
+	bool "parsec"
+	depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
+	select BR2_PACKAGE_HOST_RUSTC
+	help
+	  Hardware/platform abstraction service for TPMs, HSMs, and
+	  Root of Trust
+	  PARSEC is the Platform AbstRaction for SECurity, an
+	  open-source initiative to provide a common API to hardware
+	  security and cryptographic services in a platform-agnostic
+	  way. This abstraction layer keeps workloads decoupled from
+	  physical platform details, enabling cloud-native delivery
+	  flows within the data center and at the edge.
+
+	  https://github.com/parallaxsecond/parsec.git
diff --git a/package/parsec/parsec.hash b/package/parsec/parsec.hash
new file mode 100644
index 0000000000..e1d7b4fbc9
--- /dev/null
+++ b/package/parsec/parsec.hash
@@ -0,0 +1,3 @@ 
+# Locally computed
+sha256  0b69c30c7e40c65e3c74450e0baf1e3f821ffa624a6dc7aa49f5aa976c42fda0  parsec-1.4.1-cargo2.tar.gz
+sha256  cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30  LICENSE
diff --git a/package/parsec/parsec.mk b/package/parsec/parsec.mk
new file mode 100644
index 0000000000..eec9f4d7a3
--- /dev/null
+++ b/package/parsec/parsec.mk
@@ -0,0 +1,12 @@ 
+################################################################################
+#
+# parsec
+#
+################################################################################
+
+PARSEC_VERSION = 1.4.1
+PARSEC_SITE = $(call github,parallaxsecond,parsec,$(PARSEC_VERSION))
+PARSEC_LICENSE = Apache-2.0
+PARSEC_LICENSE_FILES = LICENSE
+
+$(eval $(cargo-package))