diff mbox series

[1/1] package/libfreefare: bump to latest git commit

Message ID 20240721172843.2342941-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libfreefare: bump to latest git commit | expand

Commit Message

Fabrice Fontaine July 21, 2024, 5:28 p.m. UTC
This bump will fix the following build failure with gcc >= 14 thanks to
https://github.com/nfc-tools/libfreefare/commit/494233d33b3a9d21da1bb0f1c59606820afe4691

mifare_desfire_crypto.c: In function 'cmac':
mifare_desfire_crypto.c:139:23: error: implicit declaration of function 'malloc' [-Wimplicit-function-declaration]
  139 |     uint8_t *buffer = malloc (padded_data_length (len, kbs));
      |                       ^~~~~~
mifare_desfire_crypto.c:69:1: note: include '<stdlib.h>' or provide a declaration of 'malloc'
   68 | #include "freefare_internal.h"
  +++ |+#include <stdlib.h>
   69 |

Fixes:
 - http://autobuild.buildroot.org/results/778be216f62b8c2e05aba1b3e297dab0c6c6ccd0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libfreefare/libfreefare.hash | 4 ++--
 package/libfreefare/libfreefare.mk   | 9 ++++-----
 2 files changed, 6 insertions(+), 7 deletions(-)

Comments

Thomas Petazzoni July 22, 2024, 12:16 p.m. UTC | #1
On Sun, 21 Jul 2024 19:28:43 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> This bump will fix the following build failure with gcc >= 14 thanks to
> https://github.com/nfc-tools/libfreefare/commit/494233d33b3a9d21da1bb0f1c59606820afe4691
> 
> mifare_desfire_crypto.c: In function 'cmac':
> mifare_desfire_crypto.c:139:23: error: implicit declaration of function 'malloc' [-Wimplicit-function-declaration]
>   139 |     uint8_t *buffer = malloc (padded_data_length (len, kbs));
>       |                       ^~~~~~
> mifare_desfire_crypto.c:69:1: note: include '<stdlib.h>' or provide a declaration of 'malloc'
>    68 | #include "freefare_internal.h"
>   +++ |+#include <stdlib.h>
>    69 |
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/778be216f62b8c2e05aba1b3e297dab0c6c6ccd0
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/libfreefare/libfreefare.hash | 4 ++--
>  package/libfreefare/libfreefare.mk   | 9 ++++-----
>  2 files changed, 6 insertions(+), 7 deletions(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 31, 2024, 9:45 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > This bump will fix the following build failure with gcc >= 14 thanks to
 > https://github.com/nfc-tools/libfreefare/commit/494233d33b3a9d21da1bb0f1c59606820afe4691

 > mifare_desfire_crypto.c: In function 'cmac':
 > mifare_desfire_crypto.c:139:23: error: implicit declaration of function 'malloc' [-Wimplicit-function-declaration]
 >   139 |     uint8_t *buffer = malloc (padded_data_length (len, kbs));
 >       |                       ^~~~~~
 > mifare_desfire_crypto.c:69:1: note: include '<stdlib.h>' or provide a declaration of 'malloc'
 >    68 | #include "freefare_internal.h"
 >   +++ |+#include <stdlib.h>
 >    69 |

 > Fixes:
 >  - http://autobuild.buildroot.org/results/778be216f62b8c2e05aba1b3e297dab0c6c6ccd0

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.05.x, thanks.
diff mbox series

Patch

diff --git a/package/libfreefare/libfreefare.hash b/package/libfreefare/libfreefare.hash
index 9115518a3f..6ef30513d1 100644
--- a/package/libfreefare/libfreefare.hash
+++ b/package/libfreefare/libfreefare.hash
@@ -1,5 +1,5 @@ 
-# From https://github.com/nfc-tools/libfreefare/releases/download/libfreefare-0.4.0/libfreefare-0.4.0.tar.bz2
-sha256  bfa31d14a99a1247f5ed49195d6373de512e3eb75bf1627658b40cf7f876bc64  libfreefare-0.4.0.tar.bz2
+# Locally computed
+sha256  48db20cccdf3435a9f205bcbb67dbd4eec055991d21840fb419874efd9ce9df8  libfreefare-c2b0cfa4b9fb0e4be88604f00b7a2405618d5abc.tar.gz
 
 # Hash for license file:
 sha256  be6209dfd763a0ba77fbe990cfd2512804441d8b5f0cad927baa3341b50fcade  COPYING
diff --git a/package/libfreefare/libfreefare.mk b/package/libfreefare/libfreefare.mk
index 16f15b34e4..7065c441dc 100644
--- a/package/libfreefare/libfreefare.mk
+++ b/package/libfreefare/libfreefare.mk
@@ -4,14 +4,13 @@ 
 #
 ################################################################################
 
-LIBFREEFARE_VERSION = 0.4.0
-LIBFREEFARE_SOURCE = libfreefare-$(LIBFREEFARE_VERSION).tar.bz2
-# Do not use the github helper here, the generated tarball is *NOT*
-# the same as the one uploaded by upstream for the release.
-LIBFREEFARE_SITE = https://github.com/nfc-tools/libfreefare/releases/download/libfreefare-$(LIBFREEFARE_VERSION)
+LIBFREEFARE_VERSION = c2b0cfa4b9fb0e4be88604f00b7a2405618d5abc
+LIBFREEFARE_SITE = $(call github,nfc-tools,libfreefare,$(LIBFREEFARE_VERSION))
 LIBFREEFARE_DEPENDENCIES = host-pkgconf libnfc openssl
 LIBFREEFARE_LICENSE = LGPL-3.0+ with exception
 LIBFREEFARE_LICENSE_FILES = COPYING
+# From git
+LIBFREEFARE_AUTORECONF = YES
 LIBFREEFARE_CONF_ENV += LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
 
 $(eval $(autotools-package))