diff mbox series

[1/1] Revert "package/gnutls: add tpm2-tss optional dependency"

Message ID 20240721090024.371743-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] Revert "package/gnutls: add tpm2-tss optional dependency" | expand

Commit Message

Fabrice Fontaine July 21, 2024, 9 a.m. UTC
This reverts commit caff4179a4481233257f5f475ca57ce9061af900 as the
following circular dependency is created if BR2_PACKAGE_TPM2_TSS_FAPI
is selected: tpm2-tss -> libcurl -> gnutls -> tmp2-tss
resulting in the following build failure of libcurl or rtmpdump:

configure: error: TLS not detected, you will not be able to use HTTPS, FTPS, NTLM and more.
Use --with-openssl, --with-gnutls, --with-wolfssl, --with-mbedtls, --with-schannel, --with-secure-transport, --with-amissl, --with-bearssl or --with-rustls to address this.

[...]

In file included from rtmp.c:32:
rtmp_sys.h:110:10: fatal error: gnutls/gnutls.h: No such file or directory
  110 | #include <gnutls/gnutls.h>
      |          ^~~~~~~~~~~~~~~~~

Fixes: caff4179a4481233257f5f475ca57ce9061af900
 - http://autobuild.buildroot.org/results/72e1843de650c9ed4795f1141e9fd485b71a14c3
 - http://autobuild.buildroot.org/results/918f0f7efa810b17f6d2266a890bf0150cbed146

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gnutls/gnutls.mk | 8 --------
 1 file changed, 8 deletions(-)

Comments

Baruch Siach July 21, 2024, 9:39 a.m. UTC | #1
Hi Fabrice,

On Sun, Jul 21 2024, Fabrice Fontaine wrote:
> This reverts commit caff4179a4481233257f5f475ca57ce9061af900 as the
> following circular dependency is created if BR2_PACKAGE_TPM2_TSS_FAPI
> is selected: tpm2-tss -> libcurl -> gnutls -> tmp2-tss
> resulting in the following build failure of libcurl or rtmpdump:
>
> configure: error: TLS not detected, you will not be able to use HTTPS, FTPS, NTLM and more.
> Use --with-openssl, --with-gnutls, --with-wolfssl, --with-mbedtls, --with-schannel, --with-secure-transport, --with-amissl, --with-bearssl or --with-rustls to address this.
>
> [...]
>
> In file included from rtmp.c:32:
> rtmp_sys.h:110:10: fatal error: gnutls/gnutls.h: No such file or directory
>   110 | #include <gnutls/gnutls.h>
>       |          ^~~~~~~~~~~~~~~~~
>
> Fixes: caff4179a4481233257f5f475ca57ce9061af900
>  - http://autobuild.buildroot.org/results/72e1843de650c9ed4795f1141e9fd485b71a14c3
>  - http://autobuild.buildroot.org/results/918f0f7efa810b17f6d2266a890bf0150cbed146

Thanks for investigating this issue. One comment below.

> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/gnutls/gnutls.mk | 8 --------
>  1 file changed, 8 deletions(-)
>
> diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
> index 8302194812..8a4f3345aa 100644
> --- a/package/gnutls/gnutls.mk
> +++ b/package/gnutls/gnutls.mk
> @@ -57,7 +57,6 @@ HOST_GNUTLS_CONF_OPTS = \
>  	--without-librt-prefix \
>  	--without-libz-prefix \
>  	--without-tpm \
> -	--without-tpm2 \

I guess we should leave this here to make it explicit we do not support
tpm2 for host. More importantly, I think we also need unconditional
--without-tpm2 in GNUTLS_CONF_OPTS.

baruch

>  	--disable-openssl-compatibility \
>  	--without-libbrotli \
>  	--without-idn \
> @@ -99,13 +98,6 @@ else
>  GNUTLS_CONF_OPTS += --without-p11-kit
>  endif
>  
> -ifeq ($(BR2_PACKAGE_TPM2_TSS),y)
> -GNUTLS_CONF_OPTS += --with-tpm2
> -GNUTLS_DEPENDENCIES += tpm2-tss
> -else
> -GNUTLS_CONF_OPTS += --without-tpm2
> -endif
> -
>  ifeq ($(BR2_PACKAGE_ZLIB),y)
>  GNUTLS_CONF_OPTS += --with-zlib
>  GNUTLS_DEPENDENCIES += zlib
Thomas Petazzoni July 21, 2024, 4:29 p.m. UTC | #2
On Sun, 21 Jul 2024 12:39:46 +0300
Baruch Siach via buildroot <buildroot@buildroot.org> wrote:

> I guess we should leave this here to make it explicit we do not support
> tpm2 for host. More importantly, I think we also need unconditional
> --without-tpm2 in GNUTLS_CONF_OPTS.

I agree.

Fabrice, could you rework the patch?

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 8302194812..8a4f3345aa 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -57,7 +57,6 @@  HOST_GNUTLS_CONF_OPTS = \
 	--without-librt-prefix \
 	--without-libz-prefix \
 	--without-tpm \
-	--without-tpm2 \
 	--disable-openssl-compatibility \
 	--without-libbrotli \
 	--without-idn \
@@ -99,13 +98,6 @@  else
 GNUTLS_CONF_OPTS += --without-p11-kit
 endif
 
-ifeq ($(BR2_PACKAGE_TPM2_TSS),y)
-GNUTLS_CONF_OPTS += --with-tpm2
-GNUTLS_DEPENDENCIES += tpm2-tss
-else
-GNUTLS_CONF_OPTS += --without-tpm2
-endif
-
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 GNUTLS_CONF_OPTS += --with-zlib
 GNUTLS_DEPENDENCIES += zlib