diff mbox series

[1/1] package/httping: fix patch fuzz

Message ID 20240720100820.347284-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/httping: fix patch fuzz | expand

Commit Message

Fabrice Fontaine July 20, 2024, 10:08 a.m. UTC
Fix patch fuzz to avoid the following build failure raised since commit
8f88a644ed7d6c9ea55fd4fbe9d7f37055920016 which reduced the fuzz factor:

Applying 0001-fix-math-library-linking.patch using patch:
patching file Makefile
Hunk #1 FAILED at 37.
1 out of 2 hunks FAILED -- saving rejects to file Makefile.rej

Fixes: 8f88a644ed7d6c9ea55fd4fbe9d7f37055920016
 - http://autobuild.buildroot.org/results/f9cfb6f55d1f2cb855e6959c2381eeddea3e4936

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/httping/0001-fix-math-library-linking.patch | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni July 20, 2024, 9:01 p.m. UTC | #1
On Sat, 20 Jul 2024 12:08:20 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fix patch fuzz to avoid the following build failure raised since commit
> 8f88a644ed7d6c9ea55fd4fbe9d7f37055920016 which reduced the fuzz factor:
> 
> Applying 0001-fix-math-library-linking.patch using patch:
> patching file Makefile
> Hunk #1 FAILED at 37.
> 1 out of 2 hunks FAILED -- saving rejects to file Makefile.rej
> 
> Fixes: 8f88a644ed7d6c9ea55fd4fbe9d7f37055920016
>  - http://autobuild.buildroot.org/results/f9cfb6f55d1f2cb855e6959c2381eeddea3e4936
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/httping/0001-fix-math-library-linking.patch | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/httping/0001-fix-math-library-linking.patch b/package/httping/0001-fix-math-library-linking.patch
index 0078f41c61..582fb9e917 100644
--- a/package/httping/0001-fix-math-library-linking.patch
+++ b/package/httping/0001-fix-math-library-linking.patch
@@ -2,12 +2,14 @@  Move LDFLAGS+=-lm option to the end.
 The order of the math library directive '-lm' matters.
 
 Signed-off-by: Yuvaraj Patil <yuvaraj.patil@wipro.com>
+[Fabrice: make the patch to be applied with fuzz factor 0]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 ---
 diff -Nurp httping-2.3.4_orig/Makefile httping-2.3.4/Makefile
 --- httping-2.3.4_orig/Makefile	2014-07-23 16:16:36.495546288 +0530
 +++ httping-2.3.4/Makefile	2014-07-23 16:18:42.547541002 +0530
-@@ -37,7 +37,6 @@ DEBUG=yes
- WFLAGS=-Wall -W
+@@ -36,7 +36,6 @@ DEBUG=yes
+ WFLAGS=-Wall -W -Wextra -pedantic -D_FORTIFY_SOURCE=2
  OFLAGS=
  CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\" -DLOCALEDIR=\"$(LOCALEDIR)\"
 -LDFLAGS+=-lm