diff mbox series

[1/1] package/edid-decode: switch to meson-package

Message ID 20240720095213.335126-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/edid-decode: switch to meson-package | expand

Commit Message

Fabrice Fontaine July 20, 2024, 9:52 a.m. UTC
Switch to meson-package to fix the following build failure raised since
bump to 6f117a8 in commit 4f5790116b42768bd1bd982245e00483440a6311 and
https://git.linuxtv.org/edid-decode.git/commit/?id=cdf81907def8658a66041a76ef2542e9a888cbed:

make[1]: *** No targets specified and no makefile found.  Stop.

Fixes: 4f5790116b42768bd1bd982245e00483440a6311
 - http://autobuild.buildroot.org/results/c569b0484dcd33f6ea88a9b6f11df5b54401db96

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/edid-decode/edid-decode.mk | 12 +-----------
 1 file changed, 1 insertion(+), 11 deletions(-)

Comments

Thomas Petazzoni July 20, 2024, 9:10 p.m. UTC | #1
On Sat, 20 Jul 2024 11:52:13 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Switch to meson-package to fix the following build failure raised since
> bump to 6f117a8 in commit 4f5790116b42768bd1bd982245e00483440a6311 and
> https://git.linuxtv.org/edid-decode.git/commit/?id=cdf81907def8658a66041a76ef2542e9a888cbed:
> 
> make[1]: *** No targets specified and no makefile found.  Stop.
> 
> Fixes: 4f5790116b42768bd1bd982245e00483440a6311
>  - http://autobuild.buildroot.org/results/c569b0484dcd33f6ea88a9b6f11df5b54401db96
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/edid-decode/edid-decode.mk | 12 +-----------
>  1 file changed, 1 insertion(+), 11 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/edid-decode/edid-decode.mk b/package/edid-decode/edid-decode.mk
index be0c4f1a0e..3e1d861f22 100644
--- a/package/edid-decode/edid-decode.mk
+++ b/package/edid-decode/edid-decode.mk
@@ -10,14 +10,4 @@  EDID_DECODE_SITE_METHOD = git
 EDID_DECODE_LICENSE = MIT
 EDID_DECODE_LICENSE_FILES = LICENSE
 
-define EDID_DECODE_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
-		CFLAGS="$(TARGET_CXXFLAGS) -std=c++11" WARN_FLAGS=
-endef
-
-define EDID_DECODE_INSTALL_TARGET_CMDS
-	$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
-		DESTDIR="$(TARGET_DIR)" install
-endef
-
-$(eval $(generic-package))
+$(eval $(meson-package))