diff mbox series

package/tio: bump to 3.5

Message ID 20240716124021.2386621-1-buildroot@bubu1.eu
State Accepted
Headers show
Series package/tio: bump to 3.5 | expand

Commit Message

Marcus Hoffmann July 16, 2024, 12:40 p.m. UTC
Dependencies changed: inih dependency was removed, glib2 and lua added.
Tio's meson build system fails to find luajit, so exclude that,
otherwise all versions of lua >= 5.1 are supported.

Retested the build for sparc and sparc64 and the compile issues have
been resolved upstream by reworking the baudrate selection code quite a
while ago[1].

Disable installation of man pages with new build option.

[1] https://github.com/tio/tio/commit/a23be7f2c2bacef428b0e50aa93e37e5b52bdd56

Signed-off-by: Marcus Hoffmann <buildroot@bubu1.eu>
---
 package/tio/Config.in | 23 +++++++++++++----------
 package/tio/tio.hash  |  4 ++--
 package/tio/tio.mk    |  6 ++++--
 3 files changed, 19 insertions(+), 14 deletions(-)

Comments

Thomas Petazzoni July 16, 2024, 2:43 p.m. UTC | #1
On Tue, 16 Jul 2024 14:40:21 +0200
Marcus Hoffmann via buildroot <buildroot@buildroot.org> wrote:

> Dependencies changed: inih dependency was removed, glib2 and lua added.
> Tio's meson build system fails to find luajit, so exclude that,
> otherwise all versions of lua >= 5.1 are supported.
> 
> Retested the build for sparc and sparc64 and the compile issues have
> been resolved upstream by reworking the baudrate selection code quite a
> while ago[1].
> 
> Disable installation of man pages with new build option.
> 
> [1] https://github.com/tio/tio/commit/a23be7f2c2bacef428b0e50aa93e37e5b52bdd56
> 
> Signed-off-by: Marcus Hoffmann <buildroot@bubu1.eu>
> ---
>  package/tio/Config.in | 23 +++++++++++++----------
>  package/tio/tio.hash  |  4 ++--
>  package/tio/tio.mk    |  6 ++++--
>  3 files changed, 19 insertions(+), 14 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/tio/Config.in b/package/tio/Config.in
index e4241fa5e1..953b26a349 100644
--- a/package/tio/Config.in
+++ b/package/tio/Config.in
@@ -1,8 +1,10 @@ 
 config BR2_PACKAGE_TIO
 	bool "tio"
-	depends on !BR2_sparc64 && !BR2_sparc
 	depends on BR2_TOOLCHAIN_HAS_THREADS
-	select BR2_PACKAGE_INIH
+	depends on BR2_USE_MMU # glib2
+	depends on BR2_USE_WCHAR # glib2
+	depends on BR2_PACKAGE_HAS_LUAINTERPRETER
+	depends on !BR2_PACKAGE_LUAJIT
 	help
 	  "tio" is a simple TTY terminal application which features a
 	  straightforward commandline interface to easily connect to
@@ -10,12 +12,13 @@  config BR2_PACKAGE_TIO
 
 	  https://tio.github.io/
 
-# tio is disabled for sparc and sparc64 architectures because it fails
-# to build with a redefinition of 'struct termio' error, with no proper
-# fix or workaround for now
-comment "tio is disabled for sparc and sparc64 architectures"
-	depends on BR2_sparc64 || BR2_sparc
-
-comment "tio needs a toolchain w/ threads"
+comment "tio needs a toolchain w/ threads, wchar"
+	depends on BR2_USE_MMU
 	depends on !BR2_sparc64 && !BR2_sparc
-	depends on !BR2_TOOLCHAIN_HAS_THREADS
+	depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
+
+comment "tio needs lua (but not luajit)"
+	depends on BR2_USE_MMU
+	depends on BR2_TOOLCHAIN_HAS_THREADS
+	depends on BR2_USE_WCHAR
+	depends on !BR2_PACKAGE_HAS_LUAINTERPRETER || BR2_PACKAGE_LUAJIT
diff --git a/package/tio/tio.hash b/package/tio/tio.hash
index 02699fdeb4..d1caeeebc6 100644
--- a/package/tio/tio.hash
+++ b/package/tio/tio.hash
@@ -1,5 +1,5 @@ 
-# From https://github.com/tio/tio/releases/download/v2.7/tio-2.7.tar.xz.sha256sum:
-sha256  bf8fe434848c2c1b6540af0b42503c986068176ddc1a988cf02e521e7de5daa5  tio-2.7.tar.xz
+# From https://github.com/tio/tio/releases/download/v3.5/tio-3.5.tar.xz.sha256sum:
+sha256  efd3e9a406f827ac22d4157e345079dde15ee5a948b24156561d6c97a54e6ec0  tio-3.5.tar.xz
 
 # Hash for license files:
 sha256  9248dee77ee136321f24556a96e07ff8f90461013941884a9defd0ac825ef131  LICENSE
diff --git a/package/tio/tio.mk b/package/tio/tio.mk
index 95831e8ce6..637a7bdd83 100644
--- a/package/tio/tio.mk
+++ b/package/tio/tio.mk
@@ -4,12 +4,14 @@ 
 #
 ################################################################################
 
-TIO_VERSION = 2.7
+TIO_VERSION = 3.5
 TIO_SOURCE = tio-$(TIO_VERSION).tar.xz
 TIO_SITE = https://github.com/tio/tio/releases/download/v$(TIO_VERSION)
 TIO_LICENSE = GPL-2.0+
 TIO_LICENSE_FILES = LICENSE
-TIO_DEPENDENCIES = inih
+TIO_DEPENDENCIES = libglib2 luainterpreter
+
+TIO_CONF_OPTS += -Dinstall_man_pages=false
 
 ifeq ($(BR2_PACKAGE_BASH_COMPLETION),y)
 TIO_CONF_OPTS +=-Dbashcompletiondir=/usr/share/bash-completion/completions