diff mbox series

[v4,1/4] package/blake3: add new host package

Message ID 20240713122331.298786-2-heiko.thiery@gmail.com
State Accepted
Headers show
Series package/ccache: bump version | expand

Commit Message

Heiko Thiery July 13, 2024, 12:23 p.m. UTC
This package is used and required for ccache update.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---

v2:
    - on change

v3:
    - fix BLAKE3_LICENSE_FILES and corresponding hash values

v4:
    - use github macro to get tagged version instead of refs/tags
    - remove override of CMAKE_ASM_COMPILER (requires series https://patchwork.ozlabs.org/project/buildroot/list/?series=415079)

 DEVELOPERS                 |  1 +
 package/blake3/blake3.hash |  3 +++
 package/blake3/blake3.mk   | 19 +++++++++++++++++++
 3 files changed, 23 insertions(+)
 create mode 100644 package/blake3/blake3.hash
 create mode 100644 package/blake3/blake3.mk
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 1fa425f3ee..0222b37efd 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1369,6 +1369,7 @@  F:	configs/kontron_bl_imx8mm_defconfig
 F:	configs/kontron_smarc_sal28_defconfig
 F:	configs/kontron_pitx_imx8m_defconfig
 F:	package/altera-stapl/
+F:	package/blake3/
 F:	package/ipmitool/
 F:	package/libnetconf2/
 F:	package/libyang/
diff --git a/package/blake3/blake3.hash b/package/blake3/blake3.hash
new file mode 100644
index 0000000000..2a00d19b02
--- /dev/null
+++ b/package/blake3/blake3.hash
@@ -0,0 +1,3 @@ 
+# sha256 computed locally
+sha256  822cd37f70152e5985433d2c50c8f6b2ec83aaf11aa31be9fe71486a91744f37  blake3-1.5.1.tar.gz
+sha256  6a94bedb8b707ed97f6e310d0d015ab14e0683ffa0a612b02958581b9cc9fc0e  LICENSE
diff --git a/package/blake3/blake3.mk b/package/blake3/blake3.mk
new file mode 100644
index 0000000000..5625046db6
--- /dev/null
+++ b/package/blake3/blake3.mk
@@ -0,0 +1,19 @@ 
+################################################################################
+#
+# blake3
+#
+################################################################################
+
+BLAKE3_VERSION = 1.5.1
+BLAKE3_SITE = $(call github,BLAKE3-team,BLAKE3,$(BLAKE3_VERSION))
+BLAKE3_SUBDIR = c
+BLAKE3_LICENSE = Apache-2.0, CC0-1.0
+BLAKE3_LICENSE_FILES = LICENSE
+
+# We may be a ccache dependency, so we can't use ccache; reset the
+# options set by the cmake infra.
+HOST_BLAKE3_CONF_OPTS += \
+	-UCMAKE_C_COMPILER_LAUNCHER \
+	-UCMAKE_CXX_COMPILER_LAUNCHER
+
+$(eval $(host-cmake-package))