diff mbox series

[2/2] package/llvm-project/llvm: remove overriding the ASM compiler

Message ID 20240713054407.229084-1-heiko.thiery@gmail.com
State Accepted
Headers show
Series pkg-cmake CMAKE_ASM_COMPILER override | expand

Commit Message

Heiko Thiery July 13, 2024, 5:44 a.m. UTC
There was an error in the pkg-cmake infra file regarding the selection
of the ASM compiler. Now that this has been fixed, overwriting the
ASM compiler selection is no longer necessary.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 package/llvm-project/llvm/llvm.mk | 4 ----
 1 file changed, 4 deletions(-)

Comments

Peter Korsgaard Aug. 12, 2024, 11:22 a.m. UTC | #1
>>>>> "Heiko" == Heiko Thiery <heiko.thiery@gmail.com> writes:

 > There was an error in the pkg-cmake infra file regarding the selection
 > of the ASM compiler. Now that this has been fixed, overwriting the
 > ASM compiler selection is no longer necessary.

 > Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>

Committed to 2024.02.x and 2024.05.x, thanks.
diff mbox series

Patch

diff --git a/package/llvm-project/llvm/llvm.mk b/package/llvm-project/llvm/llvm.mk
index 6598d8b6c1..b0515474d8 100644
--- a/package/llvm-project/llvm/llvm.mk
+++ b/package/llvm-project/llvm/llvm.mk
@@ -20,10 +20,6 @@  LLVM_DEPENDENCIES = host-llvm
 HOST_LLVM_CONF_OPTS += -DCMAKE_MODULE_PATH=$(HOST_DIR)/lib/cmake/llvm
 LLVM_CONF_OPTS += -DCMAKE_MODULE_PATH=$(HOST_DIR)/lib/cmake/llvm
 
-# Assembly files for x64 in lib/Support/BLAKE3 need to be compiled
-# by a C compiler
-HOST_LLVM_CONF_OPTS += -DCMAKE_ASM_COMPILER="$(CMAKE_HOST_C_COMPILER)"
-
 # Don't build clang libcxx libcxxabi lldb compiler-rt lld polly as llvm subprojects
 # This flag assumes that projects are checked out side-by-side and not nested
 HOST_LLVM_CONF_OPTS += -DLLVM_ENABLE_PROJECTS=""