diff mbox series

[v2,4/4] package/wpewebkit: disable libdrm usage when not available

Message ID 20240627193335.4069574-5-aperez@igalia.com
State Accepted
Headers show
Series Add support for the WPE WebKit RDK backend | expand

Commit Message

Adrian Perez de Castro June 27, 2024, 7:33 p.m. UTC
Pass USE_LIBDRM=OFF to the wpewebkit CMake configuration step when the
libdrm package has not been selected.

WPE WebKit can be built without libdrm support, and it will still work
with backends that use other platform-specific methods to handle
graphics buffers and/or presenting content onto an output. For example
this is the case with wpebackend-rdk configured to use rpi-userland,
which uses dispmanx to produce the output instead of DRM/KMS.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
---
 package/wpewebkit/wpewebkit.mk | 7 +++++++
 1 file changed, 7 insertions(+)

---
v1 -> v2:
- Patch added.

Comments

Thomas Petazzoni Aug. 2, 2024, 9:15 p.m. UTC | #1
On Thu, 27 Jun 2024 22:33:32 +0300
Adrian Perez de Castro <aperez@igalia.com> wrote:

> Pass USE_LIBDRM=OFF to the wpewebkit CMake configuration step when the
> libdrm package has not been selected.
> 
> WPE WebKit can be built without libdrm support, and it will still work
> with backends that use other platform-specific methods to handle
> graphics buffers and/or presenting content onto an output. For example
> this is the case with wpebackend-rdk configured to use rpi-userland,
> which uses dispmanx to produce the output instead of DRM/KMS.
> 
> Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
> ---
>  package/wpewebkit/wpewebkit.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/wpewebkit/wpewebkit.mk b/package/wpewebkit/wpewebkit.mk
index 382c2adca10..4071cbb0d83 100644
--- a/package/wpewebkit/wpewebkit.mk
+++ b/package/wpewebkit/wpewebkit.mk
@@ -87,6 +87,13 @@  else
 WPEWEBKIT_CONF_OPTS += -DUSE_LIBBACKTRACE=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_LIBDRM),y)
+WPEWEBKIT_CONF_OPTS += -DUSE_LIBDRM=ON
+WPEWEBKIT_DEPENDENCIES += libdrm
+else
+WPEWEBKIT_CONF_OPTS += -DUSE_LIBDRM=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_WOFF2),y)
 WPEWEBKIT_CONF_OPTS += -DUSE_WOFF2=ON
 WPEWEBKIT_DEPENDENCIES += woff2