diff mbox series

package/gnutls: add tpm2-tss optional dependency

Message ID 20240627084039.44592-1-romain.naour@smile.fr
State Accepted
Headers show
Series package/gnutls: add tpm2-tss optional dependency | expand

Commit Message

Romain Naour June 27, 2024, 8:40 a.m. UTC
tpm2-tss support is available since gnutls 3.7.3 using
--{with,without}-tpm2 configure option [1].

Since the option is not handled by gnutls package, tpm2-tss support
can be enabled if tpm2-tss package is build before gnutls package.

Likewise, tpm2-tss support can be enabled for the gnutls host variant
if tpm2-tss libraries are installed on the host.
Make sure to disable tpm2-tss support for the host-gnutls.

[1] https://lists.gnupg.org/pipermail/gnutls-help/2022-January/004736.html

Signed-off-by: Romain Naour <romain.naour@smile.fr>
---
 package/gnutls/gnutls.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Thomas Petazzoni July 10, 2024, 12:28 p.m. UTC | #1
On Thu, 27 Jun 2024 10:40:39 +0200
Romain Naour via buildroot <buildroot@buildroot.org> wrote:

> tpm2-tss support is available since gnutls 3.7.3 using
> --{with,without}-tpm2 configure option [1].
> 
> Since the option is not handled by gnutls package, tpm2-tss support
> can be enabled if tpm2-tss package is build before gnutls package.
> 
> Likewise, tpm2-tss support can be enabled for the gnutls host variant
> if tpm2-tss libraries are installed on the host.
> Make sure to disable tpm2-tss support for the host-gnutls.
> 
> [1] https://lists.gnupg.org/pipermail/gnutls-help/2022-January/004736.html
> 
> Signed-off-by: Romain Naour <romain.naour@smile.fr>
> ---
>  package/gnutls/gnutls.mk | 8 ++++++++
>  1 file changed, 8 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 8a4f3345aa..8302194812 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -57,6 +57,7 @@  HOST_GNUTLS_CONF_OPTS = \
 	--without-librt-prefix \
 	--without-libz-prefix \
 	--without-tpm \
+	--without-tpm2 \
 	--disable-openssl-compatibility \
 	--without-libbrotli \
 	--without-idn \
@@ -98,6 +99,13 @@  else
 GNUTLS_CONF_OPTS += --without-p11-kit
 endif
 
+ifeq ($(BR2_PACKAGE_TPM2_TSS),y)
+GNUTLS_CONF_OPTS += --with-tpm2
+GNUTLS_DEPENDENCIES += tpm2-tss
+else
+GNUTLS_CONF_OPTS += --without-tpm2
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 GNUTLS_CONF_OPTS += --with-zlib
 GNUTLS_DEPENDENCIES += zlib