diff mbox series

[v6,2/3] package/libtpms: add host package

Message ID 20240521115727.25343-3-jarkko@kernel.org
State Superseded
Headers show
Series swtpm and libtpms host packages | expand

Commit Message

Jarkko Sakkinen May 21, 2024, 11:57 a.m. UTC
Libtpms is a library that targets the integration of TPM functionality
into hypervisors, primarily into Qemu. Libtpms provides a very narrow
public API for this purpose so that integration is possible. Only the
minimum of necessary APIs are made publicly available.

Signed-off-by: Jarkko Sakkinen <jarkko@kernel.org>
---
v6:
- Remove Config.in.host entirely. Not required for pure deps.
v5:
- Config.in.host
- s/"libtpms"/"host libtpms"/
v4:
- Changed in libtpms.mk to purely HOST_*.
v3:
- Use package deps in Kconfig as this just a library.
- DEPENDENCIES and CONF_OPTS for the host build
v2:
- Use host packages in package/libtpms/Config.in.
- Select BR2_HOST_PACKAGE_LIBOPENSSL.
---
 DEVELOPERS                   |  1 +
 package/libtpms/libtpms.hash |  2 ++
 package/libtpms/libtpms.mk   | 18 ++++++++++++++++++
 3 files changed, 21 insertions(+)
 create mode 100644 package/libtpms/libtpms.hash
 create mode 100644 package/libtpms/libtpms.mk

--
2.45.1

Comments

Jarkko Sakkinen May 21, 2024, 12:06 p.m. UTC | #1
On Tue May 21, 2024 at 2:57 PM EEST, Jarkko Sakkinen wrote:
> Libtpms is a library that targets the integration of TPM functionality
> into hypervisors, primarily into Qemu. Libtpms provides a very narrow
> public API for this purpose so that integration is possible. Only the
> minimum of necessary APIs are made publicly available.
>
> Signed-off-by: Jarkko Sakkinen <jarkko@kernel.org>
> ---
> v6:
> - Remove Config.in.host entirely. Not required for pure deps.
> v5:
> - Config.in.host
> - s/"libtpms"/"host libtpms"/
> v4:
> - Changed in libtpms.mk to purely HOST_*.
> v3:
> - Use package deps in Kconfig as this just a library.
> - DEPENDENCIES and CONF_OPTS for the host build
> v2:
> - Use host packages in package/libtpms/Config.in.
> - Select BR2_HOST_PACKAGE_LIBOPENSSL.

I don't mind cycling this patch set as long as I don't do same
mistakes twice, and only do any other possible mistake ;-)

Good learnings given that I need to review changes to these in
the future. And yeah, most of the learnings have been really
carved into my brain by now..

And yeah, was a good idea to send the patch set so that I can
review also quota patches in the future. This address should
stick.

BR, Jarkko
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 52c9b84a9d..db0dc702a8 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1519,6 +1519,7 @@  N:	Jared Bents <jared.bents@rockwellcollins.com>
 F:	package/libvirt/

 N:	Jarkko Sakkinen <jarkko@kernel.org>
+F:	package/libtpms/
 F:	package/quota/

 N:	Jason Pruitt <jrspruitt@gmail.com>
diff --git a/package/libtpms/libtpms.hash b/package/libtpms/libtpms.hash
new file mode 100644
index 0000000000..1026aaa4f4
--- /dev/null
+++ b/package/libtpms/libtpms.hash
@@ -0,0 +1,2 @@ 
+sha256  2807466f1563ebe45fdd12dd26e501e8a0c4fbb99c7c428fbb508789efd221c0  libtpms-0.9.6.tar.gz
+sha256  82f1e6bae374bb6a9d4f4596767fd33e499718d560de140fd9f3d402cc5e41fb  LICENSE
diff --git a/package/libtpms/libtpms.mk b/package/libtpms/libtpms.mk
new file mode 100644
index 0000000000..19d7cef89f
--- /dev/null
+++ b/package/libtpms/libtpms.mk
@@ -0,0 +1,18 @@ 
+################################################################################
+#
+# libtpms
+#
+################################################################################
+
+LIBTPMS_VERSION = 0.9.6
+LIBTPMS_SITE = $(call github,stefanberger,libtpms,v$(LIBTPMS_VERSION))
+LIBTPMS_LICENSE = BSD-4-Clause
+LIBTPMS_LICENSE_FILES = LICENSE
+LIBTPMS_INSTALL_STAGING = YES
+
+# Required because a plain Git clone is used:
+HOST_LIBTPMS_AUTORECONF = YES
+HOST_LIBTPMS_DEPENDENCIES = host-pkgconf host-openssl
+HOST_LIBTPMS_CONF_OPTS = --with-openssl  -with-tpm2
+
+$(eval $(host-autotools-package))