diff mbox series

[1/1] package/uacme: fix build

Message ID 20240220195007.380433-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/uacme: fix build | expand

Commit Message

Fabrice Fontaine Feb. 20, 2024, 7:50 p.m. UTC
Fix the following build failure raised since bump to version 1.7.5 in
commit b7ee5f3b0e3ef703bafd007cc99da10312d99b9e and
https://github.com/ndilieto/uacme/commit/fe826f4b1931ae508047d8b2693b5b6ac2cb21fd:

checking if mmap(MAP_ANON|MAP_SHARED) works... configure: error: in `/home/autobuild/autobuild/instance-9/output-1/build/uacme-1.7.5':
configure: error: cannot run test program while cross compiling

Fixes: b7ee5f3b0e3ef703bafd007cc99da10312d99b9e
 - http://autobuild.buildroot.org/results/9715ade98f4894c07b640d151daa41813d2bec3a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 .../uacme/0001-Fix-cross-compilation.patch    | 29 +++++++++++++++++++
 package/uacme/uacme.mk                        |  2 ++
 2 files changed, 31 insertions(+)
 create mode 100644 package/uacme/0001-Fix-cross-compilation.patch

Comments

Yann E. MORIN Feb. 20, 2024, 8:44 p.m. UTC | #1
Fabrice, All,

On 2024-02-20 20:50 +0100, Fabrice Fontaine spake thusly:
> Fix the following build failure raised since bump to version 1.7.5 in
> commit b7ee5f3b0e3ef703bafd007cc99da10312d99b9e and
> https://github.com/ndilieto/uacme/commit/fe826f4b1931ae508047d8b2693b5b6ac2cb21fd:
> 
> checking if mmap(MAP_ANON|MAP_SHARED) works... configure: error: in `/home/autobuild/autobuild/instance-9/output-1/build/uacme-1.7.5':
> configure: error: cannot run test program while cross compiling
> 
> Fixes: b7ee5f3b0e3ef703bafd007cc99da10312d99b9e
>  - http://autobuild.buildroot.org/results/9715ade98f4894c07b640d151daa41813d2bec3a
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[--SNIP--]
> diff --git a/package/uacme/uacme.mk b/package/uacme/uacme.mk
> index f02e522761..cd670ee951 100644
> --- a/package/uacme/uacme.mk
> +++ b/package/uacme/uacme.mk
> @@ -12,6 +12,8 @@ UACME_SITE = $(call github,ndilieto,uacme,upstream/$(UACME_VERSION))
>  UACME_LICENSE = GPL-3.0+
>  UACME_LICENSE_FILES = COPYING
>  UACME_DEPENDENCIES = libcurl
> +# We're patching configure.ac

I've slightly reworded this comment to reference the patch filename, so
that's it is easier to notice when the patch is dropped that we should
also drop autoreconf.

Applied to master, thanks.

Regards,
Yann E. MORIN.

> +UACME_AUTORECONF = YES
>  
>  UACME_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99' LIBS="$(UACME_LIBS)"
>  
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/uacme/0001-Fix-cross-compilation.patch b/package/uacme/0001-Fix-cross-compilation.patch
new file mode 100644
index 0000000000..cc384f2c36
--- /dev/null
+++ b/package/uacme/0001-Fix-cross-compilation.patch
@@ -0,0 +1,29 @@ 
+From cdf63e24dc475a558400c68714e32d32904e4c57 Mon Sep 17 00:00:00 2001
+From: Nicola Di Lieto <nicola.dilieto@gmail.com>
+Date: Tue, 20 Feb 2024 01:05:00 +0100
+Subject: [PATCH] Fix cross compilation
+
+Commit fe826f4b1931ae508047d8b2693b5b6ac2cb21fd broke cross compilation
+
+Closes https://github.com/ndilieto/uacme/issues/79
+
+Upstream: https://github.com/ndilieto/uacme/commit/cdf63e24dc475a558400c68714e32d32904e4c57
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 77d1230..3bec75b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -355,7 +355,8 @@ if test "x$OPT_UALPN" != "xno"; then
+                 AC_DEFINE(HAVE_MAP_DEVZERO, 1, [if mmap("/dev/zero", MAP_SHARED) works])
+                 AC_MSG_RESULT([yes]),
+                 AC_MSG_RESULT([no])
+-                AC_MSG_ERROR([ualpn requires MAP_ANON or mmap("/dev/zero", MAP_SHARED)])),
++                AC_MSG_ERROR([ualpn requires MAP_ANON or mmap("/dev/zero", MAP_SHARED)]))
++        ], [
+             AC_COMPILE_IFELSE([AC_LANG_SOURCE([#include <sys/mman.h>
+                              int main() {return mmap(0, 4096, PROT_READ|PROT_WRITE,
+                                 MAP_ANON|MAP_SHARED, -1, 0) == MAP_FAILED;}])],
diff --git a/package/uacme/uacme.mk b/package/uacme/uacme.mk
index f02e522761..cd670ee951 100644
--- a/package/uacme/uacme.mk
+++ b/package/uacme/uacme.mk
@@ -12,6 +12,8 @@  UACME_SITE = $(call github,ndilieto,uacme,upstream/$(UACME_VERSION))
 UACME_LICENSE = GPL-3.0+
 UACME_LICENSE_FILES = COPYING
 UACME_DEPENDENCIES = libcurl
+# We're patching configure.ac
+UACME_AUTORECONF = YES
 
 UACME_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99' LIBS="$(UACME_LIBS)"