diff mbox series

[1/2] package/tio: install bash-completions

Message ID 20240213114933.2444440-1-buildroot@bubu1.eu
State Accepted
Headers show
Series [1/2] package/tio: install bash-completions | expand

Commit Message

Marcus Hoffmann Feb. 13, 2024, 11:49 a.m. UTC
See meson_options.txt file [1].

[1] https://github.com/tio/tio/blob/master/meson_options.txt

Signed-off-by: Marcus Hoffmann <buildroot@bubu1.eu>
---
 package/tio/tio.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni July 15, 2024, 10:50 a.m. UTC | #1
Hello Marcus,

On Tue, 13 Feb 2024 12:49:31 +0100
Marcus Hoffmann via buildroot <buildroot@buildroot.org> wrote:

> See meson_options.txt file [1].
> 
> [1] https://github.com/tio/tio/blob/master/meson_options.txt
> 
> Signed-off-by: Marcus Hoffmann <buildroot@bubu1.eu>
> ---
>  package/tio/tio.mk | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/package/tio/tio.mk b/package/tio/tio.mk
> index d7b554ee84..a7d3537850 100644
> --- a/package/tio/tio.mk
> +++ b/package/tio/tio.mk
> @@ -10,5 +10,10 @@ TIO_SITE = https://github.com/tio/tio/releases/download/v$(TIO_VERSION)
>  TIO_LICENSE = GPL-2.0+
>  TIO_LICENSE_FILES = LICENSE
>  TIO_DEPENDENCIES = inih
> +ifeq ($(BR2_PACKAGE_BASH_COMPLETION),y)

Added an empty line between the TIO_DEPENDENCIES line and the condition.

> +TIO_CONF_OPTS +=-Dbashcompletiondir=/usr/share/bash-completion/completions/

Dropped the final / to match with other usage of
/usr/share/bash-completion/completions in the tree.

Applied with those minor nits fixed. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/tio/tio.mk b/package/tio/tio.mk
index d7b554ee84..a7d3537850 100644
--- a/package/tio/tio.mk
+++ b/package/tio/tio.mk
@@ -10,5 +10,10 @@  TIO_SITE = https://github.com/tio/tio/releases/download/v$(TIO_VERSION)
 TIO_LICENSE = GPL-2.0+
 TIO_LICENSE_FILES = LICENSE
 TIO_DEPENDENCIES = inih
+ifeq ($(BR2_PACKAGE_BASH_COMPLETION),y)
+TIO_CONF_OPTS +=-Dbashcompletiondir=/usr/share/bash-completion/completions/
+else
+TIO_CONF_OPTS +=-Dbashcompletiondir=no
+endif
 
 $(eval $(meson-package))