@@ -24,11 +24,11 @@ comment "wpewebkit needs a toolchain w/ C++, wchar, threads, dynamic library, gc
|| !BR2_TOOLCHAIN_GCC_AT_LEAST_10 \
|| !BR2_HOST_GCC_AT_LEAST_4_9
-comment "wpewebkit needs an OpenGL ES w/ EGL-capable Wayland backend"
+comment "wpewebkit needs an OpenGL ES w/ EGL-capable implementation and an WPE backend"
depends on BR2_PACKAGE_WPEWEBKIT_ARCH_SUPPORTS
depends on !BR2_BINFMT_FLAT
- depends on !BR2_PACKAGE_HAS_LIBGLES || !BR2_PACKAGE_HAS_LIBEGL \
- || !BR2_PACKAGE_HAS_LIBEGL_WAYLAND
+ depends on !BR2_PACKAGE_HAS_LIBGLES || !BR2_PACKAGE_HAS_LIBEGL
+ depends on !BR2_PACKAGE_WPEBACKEND_FDO && !BR2_PACKAGE_WPEBACKEND_RDK
config BR2_PACKAGE_WPEWEBKIT
bool "wpewebkit"
@@ -41,8 +41,8 @@ config BR2_PACKAGE_WPEWEBKIT
depends on BR2_USE_WCHAR # icu, libsoup3
depends on BR2_PACKAGE_HAS_LIBGLES # libepoxy
depends on BR2_PACKAGE_HAS_LIBEGL # libepoxy
- depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND # wpebackend-fdo
depends on BR2_PACKAGE_WPEWEBKIT_ARCH_SUPPORTS
+ depends on BR2_PACKAGE_WPEBACKEND_FDO || BR2_PACKAGE_WPEBACKEND_RDK
select BR2_PACKAGE_CAIRO
select BR2_PACKAGE_CAIRO_PNG
select BR2_PACKAGE_HARFBUZZ
@@ -59,7 +59,6 @@ config BR2_PACKAGE_WPEWEBKIT
select BR2_PACKAGE_WAYLAND_PROTOCOLS
select BR2_PACKAGE_WEBP
select BR2_PACKAGE_WEBP_DEMUX
- select BR2_PACKAGE_WPEBACKEND_FDO
help
WPE (Web Platform for Embedded) port of the WebKit engine,
to allow embedders to create simple and performant systems
@@ -16,7 +16,7 @@ WPEWEBKIT_CPE_ID_VENDOR = wpewebkit
WPEWEBKIT_CPE_ID_PRODUCT = wpe_webkit
WPEWEBKIT_DEPENDENCIES = host-gperf host-python3 host-ruby host-unifdef \
harfbuzz cairo icu jpeg libepoxy libgcrypt libgles libsoup3 libtasn1 \
- libpng libxslt openjpeg wayland-protocols webp wpebackend-fdo
+ libpng libxslt libwpe openjpeg wayland-protocols webp
WPEWEBKIT_CMAKE_BACKEND = ninja
Remove the wpewebkit package dependency on wpebackend-fdo, as it is not needed at all during the build. What is needed is a WPE backend at run time, which may be provided by wpebackend-fdo or wpebackend-rdk. To reflect this, we make wpewebkit depend on either being selected. Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> --- package/wpewebkit/Config.in | 9 ++++----- package/wpewebkit/wpewebkit.mk | 2 +- 2 files changed, 5 insertions(+), 6 deletions(-)