diff mbox series

[v2,1/2] package/python-bitarray: new package

Message ID 20240207084503.11109-1-romain.naour@smile.fr
State Accepted
Headers show
Series [v2,1/2] package/python-bitarray: new package | expand

Commit Message

Romain Naour Feb. 7, 2024, 8:45 a.m. UTC
This package is needed at runtime by python-bitstring since
4.1.0 already [1].

Note: the License is under Python-2.0 but "Python Software
Foundation License (PSF)" has been remplaced by the author
of bitarray Ilan Schnell.

[1] https://github.com/scott-griffiths/bitstring/releases/tag/bitstring-4.1.0

Signed-off-by: Romain Naour <romain.naour@smile.fr>
Reviewed-by: Marcus Hoffmann <buildroot@bubu1.eu>
---
Triple checked the license type with other distribution:
https://salsa.debian.org/python-team/packages/python-bitarray/-/blob/master/debian/copyright?ref_type=heads
https://src.fedoraproject.org/rpms/python-bitarray/blob/rawhide/f/python-bitarray.spec
https://aur.archlinux.org/packages/python-bitarray

v2: update python-bitstring version (Marcus Hoffmann)
---
 package/Config.in                            |  1 +
 package/python-bitarray/Config.in            |  6 ++++++
 package/python-bitarray/python-bitarray.hash |  5 +++++
 package/python-bitarray/python-bitarray.mk   | 14 ++++++++++++++
 4 files changed, 26 insertions(+)
 create mode 100644 package/python-bitarray/Config.in
 create mode 100644 package/python-bitarray/python-bitarray.hash
 create mode 100644 package/python-bitarray/python-bitarray.mk

Comments

Peter Korsgaard March 1, 2024, 10:10 a.m. UTC | #1
>>>>> "Romain" == Romain Naour <romain.naour@smile.fr> writes:

 > This package is needed at runtime by python-bitstring since
 > 4.1.0 already [1].

 > Note: the License is under Python-2.0 but "Python Software
 > Foundation License (PSF)" has been remplaced by the author
 > of bitarray Ilan Schnell.

 > [1] https://github.com/scott-griffiths/bitstring/releases/tag/bitstring-4.1.0

 > Signed-off-by: Romain Naour <romain.naour@smile.fr>
 > Reviewed-by: Marcus Hoffmann <buildroot@bubu1.eu>
 > ---
 > Triple checked the license type with other distribution:
 > https://salsa.debian.org/python-team/packages/python-bitarray/-/blob/master/debian/copyright?ref_type=heads
 > https://src.fedoraproject.org/rpms/python-bitarray/blob/rawhide/f/python-bitarray.spec
 > https://aur.archlinux.org/packages/python-bitarray

 > v2: update python-bitstring version (Marcus Hoffmann)

Committed to 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 24e5f04ed6..89537f87b6 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1008,6 +1008,7 @@  menu "External python modules"
 	source "package/python-bcrypt/Config.in"
 	source "package/python-beautifulsoup4/Config.in"
 	source "package/python-bidict/Config.in"
+	source "package/python-bitarray/Config.in"
 	source "package/python-bitstring/Config.in"
 	source "package/python-bleak/Config.in"
 	source "package/python-blinker/Config.in"
diff --git a/package/python-bitarray/Config.in b/package/python-bitarray/Config.in
new file mode 100644
index 0000000000..38d685f4fd
--- /dev/null
+++ b/package/python-bitarray/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_PYTHON_BITARRAY
+	bool "python-bitarray"
+	help
+	  efficient arrays of booleans -- C extension.
+
+	  https://github.com/ilanschnell/bitarray
diff --git a/package/python-bitarray/python-bitarray.hash b/package/python-bitarray/python-bitarray.hash
new file mode 100644
index 0000000000..d91a28af20
--- /dev/null
+++ b/package/python-bitarray/python-bitarray.hash
@@ -0,0 +1,5 @@ 
+# md5, sha256 from https://pypi.org/pypi/bitarray/json
+md5  024324a82314e9e68ecdcdefdc69071f  bitarray-2.9.2.tar.gz
+sha256  a8f286a51a32323715d77755ed959f94bef13972e9a2fe71b609e40e6d27957e  bitarray-2.9.2.tar.gz
+# Locally computed sha256 checksums
+sha256  6b5e04f6e0462e1b97be833f9d65e66cd5eceb3283f4a6f532261087d0ab1233  LICENSE
diff --git a/package/python-bitarray/python-bitarray.mk b/package/python-bitarray/python-bitarray.mk
new file mode 100644
index 0000000000..f86320c112
--- /dev/null
+++ b/package/python-bitarray/python-bitarray.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# python-bitarray
+#
+################################################################################
+
+PYTHON_BITARRAY_VERSION = 2.9.2
+PYTHON_BITARRAY_SOURCE = bitarray-$(PYTHON_BITARRAY_VERSION).tar.gz
+PYTHON_BITARRAY_SITE = https://files.pythonhosted.org/packages/c7/bf/25cf92a83e1fe4948d7935ae3c02f4c9ff9cb9c13e977fba8af11a5f642c
+PYTHON_BITARRAY_SETUP_TYPE = setuptools
+PYTHON_BITARRAY_LICENSE = Python-2.0
+PYTHON_BITARRAY_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))