diff mbox series

package/pipewire: fix webrtc-audio-processing condition

Message ID 20240110205154.4091988-1-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series package/pipewire: fix webrtc-audio-processing condition | expand

Commit Message

Thomas Petazzoni Jan. 10, 2024, 8:51 p.m. UTC
The condition checking whether the webrtc-audio-processing package is
enabled, added in commit
3ccd3b4c384e98703841b12f7309362957f8f17d ("package/pipewire: bump to
version 0.3.32") is obviously incorrect, and can never be true.

Fix the condition to use the correct variable instead.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/pipewire/pipewire.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Jan. 13, 2024, 9:08 p.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni via buildroot <buildroot@buildroot.org> writes:

 > The condition checking whether the webrtc-audio-processing package is
 > enabled, added in commit
 > 3ccd3b4c384e98703841b12f7309362957f8f17d ("package/pipewire: bump to
 > version 0.3.32") is obviously incorrect, and can never be true.

 > Fix the condition to use the correct variable instead.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed, thanks.
Peter Korsgaard Jan. 14, 2024, 4:39 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni via buildroot <buildroot@buildroot.org> writes:

 > The condition checking whether the webrtc-audio-processing package is
 > enabled, added in commit
 > 3ccd3b4c384e98703841b12f7309362957f8f17d ("package/pipewire: bump to
 > version 0.3.32") is obviously incorrect, and can never be true.

 > Fix the condition to use the correct variable instead.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed to 2023.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/pipewire/pipewire.mk b/package/pipewire/pipewire.mk
index 628c69ff8a..f0f3cd847c 100644
--- a/package/pipewire/pipewire.mk
+++ b/package/pipewire/pipewire.mk
@@ -225,7 +225,7 @@  else
 PIPEWIRE_CONF_OPTS += -Dcompress-offload=disabled
 endif
 
-ifeq ($(WEBRTC_AUDIO_PROCESSING),y)
+ifeq ($(BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING),y)
 PIPEWIRE_CONF_OPTS += -Decho-cancel-webrtc=enabled
 PIPEWIRE_DEPENDENCIES += webrtc-audio-processing
 else