@@ -2289,11 +2289,9 @@ menu "Networking applications"
source "package/alfred/Config.in"
source "package/aoetools/Config.in"
source "package/apache/Config.in"
-if BR2_PACKAGE_APACHE
menu "External Apache modules"
source "package/modsecurity2/Config.in"
endmenu
-endif
source "package/argus/Config.in"
source "package/arp-scan/Config.in"
source "package/arptables/Config.in"
@@ -17,6 +17,14 @@ config BR2_PACKAGE_APACHE
if BR2_PACKAGE_APACHE
+config BR2_PACKAGE_APACHE_DAEMON
+ bool "apache-daemon"
+ default y
+ help
+ Provide entire Apache daemon, otherwise only htdigest and htpasswd
+ will be built and installed.
+
+if BR2_PACKAGE_APACHE_DAEMON
choice
prompt "Multi-Processing Module (MPM)"
default BR2_PACKAGE_APACHE_MPM_WORKER
@@ -40,6 +48,7 @@ config BR2_PACKAGE_APACHE_MPM_WORKER
Implements a hybrid multi-threaded multi-process web server
endchoice
+endif
endif
@@ -12,8 +12,6 @@ APACHE_LICENSE_FILES = LICENSE
APACHE_CPE_ID_VENDOR = apache
APACHE_CPE_ID_PRODUCT = http_server
APACHE_SELINUX_MODULES = apache
-# Needed for mod_php
-APACHE_INSTALL_STAGING = YES
# We have a patch touching configure.in and Makefile.in,
# so we need to autoreconf:
APACHE_AUTORECONF = YES
@@ -32,10 +30,16 @@ APACHE_MPM = worker
endif
APACHE_CONF_OPTS = \
- --sysconfdir=/etc/apache2 \
--with-apr=$(STAGING_DIR)/usr \
--with-apr-util=$(STAGING_DIR)/usr \
--with-pcre=$(STAGING_DIR)/usr/bin/pcre2-config \
+
+ifeq ($(BR2_PACKAGE_APACHE_DAEMON),y)
+# Needed for mod_php
+APACHE_INSTALL_STAGING = YES
+
+APACHE_CONF_OPTS += \
+ --sysconfdir=/etc/apache2 \
--enable-http \
--enable-dbd \
--enable-proxy \
@@ -121,5 +125,15 @@ define APACHE_INSTALL_INIT_SYSTEMD
$(INSTALL) -D -m 644 package/apache/apache.service \
$(TARGET_DIR)/usr/lib/systemd/system/apache.service
endef
+else
+define APACHE_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/support htdigest htpasswd
+endef
+
+define APACHE_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/support/htdigest $(TARGET_DIR)/usr/bin/htdigest
+ $(INSTALL) -m 0755 -D $(@D)/support/htpasswd $(TARGET_DIR)/usr/bin/htpasswd
+endef
+endif
$(eval $(autotools-package))
@@ -50,7 +50,7 @@ APPARMOR_DEPENDENCIES += linux-pam
APPARMOR_TOOLS += changehat/pam_apparmor
endif
-ifeq ($(BR2_PACKAGE_APACHE),y)
+ifeq ($(BR2_PACKAGE_APACHE_DAEMON),y)
APPARMOR_DEPENDENCIES += apache
APPARMOR_TOOLS += changehat/mod_apparmor
APPARMOR_MAKE_OPTS += APXS=$(STAGING_DIR)/usr/bin/apxs
@@ -1,6 +1,6 @@
config BR2_PACKAGE_MODSECURITY2
bool "modsecurity2"
- depends on BR2_PACKAGE_APACHE
+ depends on BR2_PACKAGE_APACHE_DAEMON
select BR2_PACKAGE_LIBXML2
select BR2_PACKAGE_PCRE2
help
@@ -36,7 +36,7 @@ if BR2_PACKAGE_PHP
config BR2_PACKAGE_PHP_SAPI_APACHE
bool "Apache interface"
- depends on BR2_PACKAGE_APACHE
+ depends on BR2_PACKAGE_APACHE_DAEMON
help
Apache module