diff mbox series

linux/linux.mk: fix commit d06dca38bb0373a13736a349f7795713458a2188 - remove extra bracket

Message ID 20230512110438.233473-1-br015@umbiko.net
State Accepted
Headers show
Series linux/linux.mk: fix commit d06dca38bb0373a13736a349f7795713458a2188 - remove extra bracket | expand

Commit Message

Andreas Ziegler May 12, 2023, 11:04 a.m. UTC
Commit d06dca38bb0373a13736a349f7795713458a2188 (linux: cleanup 
kconfig fixup processing) moved the initramfs setup out of an 
enclosing statement but kept the closing bracket. 

Remove the extra bracket to fix a syntax error in sed processing.

Fixes:
  >>> linux 6.4-rc1 Updating kernel config with fixups
  /bin/bash: -c: line 1: syntax error near unexpected token `)'
  /bin/bash: -c: line 1: `/usr/bin/sed -i -e '/^\(# \)\?CONFIG_INITRAMFS_ROOT_GID\>/d' /home/data/buildroot.experimental/build/linux-6.4-rc1//.config && echo 'CONFIG_INITRAMFS_ROOT_GID=0' >> /home/data/buildroot.experimental/build/linux-6.4-rc1//.config)'

Signed-off-by: Andreas Ziegler <br015@umbiko.net>
---
 linux/linux.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard May 12, 2023, 3:23 p.m. UTC | #1
>>>>> "Andreas" == Andreas Ziegler <br015@umbiko.net> writes:

 > Commit d06dca38bb0373a13736a349f7795713458a2188 (linux: cleanup 
 > kconfig fixup processing) moved the initramfs setup out of an 
 > enclosing statement but kept the closing bracket. 

 > Remove the extra bracket to fix a syntax error in sed processing.

 > Fixes:
 >>>> linux 6.4-rc1 Updating kernel config with fixups
 >   /bin/bash: -c: line 1: syntax error near unexpected token `)'
 >   /bin/bash: -c: line 1: `/usr/bin/sed -i -e '/^\(# \)\?CONFIG_INITRAMFS_ROOT_GID\>/d' /home/data/buildroot.experimental/build/linux-6.4-rc1//.config && echo 'CONFIG_INITRAMFS_ROOT_GID=0' >> /home/data/buildroot.experimental/build/linux-6.4-rc1//.config)'

 > Signed-off-by: Andreas Ziegler <br015@umbiko.net>

Committed, thanks.
diff mbox series

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index 7c941fa339..cc36b5251d 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -376,7 +376,7 @@  define LINUX_KCONFIG_FIXUP_CMDS_ROOTFS_CPIO
 	$(Q)touch $(BINARIES_DIR)/rootfs.cpio
 	$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,"$${BR_BINARIES_DIR}/rootfs.cpio")
 	$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_UID,0)
-	$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_GID,0))
+	$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_GID,0)
 endef
 endif