diff mbox series

package/mpd: update to version 0.23.12

Message ID 20230213092611.86858-1-br015@umbiko.net
State Accepted
Headers show
Series package/mpd: update to version 0.23.12 | expand

Commit Message

Andreas Ziegler Feb. 13, 2023, 9:26 a.m. UTC
List of changes:
	decoder::mad: fix integer underflow with very small files
	input::curl: require CURL 7.55.0 or later
	output::pipewire: adjust to PipeWire 0.3.64 API change
	tags:: fix crash bug due to race condition
	fix build failures with GCC 13

Change log:
	https://raw.githubusercontent.com/MusicPlayerDaemon/MPD/v0.23.12/NEWS

Commit:
	https://github.com/MusicPlayerDaemon/MPD/commit/b1422fb

Tested on:
	i386 (build)
	x86_64 (build, run)
	Aarch64 (build)

Signed-off-by: Andreas Ziegler <br015@umbiko.net>
---
 package/mpd/mpd.hash | 2 +-
 package/mpd/mpd.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Feb. 14, 2023, 5:12 p.m. UTC | #1
>>>>> "Andreas" == Andreas Ziegler <br015@umbiko.net> writes:

 > List of changes:
 > 	decoder::mad: fix integer underflow with very small files
 > 	input::curl: require CURL 7.55.0 or later
 > 	output::pipewire: adjust to PipeWire 0.3.64 API change
 > 	tags:: fix crash bug due to race condition
 > 	fix build failures with GCC 13

 > Change log:
 > 	https://raw.githubusercontent.com/MusicPlayerDaemon/MPD/v0.23.12/NEWS

 > Commit:
 > 	https://github.com/MusicPlayerDaemon/MPD/commit/b1422fb

 > Tested on:
 > 	i386 (build)
 > 	x86_64 (build, run)
 > 	Aarch64 (build)

 > Signed-off-by: Andreas Ziegler <br015@umbiko.net>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/mpd/mpd.hash b/package/mpd/mpd.hash
index 8c488d0357..2521238f64 100644
--- a/package/mpd/mpd.hash
+++ b/package/mpd/mpd.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated after checking pgp signature
-sha256  edb4e7a8f9dff238b5610f9e2461940ea98c727a5462fafb1cdf836304dfdca9  mpd-0.23.11.tar.xz
+sha256  b7fca62284ecc25a681ea6a07abc49200af5353be42cb5a31e3173be9d8702e7  mpd-0.23.12.tar.xz
 sha256  ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6  COPYING
diff --git a/package/mpd/mpd.mk b/package/mpd/mpd.mk
index 449600eda2..6c25c9b46f 100644
--- a/package/mpd/mpd.mk
+++ b/package/mpd/mpd.mk
@@ -5,7 +5,7 @@ 
 ################################################################################
 
 MPD_VERSION_MAJOR = 0.23
-MPD_VERSION = $(MPD_VERSION_MAJOR).11
+MPD_VERSION = $(MPD_VERSION_MAJOR).12
 MPD_SOURCE = mpd-$(MPD_VERSION).tar.xz
 MPD_SITE = https://www.musicpd.org/download/mpd/$(MPD_VERSION_MAJOR)
 MPD_DEPENDENCIES = host-pkgconf boost fmt