diff mbox series

[2/4] package/qemu: split long lines

Message ID 20221217153729.545952-2-romain.naour@gmail.com
State Accepted
Headers show
Series [1/4] package/slirp: add host variant for host-qemu | expand

Commit Message

Romain Naour Dec. 17, 2022, 3:37 p.m. UTC
Split the list of dependencies to ease further addition.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
 package/qemu/qemu.mk | 14 ++++++++++++--
 1 file changed, 12 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Dec. 28, 2022, 7:52 p.m. UTC | #1
Romain, All,

On 2022-12-17 16:37 +0100, Romain Naour spake thusly:
> Split the list of dependencies to ease further addition.
> 
> Signed-off-by: Romain Naour <romain.naour@gmail.com>
> ---
>  package/qemu/qemu.mk | 14 ++++++++++++--
>  1 file changed, 12 insertions(+), 2 deletions(-)
> 
> diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
> index a991d49993..e800f31e7e 100644
> --- a/package/qemu/qemu.mk
> +++ b/package/qemu/qemu.mk
> @@ -20,7 +20,12 @@ QEMU_CPE_ID_VENDOR = qemu
>  # However, building is still done with configure and make as in previous versions of QEMU.
>  
>  # Target-qemu
> -QEMU_DEPENDENCIES = host-meson host-pkgconf libglib2 zlib pixman host-python3
> +QEMU_DEPENDENCIES = host-meson \

I like that the first item is also on its own line, and this is what we
do elsewhere most of the time too, so I also changed that.

Applied to master, thanks.

Regards,
Yann E. MORIN.

> +	host-pkgconf \
> +	libglib2 \
> +	zlib \
> +	pixman \
> +	host-python3
>  
>  # Need the LIBS variable because librt and libm are
>  # not automatically pulled. :-(
> @@ -246,7 +251,12 @@ $(eval $(generic-package))
>  #-------------------------------------------------------------
>  # Host-qemu
>  
> -HOST_QEMU_DEPENDENCIES = host-meson host-pkgconf host-zlib host-libglib2 host-pixman host-python3
> +HOST_QEMU_DEPENDENCIES = host-meson \
> +	host-pkgconf \
> +	host-zlib \
> +	host-libglib2 \
> +	host-pixman \
> +	host-python3
>  
>  #       BR ARCH         qemu
>  #       -------         ----
> -- 
> 2.38.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index a991d49993..e800f31e7e 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -20,7 +20,12 @@  QEMU_CPE_ID_VENDOR = qemu
 # However, building is still done with configure and make as in previous versions of QEMU.
 
 # Target-qemu
-QEMU_DEPENDENCIES = host-meson host-pkgconf libglib2 zlib pixman host-python3
+QEMU_DEPENDENCIES = host-meson \
+	host-pkgconf \
+	libglib2 \
+	zlib \
+	pixman \
+	host-python3
 
 # Need the LIBS variable because librt and libm are
 # not automatically pulled. :-(
@@ -246,7 +251,12 @@  $(eval $(generic-package))
 #-------------------------------------------------------------
 # Host-qemu
 
-HOST_QEMU_DEPENDENCIES = host-meson host-pkgconf host-zlib host-libglib2 host-pixman host-python3
+HOST_QEMU_DEPENDENCIES = host-meson \
+	host-pkgconf \
+	host-zlib \
+	host-libglib2 \
+	host-pixman \
+	host-python3
 
 #       BR ARCH         qemu
 #       -------         ----