diff mbox series

[1/2] package/micropython: Bug fix release 1.19.1

Message ID 20221002004931.1805825-1-judge.packham@gmail.com
State Accepted
Headers show
Series [1/2] package/micropython: Bug fix release 1.19.1 | expand

Commit Message

Chris Packham Oct. 2, 2022, 12:49 a.m. UTC
This is a bug fix release.  The changes are:

- extmod/machine_i2c: only use WRITE1 option if transfer supports it

  This fixes the machine.SoftI2C.readfrom_mem() method on esp32, so it
  writes the address to read from.

Signed-off-by: Chris Packham <judge.packham@gmail.com>
---
 package/micropython/micropython.hash | 2 +-
 package/micropython/micropython.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Oct. 14, 2022, 2:11 p.m. UTC | #1
>>>>> "Chris" == Chris Packham <judge.packham@gmail.com> writes:

 > This is a bug fix release.  The changes are:
 > - extmod/machine_i2c: only use WRITE1 option if transfer supports it

 >   This fixes the machine.SoftI2C.readfrom_mem() method on esp32, so it
 >   writes the address to read from.

 > Signed-off-by: Chris Packham <judge.packham@gmail.com>

Committed, thanks.

Does this mean that it also needs to be backported to 2022.08.x? If this
is an esp32-only issue then presumably not?
Chris Packham Oct. 14, 2022, 9:17 p.m. UTC | #2
On Sat, 15 Oct 2022, 3:11 AM Peter Korsgaard, <peter@korsgaard.com> wrote:

> >>>>> "Chris" == Chris Packham <judge.packham@gmail.com> writes:
>
>  > This is a bug fix release.  The changes are:
>  > - extmod/machine_i2c: only use WRITE1 option if transfer supports it
>
>  >   This fixes the machine.SoftI2C.readfrom_mem() method on esp32, so it
>  >   writes the address to read from.
>
>  > Signed-off-by: Chris Packham <judge.packham@gmail.com>
>
> Committed, thanks.
>
> Does this mean that it also needs to be backported to 2022.08.x? If this
> is an esp32-only issue then presumably not?
>

No I don't think it needs to be backported.

>
>
> --
> Bye, Peter Korsgaard
>
diff mbox series

Patch

diff --git a/package/micropython/micropython.hash b/package/micropython/micropython.hash
index 09bc574ebc..7bff7de4e2 100644
--- a/package/micropython/micropython.hash
+++ b/package/micropython/micropython.hash
@@ -1,3 +1,3 @@ 
 #locally computed
-sha256  128b6fb13b518b4d3e75b4f0c04f175dc336c762d8c6360f647e91dc4d25e5d0  micropython-1.19.tar.gz
+sha256  c980ad7e742491df0dc10db2958137dbbf9aa7a8009e102fc75f4c0cac2d6b5e  micropython-1.19.1.tar.gz
 sha256  0f678c2abd7fe2cfca36693630506bbcbdfc219bd04bf4a02fe3b094ae4c666f  LICENSE
diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
index f7af9bfc32..51b45e5e99 100644
--- a/package/micropython/micropython.mk
+++ b/package/micropython/micropython.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-MICROPYTHON_VERSION = 1.19
+MICROPYTHON_VERSION = 1.19.1
 MICROPYTHON_SITE = $(call github,micropython,micropython,v$(MICROPYTHON_VERSION))
 # Micropython has a lot of code copied from other projects, and also a number
 # of submodules for various libs. However, we don't even clone the submodules,