diff mbox series

[v2] package/mbw: new package

Message ID 20220728112840.5143-1-guillaume.bressaix@gmail.com
State Accepted
Headers show
Series [v2] package/mbw: new package | expand

Commit Message

Guillaume Bres July 28, 2022, 11:28 a.m. UTC
Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
---
changes v1 -> v2
 - applied Romain's review
 - update mbw to v1.5 latest
 - update legal info
 - mbw is now a cmake package, simplifies installation process
---
 DEVELOPERS            |  1 +
 package/Config.in     |  1 +
 package/mbw/Config.in |  8 ++++++++
 package/mbw/mbw.hash  |  3 +++
 package/mbw/mbw.mk    | 12 ++++++++++++
 5 files changed, 25 insertions(+)
 create mode 100644 package/mbw/Config.in
 create mode 100644 package/mbw/mbw.hash
 create mode 100644 package/mbw/mbw.mk

Comments

Yann E. MORIN Aug. 3, 2022, 6:54 p.m. UTC | #1
Guillaume, All,

On 2022-07-28 13:28 +0200, Guillaume W. Bres spake thusly:
> Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> changes v1 -> v2
>  - applied Romain's review
>  - update mbw to v1.5 latest
>  - update legal info
>  - mbw is now a cmake package, simplifies installation process
> ---
>  DEVELOPERS            |  1 +
>  package/Config.in     |  1 +
>  package/mbw/Config.in |  8 ++++++++
>  package/mbw/mbw.hash  |  3 +++
>  package/mbw/mbw.mk    | 12 ++++++++++++
>  5 files changed, 25 insertions(+)
>  create mode 100644 package/mbw/Config.in
>  create mode 100644 package/mbw/mbw.hash
>  create mode 100644 package/mbw/mbw.mk
> 
> diff --git a/DEVELOPERS b/DEVELOPERS
> index cb98c38..754f8c5 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -1179,6 +1179,7 @@ N:	Guillaume William Brs <guillaume.bressaix@gmail.com>
>  F:	package/libnids/
>  F:	package/libxcrypt/
>  F:	package/liquid-dsp/
> +F:	package/mbw/
>  F:	package/pixiewps/
>  F:	package/python-pybind/
>  F:	package/reaver/
> diff --git a/package/Config.in b/package/Config.in
> index 4ff1fb2..fe68d32 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -122,6 +122,7 @@ menu "Debugging, profiling and benchmark"
>  	source "package/lttng-babeltrace/Config.in"
>  	source "package/lttng-modules/Config.in"
>  	source "package/lttng-tools/Config.in"
> +	source "package/mbw/Config.in"
>  	source "package/mcelog/Config.in"
>  	source "package/memstat/Config.in"
>  	source "package/netperf/Config.in"
> diff --git a/package/mbw/Config.in b/package/mbw/Config.in
> new file mode 100644
> index 0000000..e4f56c8
> --- /dev/null
> +++ b/package/mbw/Config.in
> @@ -0,0 +1,8 @@
> +config BR2_PACKAGE_MBW
> +	bool "mbw"
> +	help
> +	  MBW is a memory bandwidth benchmarking tool.
> +	  MBW determines the "copy" memory bandwidth available
> +	  to userspace programs.
> +
> +	  https://github.com/raas/mbw
> diff --git a/package/mbw/mbw.hash b/package/mbw/mbw.hash
> new file mode 100644
> index 0000000..74e3899
> --- /dev/null
> +++ b/package/mbw/mbw.hash
> @@ -0,0 +1,3 @@
> +# Locally computed
> +sha256  3c396ce09bb78c895e4d45e99b1ae07f80e3ea5eee59d78ed2048a7f2ae591ae  mbw-1.5.tar.gz
> +sha256  1afb2b8258506742238b9ceb8a865d7030c5889c56ba2911a0c0c042aa1335d1  mbw.spec
> diff --git a/package/mbw/mbw.mk b/package/mbw/mbw.mk
> new file mode 100644
> index 0000000..755a9f5
> --- /dev/null
> +++ b/package/mbw/mbw.mk
> @@ -0,0 +1,12 @@
> +################################################################################
> +#
> +# mbw
> +#
> +################################################################################
> +
> +MBW_VERSION = 1.5
> +MBW_SITE = $(call github,raas,mbw,v$(MBW_VERSION))
> +MBW_LICENSE = LGPL-2.1
> +MBW_LICENSE_FILES = mbw.spec
> +
> +$(eval $(cmake-package))
> -- 
> 1.8.3.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index cb98c38..754f8c5 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1179,6 +1179,7 @@  N:	Guillaume William Brs <guillaume.bressaix@gmail.com>
 F:	package/libnids/
 F:	package/libxcrypt/
 F:	package/liquid-dsp/
+F:	package/mbw/
 F:	package/pixiewps/
 F:	package/python-pybind/
 F:	package/reaver/
diff --git a/package/Config.in b/package/Config.in
index 4ff1fb2..fe68d32 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -122,6 +122,7 @@  menu "Debugging, profiling and benchmark"
 	source "package/lttng-babeltrace/Config.in"
 	source "package/lttng-modules/Config.in"
 	source "package/lttng-tools/Config.in"
+	source "package/mbw/Config.in"
 	source "package/mcelog/Config.in"
 	source "package/memstat/Config.in"
 	source "package/netperf/Config.in"
diff --git a/package/mbw/Config.in b/package/mbw/Config.in
new file mode 100644
index 0000000..e4f56c8
--- /dev/null
+++ b/package/mbw/Config.in
@@ -0,0 +1,8 @@ 
+config BR2_PACKAGE_MBW
+	bool "mbw"
+	help
+	  MBW is a memory bandwidth benchmarking tool.
+	  MBW determines the "copy" memory bandwidth available
+	  to userspace programs.
+
+	  https://github.com/raas/mbw
diff --git a/package/mbw/mbw.hash b/package/mbw/mbw.hash
new file mode 100644
index 0000000..74e3899
--- /dev/null
+++ b/package/mbw/mbw.hash
@@ -0,0 +1,3 @@ 
+# Locally computed
+sha256  3c396ce09bb78c895e4d45e99b1ae07f80e3ea5eee59d78ed2048a7f2ae591ae  mbw-1.5.tar.gz
+sha256  1afb2b8258506742238b9ceb8a865d7030c5889c56ba2911a0c0c042aa1335d1  mbw.spec
diff --git a/package/mbw/mbw.mk b/package/mbw/mbw.mk
new file mode 100644
index 0000000..755a9f5
--- /dev/null
+++ b/package/mbw/mbw.mk
@@ -0,0 +1,12 @@ 
+################################################################################
+#
+# mbw
+#
+################################################################################
+
+MBW_VERSION = 1.5
+MBW_SITE = $(call github,raas,mbw,v$(MBW_VERSION))
+MBW_LICENSE = LGPL-2.1
+MBW_LICENSE_FILES = mbw.spec
+
+$(eval $(cmake-package))