diff mbox series

[v2,1/1] package/mpd: add io_uring optional dependency

Message ID 20220725123002.2967-1-br015@umbiko.net
State Accepted
Headers show
Series [v2,1/1] package/mpd: add io_uring optional dependency | expand

Commit Message

Andreas Ziegler July 25, 2022, 12:30 p.m. UTC
Since version 0.22 mpd provides an option to use the io_uring kernel interface 
for asynchronous access to local files. Buildroot has the necessary library 
(package/liburing) since commit 03ca6f4e39874583060317e7e15e9e360220877e.

Add an optional dependency on liburing to enable asynchronous file access using 
the kernel io_uring interface.

Signed-off-by: Andreas Ziegler <br015@umbiko.net>
Reviewed-by: Romain Naour <romain.naour@smile.fr>
---
Changes v1 -> v2:
  Commit message (Romain Naour)
  Dependency comment (Romain Naour)
  Modify patch description to match commit message

 package/mpd/Config.in | 10 ++++++++++
 package/mpd/mpd.mk    |  7 +++++++
 2 files changed, 17 insertions(+)

Comments

Arnout Vandecappelle July 25, 2022, 10:22 p.m. UTC | #1
On 25/07/2022 14:30, Andreas Ziegler wrote:
> Since version 0.22 mpd provides an option to use the io_uring kernel interface
> for asynchronous access to local files. Buildroot has the necessary library
> (package/liburing) since commit 03ca6f4e39874583060317e7e15e9e360220877e.
> 
> Add an optional dependency on liburing to enable asynchronous file access using
> the kernel io_uring interface.
> 
> Signed-off-by: Andreas Ziegler <br015@umbiko.net>
> Reviewed-by: Romain Naour <romain.naour@smile.fr>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
> Changes v1 -> v2:
>    Commit message (Romain Naour)
>    Dependency comment (Romain Naour)
>    Modify patch description to match commit message
> 
>   package/mpd/Config.in | 10 ++++++++++
>   package/mpd/mpd.mk    |  7 +++++++
>   2 files changed, 17 insertions(+)
> 
> diff --git a/package/mpd/Config.in b/package/mpd/Config.in
> index fc0f409448..8f0af7b2d3 100644
> --- a/package/mpd/Config.in
> +++ b/package/mpd/Config.in
> @@ -347,6 +347,16 @@ config BR2_PACKAGE_MPD_AVAHI_SUPPORT
>   comment "avahi support needs a toolchain w/ dynamic library"
>   	depends on BR2_STATIC_LIBS
>   
> +config BR2_PACKAGE_MPD_IO_URING
> +	bool "io_uring"
> +	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_1
> +	select BR2_PACKAGE_LIBURING
> +	help
> +	  Asynchronous I/O using kernel io_uring subsystem
> +
> +comment "io_uring support needs a toolchain w/ headers >= 5.1"
> +	depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_1
> +
>   config BR2_PACKAGE_MPD_LIBMPDCLIENT
>   	bool "libmpdclient"
>   	select BR2_PACKAGE_LIBMPDCLIENT
> diff --git a/package/mpd/mpd.mk b/package/mpd/mpd.mk
> index e265a9fc4f..c21426b873 100644
> --- a/package/mpd/mpd.mk
> +++ b/package/mpd/mpd.mk
> @@ -119,6 +119,13 @@ else
>   MPD_CONF_OPTS += -Did3tag=disabled
>   endif
>   
> +ifeq ($(BR2_PACKAGE_MPD_IO_URING),y)
> +MPD_DEPENDENCIES += liburing
> +MPD_CONF_OPTS += -Dio_uring=enabled
> +else
> +MPD_CONF_OPTS += -Dio_uring=disabled
> +endif
> +
>   ifeq ($(BR2_PACKAGE_MPD_JACK2),y)
>   MPD_DEPENDENCIES += jack2
>   MPD_CONF_OPTS += -Djack=enabled
diff mbox series

Patch

diff --git a/package/mpd/Config.in b/package/mpd/Config.in
index fc0f409448..8f0af7b2d3 100644
--- a/package/mpd/Config.in
+++ b/package/mpd/Config.in
@@ -347,6 +347,16 @@  config BR2_PACKAGE_MPD_AVAHI_SUPPORT
 comment "avahi support needs a toolchain w/ dynamic library"
 	depends on BR2_STATIC_LIBS
 
+config BR2_PACKAGE_MPD_IO_URING
+	bool "io_uring"
+	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_1
+	select BR2_PACKAGE_LIBURING
+	help
+	  Asynchronous I/O using kernel io_uring subsystem
+
+comment "io_uring support needs a toolchain w/ headers >= 5.1"
+	depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_1
+
 config BR2_PACKAGE_MPD_LIBMPDCLIENT
 	bool "libmpdclient"
 	select BR2_PACKAGE_LIBMPDCLIENT
diff --git a/package/mpd/mpd.mk b/package/mpd/mpd.mk
index e265a9fc4f..c21426b873 100644
--- a/package/mpd/mpd.mk
+++ b/package/mpd/mpd.mk
@@ -119,6 +119,13 @@  else
 MPD_CONF_OPTS += -Did3tag=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_IO_URING),y)
+MPD_DEPENDENCIES += liburing
+MPD_CONF_OPTS += -Dio_uring=enabled
+else
+MPD_CONF_OPTS += -Dio_uring=disabled
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_JACK2),y)
 MPD_DEPENDENCIES += jack2
 MPD_CONF_OPTS += -Djack=enabled