diff mbox series

[3/3] board/kontron/pitx-imx8m: add U-Boot 2022.04 patch

Message ID 20220719190051.555180-3-heiko.thiery@gmail.com
State Accepted
Headers show
Series [1/3] boot/uboot: add BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX option | expand

Commit Message

Heiko Thiery July 19, 2022, 7 p.m. UTC
The patch is required to fix an issue in U-Boot for linking
the mkeficapsule tool against -luuid and -lgnutls.

Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/2720001065

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 ...le-use-pkg-config-to-get-luuid-and-l.patch | 33 +++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 board/kontron/pitx-imx8m/patches/uboot/2022.04/0001-tools-mkeficapsule-use-pkg-config-to-get-luuid-and-l.patch

Comments

Yann E. MORIN July 19, 2022, 9:15 p.m. UTC | #1
Heiko, All,

On 2022-07-19 21:00 +0200, Heiko Thiery spake thusly:
> The patch is required to fix an issue in U-Boot for linking
> the mkeficapsule tool against -luuid and -lgnutls.
> 
> Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/2720001065
> 
> Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
> ---
>  ...le-use-pkg-config-to-get-luuid-and-l.patch | 33 +++++++++++++++++++
>  1 file changed, 33 insertions(+)
>  create mode 100644 board/kontron/pitx-imx8m/patches/uboot/2022.04/0001-tools-mkeficapsule-use-pkg-config-to-get-luuid-and-l.patch

So, you added that patch just for your one board that needs
mkeficapsule. At first, I was thinking that it should be a
generic (but still version-specific) patch, because the
corresponding options, BR2_TARGET_UBOOT_NEEDS_GNUTLS and
BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX, are generic. So I was
about to move to boot/uboot/2022.04/

But then I just noticed I forgot to do so before I pushed,
and I will not try to retroactively justify not doing so.

So, instead, I'll sleepily wait for your justification that
this indeed should not be made generic, or a follow-up patch
that moves it. ;-)

Sorry for the mishap...

Regards,
Yann E. MORIN.

> diff --git a/board/kontron/pitx-imx8m/patches/uboot/2022.04/0001-tools-mkeficapsule-use-pkg-config-to-get-luuid-and-l.patch b/board/kontron/pitx-imx8m/patches/uboot/2022.04/0001-tools-mkeficapsule-use-pkg-config-to-get-luuid-and-l.patch
> new file mode 100644
> index 0000000000..9530a45efe
> --- /dev/null
> +++ b/board/kontron/pitx-imx8m/patches/uboot/2022.04/0001-tools-mkeficapsule-use-pkg-config-to-get-luuid-and-l.patch
> @@ -0,0 +1,33 @@
> +From f3523977e8f5f6b2173708777001332431ebc609 Mon Sep 17 00:00:00 2001
> +From: Heiko Thiery <heiko.thiery@gmail.com>
> +Date: Tue, 19 Jul 2022 16:17:09 +0200
> +Subject: [PATCH 1/2] tools: mkeficapsule: use pkg-config to get -luuid and -lgnutls
> +
> +Instead of hardcoding -luuid -lgnutls as the flags needed to build
> +mkeficapsule, use pkg-config when available.
> +
> +We gracefully fallback on the previous behavior of hardcoding -luuid
> +-lgnutls if pkg-config is not available or fails with an error.
> +
> +Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
> +---
> + tools/Makefile | 3 ++-
> + 1 file changed, 2 insertions(+), 1 deletion(-)
> +
> +diff --git a/tools/Makefile b/tools/Makefile
> +index 9f2339666a..9f6b282ad8 100644
> +--- a/tools/Makefile
> ++++ b/tools/Makefile
> +@@ -242,7 +242,8 @@ hostprogs-$(CONFIG_MIPS) += mips-relocs
> + hostprogs-$(CONFIG_ASN1_COMPILER)	+= asn1_compiler
> + HOSTCFLAGS_asn1_compiler.o = -idirafter $(srctree)/include
> + 
> +-HOSTLDLIBS_mkeficapsule += -lgnutls -luuid
> ++HOSTLDLIBS_mkeficapsule += \
> ++	$(shell pkg-config --libs gnutls uuid 2> /dev/null || echo "-lgnutls -luuid")
> + hostprogs-$(CONFIG_TOOLS_MKEFICAPSULE) += mkeficapsule
> + 
> + # We build some files with extra pedantic flags to try to minimize things
> +-- 
> +2.30.2
> +
> -- 
> 2.30.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/board/kontron/pitx-imx8m/patches/uboot/2022.04/0001-tools-mkeficapsule-use-pkg-config-to-get-luuid-and-l.patch b/board/kontron/pitx-imx8m/patches/uboot/2022.04/0001-tools-mkeficapsule-use-pkg-config-to-get-luuid-and-l.patch
new file mode 100644
index 0000000000..9530a45efe
--- /dev/null
+++ b/board/kontron/pitx-imx8m/patches/uboot/2022.04/0001-tools-mkeficapsule-use-pkg-config-to-get-luuid-and-l.patch
@@ -0,0 +1,33 @@ 
+From f3523977e8f5f6b2173708777001332431ebc609 Mon Sep 17 00:00:00 2001
+From: Heiko Thiery <heiko.thiery@gmail.com>
+Date: Tue, 19 Jul 2022 16:17:09 +0200
+Subject: [PATCH 1/2] tools: mkeficapsule: use pkg-config to get -luuid and -lgnutls
+
+Instead of hardcoding -luuid -lgnutls as the flags needed to build
+mkeficapsule, use pkg-config when available.
+
+We gracefully fallback on the previous behavior of hardcoding -luuid
+-lgnutls if pkg-config is not available or fails with an error.
+
+Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
+---
+ tools/Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tools/Makefile b/tools/Makefile
+index 9f2339666a..9f6b282ad8 100644
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -242,7 +242,8 @@ hostprogs-$(CONFIG_MIPS) += mips-relocs
+ hostprogs-$(CONFIG_ASN1_COMPILER)	+= asn1_compiler
+ HOSTCFLAGS_asn1_compiler.o = -idirafter $(srctree)/include
+ 
+-HOSTLDLIBS_mkeficapsule += -lgnutls -luuid
++HOSTLDLIBS_mkeficapsule += \
++	$(shell pkg-config --libs gnutls uuid 2> /dev/null || echo "-lgnutls -luuid")
+ hostprogs-$(CONFIG_TOOLS_MKEFICAPSULE) += mkeficapsule
+ 
+ # We build some files with extra pedantic flags to try to minimize things
+-- 
+2.30.2
+