diff mbox series

[1/2] package/python-orjson: bump version to 3.6.8.

Message ID 20220509190650.1348657-1-gsmecher@threespeedlogic.com
State Superseded
Headers show
Series [1/2] package/python-orjson: bump version to 3.6.8. | expand

Commit Message

Graeme Smecher May 9, 2022, 7:06 p.m. UTC
Signed-off-by: Graeme Smecher <gsmecher@threespeedlogic.com>
---
 package/python-orjson/python-orjson.hash | 2 +-
 package/python-orjson/python-orjson.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

James Hilliard May 9, 2022, 10:14 p.m. UTC | #1
On Mon, May 9, 2022 at 1:07 PM Graeme Smecher
<gsmecher@threespeedlogic.com> wrote:
>
> Signed-off-by: Graeme Smecher <gsmecher@threespeedlogic.com>
> ---
>  package/python-orjson/python-orjson.hash | 2 +-
>  package/python-orjson/python-orjson.mk   | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/python-orjson/python-orjson.hash b/package/python-orjson/python-orjson.hash
> index 5ef2726d82..2c00164702 100644
> --- a/package/python-orjson/python-orjson.hash
> +++ b/package/python-orjson/python-orjson.hash
> @@ -1,4 +1,4 @@
>  # Locally calculated
> -sha256  4713b120ad86b1b273f5952cbf9578c13d0f453064bd26d823e04a10c84824e6  python-orjson-3.6.7.tar.gz
> +sha256  2b0259ff26455c4f9ad2290b49ba184a35e98eea4839f0d6d5c2b7d91383b3d9  python-orjson-3.6.8.tar.gz
>  sha256  a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2  LICENSE-APACHE
>  sha256  23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3  LICENSE-MIT
> diff --git a/package/python-orjson/python-orjson.mk b/package/python-orjson/python-orjson.mk
> index 5de4b2c5fa..cfcaedc280 100644
> --- a/package/python-orjson/python-orjson.mk
> +++ b/package/python-orjson/python-orjson.mk
> @@ -4,7 +4,7 @@
>  #
>  ################################################################################
>
> -PYTHON_ORJSON_VERSION = 3.6.7
> +PYTHON_ORJSON_VERSION = 3.6.8
>  PYTHON_ORJSON_SITE = $(call github,ijl,orjson,$(PYTHON_ORJSON_VERSION))

This package should be using the python package infrastructure instead of cargo,
I went ahead and converted it here:
https://patchwork.ozlabs.org/project/buildroot/patch/20220509221055.335263-2-james.hilliard1@gmail.com/

I just needed to add the maturin pep517 backend here:
https://patchwork.ozlabs.org/project/buildroot/patch/20220509221055.335263-1-james.hilliard1@gmail.com/

>  PYTHON_ORJSON_LICENSE = Apache-2.0 or MIT
>  PYTHON_ORJSON_LICENSE_FILES = LICENSE-APACHE LICENSE-MIT
> --
> 2.35.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Thomas Petazzoni July 24, 2022, 7:40 a.m. UTC | #2
On Mon,  9 May 2022 12:06:49 -0700
Graeme Smecher <gsmecher@threespeedlogic.com> wrote:

> Signed-off-by: Graeme Smecher <gsmecher@threespeedlogic.com>
> ---
>  package/python-orjson/python-orjson.hash | 2 +-
>  package/python-orjson/python-orjson.mk   | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/python-orjson/python-orjson.hash b/package/python-orjson/python-orjson.hash
index 5ef2726d82..2c00164702 100644
--- a/package/python-orjson/python-orjson.hash
+++ b/package/python-orjson/python-orjson.hash
@@ -1,4 +1,4 @@ 
 # Locally calculated
-sha256  4713b120ad86b1b273f5952cbf9578c13d0f453064bd26d823e04a10c84824e6  python-orjson-3.6.7.tar.gz
+sha256  2b0259ff26455c4f9ad2290b49ba184a35e98eea4839f0d6d5c2b7d91383b3d9  python-orjson-3.6.8.tar.gz
 sha256  a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2  LICENSE-APACHE
 sha256  23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3  LICENSE-MIT
diff --git a/package/python-orjson/python-orjson.mk b/package/python-orjson/python-orjson.mk
index 5de4b2c5fa..cfcaedc280 100644
--- a/package/python-orjson/python-orjson.mk
+++ b/package/python-orjson/python-orjson.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-PYTHON_ORJSON_VERSION = 3.6.7
+PYTHON_ORJSON_VERSION = 3.6.8
 PYTHON_ORJSON_SITE = $(call github,ijl,orjson,$(PYTHON_ORJSON_VERSION))
 PYTHON_ORJSON_LICENSE = Apache-2.0 or MIT
 PYTHON_ORJSON_LICENSE_FILES = LICENSE-APACHE LICENSE-MIT