diff mbox series

[1/1] package/redis: bump to v7.0.0

Message ID 20220502101208.1576497-1-titouanchristophe@gmail.com
State Accepted
Headers show
Series [1/1] package/redis: bump to v7.0.0 | expand

Commit Message

Titouan Christophe May 2, 2022, 10:12 a.m. UTC
From the release notes:
(See https://github.com/redis/redis/blob/7.0.0/00-RELEASENOTES)

Introduction to the Redis 7.0 release
=====================================

Redis 7.0 includes several new user-facing features, significant performance
optimizations, and many other improvements. It also includes changes that
potentially break backwards compatibility with older versions. We urge users to
review the release notes carefully before upgrading.

In particular, users should be aware of the following changes:

1. Redis 7 stores AOF as multiple files in a folder; see Multi-Part AOF below.
2. Redis 7 uses a new version 10 format for RDB files, which is incompatible
   with older versions.
3. Redis 7 converts ziplist encoded keys to listpacks on the fly when loading
   an older RDB format. Conversion applies to loading a file from disk or
   replicating from a Redis master and will slightly increase loading time.

Signed-off-by: Titouan Christophe <titouanchristophe@gmail.com>
---
 package/redis/redis.hash | 2 +-
 package/redis/redis.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Arnout Vandecappelle May 2, 2022, 9:55 p.m. UTC | #1
On 02/05/2022 12:12, Titouan Christophe wrote:
>  From the release notes:
> (See https://github.com/redis/redis/blob/7.0.0/00-RELEASENOTES)
> 
> Introduction to the Redis 7.0 release
> =====================================
> 
> Redis 7.0 includes several new user-facing features, significant performance
> optimizations, and many other improvements. It also includes changes that
> potentially break backwards compatibility with older versions. We urge users to
> review the release notes carefully before upgrading.
> 
> In particular, users should be aware of the following changes:
> 
> 1. Redis 7 stores AOF as multiple files in a folder; see Multi-Part AOF below.
> 2. Redis 7 uses a new version 10 format for RDB files, which is incompatible
>     with older versions.
> 3. Redis 7 converts ziplist encoded keys to listpacks on the fly when loading
>     an older RDB format. Conversion applies to loading a file from disk or
>     replicating from a Redis master and will slightly increase loading time.
> 
> Signed-off-by: Titouan Christophe <titouanchristophe@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/redis/redis.hash | 2 +-
>   package/redis/redis.mk   | 2 +-
>   2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/redis/redis.hash b/package/redis/redis.hash
> index 74a9392a63..582c3afa03 100644
> --- a/package/redis/redis.hash
> +++ b/package/redis/redis.hash
> @@ -1,5 +1,5 @@
>   # From https://github.com/redis/redis-hashes/blob/master/README
> -sha256  5b2b8b7a50111ef395bf1c1d5be11e6e167ac018125055daa8b5c2317ae131ab  redis-6.2.6.tar.gz
> +sha256  284d8bd1fd85d6a55a05ee4e7c31c31977ad56cbf344ed83790beeb148baa720  redis-7.0.0.tar.gz
>   
>   # Locally calculated
>   sha256  97f0a15b7bbae580d2609dad2e11f1956ae167be296ab60f4691ab9c30ee9828  COPYING
> diff --git a/package/redis/redis.mk b/package/redis/redis.mk
> index f3c030d68c..3b91fbf8c8 100644
> --- a/package/redis/redis.mk
> +++ b/package/redis/redis.mk
> @@ -4,7 +4,7 @@
>   #
>   ################################################################################
>   
> -REDIS_VERSION = 6.2.6
> +REDIS_VERSION = 7.0.0
>   REDIS_SITE = http://download.redis.io/releases
>   REDIS_LICENSE = BSD-3-Clause (core); MIT and BSD family licenses (Bundled components)
>   REDIS_LICENSE_FILES = COPYING
diff mbox series

Patch

diff --git a/package/redis/redis.hash b/package/redis/redis.hash
index 74a9392a63..582c3afa03 100644
--- a/package/redis/redis.hash
+++ b/package/redis/redis.hash
@@ -1,5 +1,5 @@ 
 # From https://github.com/redis/redis-hashes/blob/master/README
-sha256  5b2b8b7a50111ef395bf1c1d5be11e6e167ac018125055daa8b5c2317ae131ab  redis-6.2.6.tar.gz
+sha256  284d8bd1fd85d6a55a05ee4e7c31c31977ad56cbf344ed83790beeb148baa720  redis-7.0.0.tar.gz
 
 # Locally calculated
 sha256  97f0a15b7bbae580d2609dad2e11f1956ae167be296ab60f4691ab9c30ee9828  COPYING
diff --git a/package/redis/redis.mk b/package/redis/redis.mk
index f3c030d68c..3b91fbf8c8 100644
--- a/package/redis/redis.mk
+++ b/package/redis/redis.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-REDIS_VERSION = 6.2.6
+REDIS_VERSION = 7.0.0
 REDIS_SITE = http://download.redis.io/releases
 REDIS_LICENSE = BSD-3-Clause (core); MIT and BSD family licenses (Bundled components)
 REDIS_LICENSE_FILES = COPYING