diff mbox series

[PATCH/next,2/2] package/gnuradio: fix host python name

Message ID 20211129165001.363636-2-gwenj@trabucayre.com
State Accepted
Headers show
Series [PATCH/next,1/2] package/gnuradio: force python3-six | expand

Commit Message

Gwenhael Goavec-Merou Nov. 29, 2021, 4:50 p.m. UTC
From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>

$(HOST_DIR)/bin/python symlink is only created when BR2_PACKAGE_PYTHON3 is
set.
When only host-python3 is used this symlink is not present and build fails
with:

-- User set python executable buildroot/output/host/bin/python
-- Found PythonInterp: buildroot/output/host/bin/python (Required is at least version "2.7.6")
CMake Error at cmake/Modules/GrPython.cmake:40 (if):
  if given arguments:

    "VERSION_EQUAL" "3"

  Unknown arguments specified
Call Stack (most recent call first):
  CMakeLists.txt:368 (include)


-- Configuring incomplete, errors occurred!

This patch set explicitly PYTHON_EXECUTABLE to $(HOST_DIR)/bin/python3

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
 package/gnuradio/gnuradio.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/gnuradio/gnuradio.mk b/package/gnuradio/gnuradio.mk
index 5616039559..658357398d 100644
--- a/package/gnuradio/gnuradio.mk
+++ b/package/gnuradio/gnuradio.mk
@@ -29,7 +29,7 @@  GNURADIO_DEPENDENCIES = \
 	gmp
 
 GNURADIO_CONF_OPTS = \
-	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python \
+	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3 \
 	-DENABLE_DEFAULT=OFF \
 	-DENABLE_VOLK=ON \
 	-DENABLE_GNURADIO_RUNTIME=ON \