diff mbox series

[1/1] package/libubootenv: bump to version 7dbfffa

Message ID 20211102212801.174162-1-texier.pj2@gmail.com
State Accepted
Headers show
Series [1/1] package/libubootenv: bump to version 7dbfffa | expand

Commit Message

Pierre-Jean Texier Nov. 2, 2021, 9:28 p.m. UTC
This includes the following changes:

7dbfffa Fix parsing multiple .flags variables
de31f3d Add REUSE badge
6390c1c Make libubootenv REUSE compliant
0573071 doxygen: fix libuboot_open/close return value description
0d12468 Add documentation for the configuration file
b1178c1 Add configuration for disabling MTD lock
5dadcb3 main: Remove duplicated code about '=' in variable name.
e085e37 libubootenv: Forbid to give empty variable name to fw_setenv.
42f919e main: Check libuboot_set_env() result.
1bc91d1 CI: add gitlab config

License update details: see commit 6390c1c ("Make libubootenv REUSE
compliant") in [0]

[0] - https://github.com/sbabic/libubootenv/commit/6390c1c26a816a96c9a72588679df3b9445dc192

Signed-off-by: Pierre-Jean Texier <texier.pj2@gmail.com>
---
 package/libubootenv/libubootenv.hash |  6 ++++--
 package/libubootenv/libubootenv.mk   | 11 +++++++----
 2 files changed, 11 insertions(+), 6 deletions(-)

Comments

Thomas Petazzoni Nov. 3, 2021, 5:52 p.m. UTC | #1
On Tue,  2 Nov 2021 22:28:01 +0100
Pierre-Jean Texier <texier.pj2@gmail.com> wrote:

> This includes the following changes:
> 
> 7dbfffa Fix parsing multiple .flags variables
> de31f3d Add REUSE badge
> 6390c1c Make libubootenv REUSE compliant
> 0573071 doxygen: fix libuboot_open/close return value description
> 0d12468 Add documentation for the configuration file
> b1178c1 Add configuration for disabling MTD lock
> 5dadcb3 main: Remove duplicated code about '=' in variable name.
> e085e37 libubootenv: Forbid to give empty variable name to fw_setenv.
> 42f919e main: Check libuboot_set_env() result.
> 1bc91d1 CI: add gitlab config
> 
> License update details: see commit 6390c1c ("Make libubootenv REUSE
> compliant") in [0]
> 
> [0] - https://github.com/sbabic/libubootenv/commit/6390c1c26a816a96c9a72588679df3b9445dc192
> 
> Signed-off-by: Pierre-Jean Texier <texier.pj2@gmail.com>
> ---
>  package/libubootenv/libubootenv.hash |  6 ++++--
>  package/libubootenv/libubootenv.mk   | 11 +++++++----
>  2 files changed, 11 insertions(+), 6 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/libubootenv/libubootenv.hash b/package/libubootenv/libubootenv.hash
index d6de614612..5ff7450806 100644
--- a/package/libubootenv/libubootenv.hash
+++ b/package/libubootenv/libubootenv.hash
@@ -1,3 +1,5 @@ 
 # Locally calculated
-sha256  662ef1efe058e2d5a07498f7b63aff7b2a521c0f6f199c499fb3ae84b54121bd  libubootenv-0.3.2.tar.gz
-sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  Licenses/lgpl-2.1.txt
+sha256  760fe53ca20ced93a09dea0f123eb429c820b565c103920afa738873e8cd16b7  libubootenv-7dbfffa4cc0e42ad3febb122a711fe9d1b20e9f7.tar.gz
+sha256  0558101984550fa84d1d13c2af11d116c20079d2be58711e8d99cadce7009192  LICENSES/CC0-1.0.txt
+sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  LICENSES/LGPL-2.1-or-later.txt
+sha256  89807acf2309bd285f033404ee78581602f3cd9b819a16ac2f0e5f60ff4a473e  LICENSES/MIT.txt
diff --git a/package/libubootenv/libubootenv.mk b/package/libubootenv/libubootenv.mk
index 295226b9aa..51ea02e678 100644
--- a/package/libubootenv/libubootenv.mk
+++ b/package/libubootenv/libubootenv.mk
@@ -4,10 +4,13 @@ 
 #
 ################################################################################
 
-LIBUBOOTENV_VERSION = 0.3.2
-LIBUBOOTENV_SITE = $(call github,sbabic,libubootenv,v$(LIBUBOOTENV_VERSION))
-LIBUBOOTENV_LICENSE = LGPL-2.1
-LIBUBOOTENV_LICENSE_FILES = Licenses/lgpl-2.1.txt
+LIBUBOOTENV_VERSION = 7dbfffa4cc0e42ad3febb122a711fe9d1b20e9f7
+LIBUBOOTENV_SITE = $(call github,sbabic,libubootenv,$(LIBUBOOTENV_VERSION))
+LIBUBOOTENV_LICENSE = LGPL-2.1+, MIT, CC0-1.0
+LIBUBOOTENV_LICENSE_FILES = LICENSES/CC0-1.0.txt \
+	LICENSES/LGPL-2.1-or-later.txt \
+	LICENSES/MIT.txt
+
 LIBUBOOTENV_INSTALL_STAGING = YES
 LIBUBOOTENV_DEPENDENCIES = zlib