diff mbox series

package/eigen: override Fortran path

Message ID 20210819142558.10417-1-matthew.weber@collins.com
State Accepted
Headers show
Series package/eigen: override Fortran path | expand

Commit Message

Matthew Weber Aug. 19, 2021, 2:25 p.m. UTC
The language detection is falling back to the host system
Fortran compiler. An example of this is in RHEL7.9
(gcc4.8.5 20150623 (Red Hat 4.8.5-44)).

This patch bypasses detection and points to the location
where the compiler would be installed (if present). In the
cases where it doesn't exist, the detection falls through
and leaves Fortran disabled.

Fixes:
http://autobuild.buildroot.net/results/8354da225d1e5e337aa7ea62a7e6524fb5f1135f/

Signed-off-by: Matthew Weber <matthew.weber@collins.com>
---
 package/eigen/eigen.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 19, 2021, 8:39 p.m. UTC | #1
On Thu, 19 Aug 2021 09:25:58 -0500
Matthew Weber via buildroot <buildroot@busybox.net> wrote:

> The language detection is falling back to the host system
> Fortran compiler. An example of this is in RHEL7.9
> (gcc4.8.5 20150623 (Red Hat 4.8.5-44)).
> 
> This patch bypasses detection and points to the location
> where the compiler would be installed (if present). In the
> cases where it doesn't exist, the detection falls through
> and leaves Fortran disabled.
> 
> Fixes:
> http://autobuild.buildroot.net/results/8354da225d1e5e337aa7ea62a7e6524fb5f1135f/
> 
> Signed-off-by: Matthew Weber <matthew.weber@collins.com>

Thanks for looking into this!

>  # Default Eigen CMake installs .pc file in /usr/share/pkgconfig
>  # change it to /usr/lib/pkgconfig, to be consistent with other packages.
> -EIGEN_CONF_OPTS = -DPKGCONFIG_INSTALL_DIR=/usr/lib/pkgconfig
> +EIGEN_CONF_OPTS = -DPKGCONFIG_INSTALL_DIR=/usr/lib/pkgconfig \
> +	-DCMAKE_Fortran_COMPILER=${TARGET_FC}

We use $(...) to reference make variables, not ${...}. This is reported
by "make check-package". I fixed that and applied to master. Thanks!

Thomas
Peter Korsgaard Sept. 6, 2021, 12:26 p.m. UTC | #2
>>>>> "Matthew" == Matthew Weber via buildroot <buildroot@busybox.net> writes:

 > The language detection is falling back to the host system
 > Fortran compiler. An example of this is in RHEL7.9
 > (gcc4.8.5 20150623 (Red Hat 4.8.5-44)).

 > This patch bypasses detection and points to the location
 > where the compiler would be installed (if present). In the
 > cases where it doesn't exist, the detection falls through
 > and leaves Fortran disabled.

 > Fixes:
 > http://autobuild.buildroot.net/results/8354da225d1e5e337aa7ea62a7e6524fb5f1135f/

 > Signed-off-by: Matthew Weber <matthew.weber@collins.com>

Committed to 2021.02.x and 2021.05.x, thanks.
diff mbox series

Patch

diff --git a/package/eigen/eigen.mk b/package/eigen/eigen.mk
index c9998da357..5c726c9d71 100644
--- a/package/eigen/eigen.mk
+++ b/package/eigen/eigen.mk
@@ -15,6 +15,7 @@  EIGEN_SUPPORTS_IN_SOURCE_BUILD = NO
 
 # Default Eigen CMake installs .pc file in /usr/share/pkgconfig
 # change it to /usr/lib/pkgconfig, to be consistent with other packages.
-EIGEN_CONF_OPTS = -DPKGCONFIG_INSTALL_DIR=/usr/lib/pkgconfig
+EIGEN_CONF_OPTS = -DPKGCONFIG_INSTALL_DIR=/usr/lib/pkgconfig \
+	-DCMAKE_Fortran_COMPILER=${TARGET_FC}
 
 $(eval $(cmake-package))