diff mbox series

[1/1] package/systemd: disable zstd for host-systemd

Message ID 20200904152633.198288-1-titouan.christophe@railnova.eu
State Accepted
Headers show
Series [1/1] package/systemd: disable zstd for host-systemd | expand

Commit Message

Titouan Christophe Sept. 4, 2020, 3:26 p.m. UTC
systemd 246 added support for zstd compression of large fields in
journal files [1]. Since zstd is only used at runtime, we don't
need it to enable its support in host-systemd.

[1] https://github.com/systemd/systemd/blob/v246/NEWS#L323-L331

Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
---
 package/systemd/systemd.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN Sept. 4, 2020, 8:15 p.m. UTC | #1
Titouan, All,

On 2020-09-04 17:26 +0200, Titouan Christophe spake thusly:
> systemd 246 added support for zstd compression of large fields in
> journal files [1]. Since zstd is only used at runtime, we don't
> need it to enable its support in host-systemd.
> 
> [1] https://github.com/systemd/systemd/blob/v246/NEWS#L323-L331
> 
> Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/systemd/systemd.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
> index c132f36663..d72cb58693 100644
> --- a/package/systemd/systemd.mk
> +++ b/package/systemd/systemd.mk
> @@ -700,7 +700,8 @@ HOST_SYSTEMD_CONF_OPTS = \
>  	-Dkernel-install=false \
>  	-Dsystemd-analyze=false \
>  	-Dlibcryptsetup=false \
> -	-Daudit=false
> +	-Daudit=false \
> +	-Dzstd=false
>  
>  HOST_SYSTEMD_DEPENDENCIES = \
>  	$(BR2_COREUTILS_HOST_DEPENDENCY) \
> -- 
> 2.25.3
>
Peter Korsgaard Sept. 5, 2020, 12:27 p.m. UTC | #2
>>>>> "Titouan" == Titouan Christophe <titouan.christophe@railnova.eu> writes:

 > systemd 246 added support for zstd compression of large fields in
 > journal files [1]. Since zstd is only used at runtime, we don't
 > need it to enable its support in host-systemd.

 > [1] https://github.com/systemd/systemd/blob/v246/NEWS#L323-L331

 > Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>

Committed to 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index c132f36663..d72cb58693 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -700,7 +700,8 @@  HOST_SYSTEMD_CONF_OPTS = \
 	-Dkernel-install=false \
 	-Dsystemd-analyze=false \
 	-Dlibcryptsetup=false \
-	-Daudit=false
+	-Daudit=false \
+	-Dzstd=false
 
 HOST_SYSTEMD_DEPENDENCIES = \
 	$(BR2_COREUTILS_HOST_DEPENDENCY) \