diff mbox series

[1/1] package/python-pip: add host-python-pip possibility

Message ID 20200609121702.19880-1-guillaume.bressaix@gmail.com
State Changes Requested
Headers show
Series [1/1] package/python-pip: add host-python-pip possibility | expand

Commit Message

Guillaume Bres June 9, 2020, 12:17 p.m. UTC
My next contribution requires host-python-pip
because 'import pip' is required in its setup.py
and so, must be present at build time.

This is a just a new option, compatible
with previous packages. Call it with
with 'PYTHON_FOO_DEPENCIES = host-python-pip'

Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
---
 package/python-pip/python-pip.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni June 10, 2020, 8:47 p.m. UTC | #1
On Tue,  9 Jun 2020 14:17:02 +0200
"Guillaume W. Bres" <guillaume.bressaix@gmail.com> wrote:

> My next contribution requires host-python-pip
> because 'import pip' is required in its setup.py
> and so, must be present at build time.
> 
> This is a just a new option, compatible
> with previous packages. Call it with
> with 'PYTHON_FOO_DEPENCIES = host-python-pip'
> 
> Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>

Could you preferably send this together with your next contribution, as
a patch series ? This way, we'll see how it fits with the rest of your
contribution.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/python-pip/python-pip.mk b/package/python-pip/python-pip.mk
index cc40eecdfe..0af41ab807 100644
--- a/package/python-pip/python-pip.mk
+++ b/package/python-pip/python-pip.mk
@@ -12,3 +12,4 @@  PYTHON_PIP_LICENSE = MIT
 PYTHON_PIP_LICENSE_FILES = LICENSE.txt
 
 $(eval $(python-package))
+$(eval $(host-python-package))